]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
- missing R for ecore-evas-devel package
[packages/ecore.git] / ecore.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     xcb             # XCB instead of Xlib (highly experimental)
5 #
6 Summary:        Enlightened Core X interface library
7 Summary(pl.UTF-8):      Biblioteka interfejsu X Enlightened Core
8 Name:           ecore
9 %define subver  beta3
10 Version:        1.0.0
11 Release:        0.%{subver}.1
12 License:        BSD
13 Group:          X11/Libraries
14 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
15 # Source0-md5:  34c13b29f675eaaea4b51b7b3963d7a1
16 URL:            http://enlightenment.org/p.php?p=about/libs/ecore
17 BuildRequires:  DirectFB-devel >= 0.9.16
18 BuildRequires:  SDL-devel >= 1.2.0
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  c-ares-devel
22 BuildRequires:  curl-devel
23 BuildRequires:  eina-devel >= 1.0.0
24 # for disabled config library
25 #BuildRequires: eet-devel >= 1.4.0
26 BuildRequires:  evas-devel >= %{version}
27 BuildRequires:  gettext-devel >= 0.12.1
28 BuildRequires:  glib2-devel >= 2.0
29 BuildRequires:  gnutls-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig >= 1:0.22
32 BuildRequires:  tslib-devel
33 %if %{with xcb}
34 BuildRequires:  libxcb-devel
35 BuildRequires:  xcb-util-devel
36 %else
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXScrnSaver-devel
39 BuildRequires:  xorg-lib-libXcomposite-devel
40 BuildRequires:  xorg-lib-libXcursor-devel
41 BuildRequires:  xorg-lib-libXdamage-devel
42 BuildRequires:  xorg-lib-libXext-devel
43 BuildRequires:  xorg-lib-libXfixes-devel
44 BuildRequires:  xorg-lib-libXi-devel
45 BuildRequires:  xorg-lib-libXinerama-devel
46 BuildRequires:  xorg-lib-libXp-devel
47 BuildRequires:  xorg-lib-libXrandr-devel
48 BuildRequires:  xorg-lib-libXrender-devel
49 BuildRequires:  xorg-lib-libXtst-devel
50 %endif
51 Requires:       eina >= 1.0.0
52 Obsoletes:      ecore-desktop
53 Obsoletes:      ecore-job
54 Obsoletes:      ecore-libs
55 Obsoletes:      ecore-txt
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %undefine       __cxx
59
60 %description
61 Ecore is the event/X abstraction layer that makes doing selections,
62 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
63 optimized, and convenient. It's a separate library so anyone can make
64 use of the work put into Ecore to make this job easy for applications.
65
66 %description -l pl.UTF-8
67 Ecore to warstwa abstrakcji zdarzeń/X, która powoduje, że dokonywanie
68 zaznaczeń, Xdnd, ogólne operacje X, pętle zdarzeń, obsługa timeoutów i
69 bezczynności są szybkie, zoptymalizowane i wygodne. Jest to wydzielona
70 biblioteka, więc każdy może skorzystać z pracy włożonej w Ecore do
71 ułatwienia swojej pracy przy aplikacjach.
72
73 %package devel
74 Summary:        Header files for Ecore library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ecore
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       eina-devel >= 1.0.0
79 Requires:       glib2-devel >= 2.0
80
81 %description devel
82 Header files for Ecore library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki Ecore.
86
87 %package static
88 Summary:        Static Ecore library
89 Summary(pl.UTF-8):      Statyczna biblioteka Ecore
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Ecore library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka Ecore.
98
99 %package con
100 Summary:        Ecore Con(nection) library
101 Summary(pl.UTF-8):      Biblioteka połączeń Ecore Con
102 Group:          Libraries
103 Requires:       %{name} = %{version}-%{release}
104
105 %description con
106 Ecore Con(nection) Library.
107
108 %description con -l pl.UTF-8
109 Biblioteka połączeń Ecore Con.
110
111 %package con-devel
112 Summary:        Header file for Ecore Con library
113 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore Con
114 Group:          Development/Libraries
115 Requires:       %{name}-con = %{version}-%{release}
116 Requires:       %{name}-devel = %{version}-%{release}
117 Requires:       c-ares-devel
118 Requires:       curl-devel
119 Requires:       gnutls-devel
120
121 %description con-devel
122 Header file for Ecore Con(nection) library.
123
124 %description con-devel -l pl.UTF-8
125 Plik nagłówkowy biblioteki połączeń Ecore Con.
126
127 %package con-static
128 Summary:        Static Ecore Con library
129 Summary(pl.UTF-8):      Statyczna biblioteka Ecore Con
130 Group:          Development/Libraries
131 Requires:       %{name}-con-devel = %{version}-%{release}
132
133 %description con-static
134 Static Ecore Con(nection) library.
135
136 %description con-static -l pl.UTF-8
137 Statyczna biblioteka połączeń Ecore Con.
138
139 %package config
140 Summary:        Ecore Config library
141 Summary(pl.UTF-8):      Biblioteka właściwości Ecore Config
142 Group:          Libraries
143 Requires:       %{name}-ipc = %{version}-%{release}
144 Requires:       eet >= 1.4.0
145 Requires:       evas >= 1.0.0
146
147 %description config
148 Ecore Config library.
149
150 %description config -l pl.UTF-8
151 Biblioteka właściwości Ecore Config.
152
153 %package config-devel
154 Summary:        Header file for Ecore Config library
155 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore Config
156 Group:          Development/Libraries
157 Requires:       %{name}-config = %{version}-%{release}
158 Requires:       %{name}-devel = %{version}-%{release}
159 Requires:       %{name}-ipc-devel = %{version}-%{release}
160 Requires:       eet-devel >= 1.4.0
161 Requires:       evas-devel >= 1.0.0
162
163 %description config-devel
164 Header file for Ecore Config library.
165
166 %description config-devel -l pl.UTF-8
167 Plik nagłówkowy biblioteki właściwości Ecore Config.
168
169 %package config-static
170 Summary:        Static Ecore Config library
171 Summary(pl.UTF-8):      Statyczna biblioteka Ecore Config
172 Group:          Development/Libraries
173 Requires:       %{name}-config-devel = %{version}-%{release}
174
175 %description config-static
176 Static Ecore Config library.
177
178 %description config-static -l pl.UTF-8
179 Statyczna biblioteka właściwości Ecore Config.
180
181 %package directfb
182 Summary:        Ecore DirectFB (frame buffer system functions) library
183 Summary(pl.UTF-8):      Biblioteka Ecore DirectFB (funkcji systemowych framebuffera)
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       DirectFB >= 0.9.16
187
188 %description directfb
189 Ecore DirectFB (frame buffer system functions) library.
190
191 %description directfb -l pl.UTF-8
192 Biblioteka Ecore DirectFB (funkcji systemowych framebuffera).
193
194 %package directfb-devel
195 Summary:        Header file for Ecore DirectFB library
196 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore DirectFB
197 Group:          Development/Libraries
198 Requires:       %{name}-devel = %{version}-%{release}
199 Requires:       %{name}-directfb = %{version}-%{release}
200 Requires:       DirectFB-devel >= 0.9.16
201
202 %description directfb-devel
203 Header file for Ecore DirectFB (frame buffer system functions)
204 library.
205
206 %description directfb-devel -l pl.UTF-8
207 Plik nagłówkowy biblioteki Ecore DirectFB (funkcji systemowych
208 framebuffera).
209
210 %package directfb-static
211 Summary:        Static Ecore DirectFB library
212 Summary(pl.UTF-8):      Statyczna biblioteka Ecore DirectFB
213 Group:          Development/Libraries
214 Requires:       %{name}-directfb-devel = %{version}-%{release}
215
216 %description directfb-static
217 Static Ecore DirectFB (frame buffer system functions) library.
218
219 %description directfb-static -l pl.UTF-8
220 Statyczna biblioteka Ecore DirectFB (funkcji systemowych
221 framebuffera).
222
223 %package evas
224 Summary:        Ecore Evas library
225 Summary(pl.UTF-8):      Biblioteka Ecore Evas
226 Group:          Libraries
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       %{name}-directfb = %{version}-%{release}
229 Requires:       %{name}-fb = %{version}-%{release}
230 Requires:       %{name}-input = %{version}-%{release}
231 Requires:       %{name}-input-evas = %{version}-%{release}
232 Requires:       %{name}-sdl = %{version}-%{release}
233 Requires:       %{name}-x = %{version}-%{release}
234 Requires:       evas >= 1.0.0
235
236 %description evas
237 Ecore Evas library.
238
239 %description evas -l pl.UTF-8
240 Biblioteka Ecore Evas.
241
242 %package evas-devel
243 Summary:        Header file for Ecore Evas library
244 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore Evas
245 Group:          Development/Libraries
246 Requires:       %{name}-devel = %{version}-%{release}
247 Requires:       %{name}-directfb-devel = %{version}-%{release}
248 Requires:       %{name}-evas = %{version}-%{release}
249 Requires:       %{name}-fb-devel = %{version}-%{release}
250 Requires:       %{name}-input-devel = %{version}-%{release}
251 Requires:       %{name}-input-evas-devel = %{version}-%{release}
252 Requires:       %{name}-sdl-devel = %{version}-%{release}
253 Requires:       %{name}-x-devel = %{version}-%{release}
254 Requires:       evas-devel >= 1.0.0
255
256 %description evas-devel
257 Header file for Ecore Evas library.
258
259 %description evas-devel -l pl.UTF-8
260 Plik nagłówkowy biblioteki Ecore Evas.
261
262 %package evas-static
263 Summary:        Static Ecore Evas library
264 Summary(pl.UTF-8):      Biblioteka statyczna Ecore Evas
265 Group:          Development/Libraries
266 Requires:       %{name}-evas-devel = %{version}-%{release}
267
268 %description evas-static
269 Static Ecore Evas library.
270
271 %description evas-static -l pl.UTF-8
272 Biblioteka statyczna Ecore Evas.
273
274 %package fb
275 Summary:        Ecore FB (frame buffer system functions) library
276 Summary(pl.UTF-8):      Biblioteka Ecore FB (funkcji systemowych framebuffera)
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description fb
281 Ecore FB (frame buffer system functions) library.
282
283 %description fb -l pl.UTF-8
284 Biblioteka Ecore FB (funkcji systemowych framebuffera).
285
286 %package fb-devel
287 Summary:        Header file for Ecore FB library
288 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore FB
289 Group:          Development/Libraries
290 Requires:       %{name}-devel = %{version}-%{release}
291 Requires:       %{name}-fb = %{version}-%{release}
292 Requires:       tslib-devel
293
294 %description fb-devel
295 Header file for Ecore FB (frame buffer system functions) library.
296
297 %description fb -l pl.UTF-8
298 Plik nagłówkowy biblioteki Ecore FB (funkcji systemowych
299 framebuffera).
300
301 %package fb-static
302 Summary:        Static Ecore FB library
303 Summary(pl.UTF-8):      Statyczna biblioteka Ecore FB
304 Group:          Development/Libraries
305 Requires:       %{name}-fb-devel = %{version}-%{release}
306
307 %description fb-static
308 Static Ecore FB (frame buffer system functions) library.
309
310 %description fb-static -l pl.UTF-8
311 Statyczna biblioteka Ecore FB (funkcji systemowych framebuffera).
312
313 %package file
314 Summary:        Ecore File library
315 Summary(pl.UTF-8):      Biblioteka Ecore File
316 Group:          Libraries
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       %{name}-con = %{version}-%{release}
319
320 %description file
321 Ecore File library.
322
323 %description file -l pl.UTF-8
324 Biblioteka Ecore File.
325
326 %package file-devel
327 Summary:        Header file for Ecore File library
328 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore File
329 Group:          Development/Libraries
330 Requires:       %{name}-con-devel = %{version}-%{release}
331 Requires:       %{name}-devel = %{version}-%{release}
332 Requires:       %{name}-file = %{version}-%{release}
333
334 %description file-devel
335 Header file for Ecore File library.
336
337 %description file-devel -l pl.UTF-8
338 Plik nagłówkowy biblioteki Ecore File.
339
340 %package file-static
341 Summary:        Static Ecore File library
342 Summary(pl.UTF-8):      Statyczna biblioteka Ecore File
343 Group:          Development/Libraries
344 Requires:       %{name}-file-devel = %{version}-%{release}
345
346 %description file-static
347 Static Ecore File library.
348
349 %description file-static -l pl.UTF-8
350 Statyczna biblioteka Ecore File.
351
352 %package imf
353 Summary:        Ecore IMF library
354 Summary(pl.UTF-8):      Biblioteka Ecore IMF
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description imf
359 Ecore IMF library.
360
361 %description imf -l pl.UTF-8
362 Biblioteka Ecore IMF.
363
364 %package imf-devel
365 Summary:        Header file for Ecore IMF library
366 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore IMF
367 Group:          Development/Libraries
368 Requires:       %{name}-devel = %{version}-%{release}
369 Requires:       %{name}-imf = %{version}-%{release}
370
371 %description imf-devel
372 Header file for Ecore IMF library.
373
374 %description imf-devel -l pl.UTF-8
375 Plik nagłówkowy biblioteki Ecore IMF.
376
377 %package imf-static
378 Summary:        Static Ecore IMF library
379 Summary(pl.UTF-8):      Statyczna biblioteka Ecore IMF
380 Group:          Development/Libraries
381 Requires:       %{name}-imf-devel = %{version}-%{release}
382
383 %description imf-static
384 Static Ecore IMF library.
385
386 %description imf-static -l pl.UTF-8
387 Statyczna biblioteka Ecore IMF.
388
389 %package imf-evas
390 Summary:        Ecore IMF Evas library
391 Summary(pl.UTF-8):      Biblioteka Ecore IMF Evas
392 Group:          Libraries
393 Requires:       %{name} = %{version}-%{release}
394 Requires:       %{name}-imf = %{version}-%{release}
395 Requires:       evas >= 1.0.0
396
397 %description imf-evas
398 Ecore IMF Evas library.
399
400 %description imf-evas -l pl.UTF-8
401 Biblioteka Ecore IMF Evas.
402
403 %package imf-evas-devel
404 Summary:        Header file for Ecore IMF Evas library
405 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore IMF Evas
406 Group:          Development/Libraries
407 Requires:       %{name}-devel = %{version}-%{release}
408 Requires:       %{name}-imf-devel = %{version}-%{release}
409 Requires:       %{name}-imf-evas = %{version}-%{release}
410 Requires:       evas-devel >= 1.0.0
411
412 %description imf-evas-devel
413 Header file for Ecore IMF Evas library.
414
415 %description imf-evas-devel -l pl.UTF-8
416 Plik nagłówkowy biblioteki Ecore IMF Evas.
417
418 %package imf-evas-static
419 Summary:        Static Ecore IMF Evas library
420 Summary(pl.UTF-8):      Statyczna biblioteka Ecore IMF Evas
421 Group:          Development/Libraries
422 Requires:       %{name}-imf-evas-devel = %{version}-%{release}
423
424 %description imf-evas-static
425 Static Ecore IMF Evas library.
426
427 %description imf-evas-static -l pl.UTF-8
428 Statyczna biblioteka Ecore IMF Evas.
429
430 %package input
431 Summary:        Ecore Input library
432 Summary(pl.UTF-8):      Biblioteka Ecore Input
433 Group:          Libraries
434 Requires:       %{name} = %{version}-%{release}
435
436 %description input
437 Ecore Input library.
438
439 %description input -l pl.UTF-8
440 Biblioteka Ecore Input.
441
442 %package input-devel
443 Summary:        Header file for Ecore Input library
444 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore Input
445 Group:          Development/Libraries
446 Requires:       %{name}-devel = %{version}-%{release}
447 Requires:       %{name}-input = %{version}-%{release}
448
449 %description input-devel
450 Header file for Ecore Input library.
451
452 %description input-devel -l pl.UTF-8
453 Plik nagłówkowy biblioteki Ecore Input.
454
455 %package input-static
456 Summary:        Static Ecore Input library
457 Summary(pl.UTF-8):      Statyczna biblioteka Ecore Input
458 Group:          Development/Libraries
459 Requires:       %{name}-input-devel = %{version}-%{release}
460
461 %description input-static
462 Static Ecore Input library.
463
464 %description input-static -l pl.UTF-8
465 Statyczna biblioteka Ecore Input.
466
467 %package input-evas
468 Summary:        Ecore Input Evas extension library
469 Summary(pl.UTF-8):      Biblioteka rozszerzenia Ecore Input Evas
470 Group:          Libraries
471 Requires:       %{name} = %{version}-%{release}
472 Requires:       %{name}-input = %{version}-%{release}
473 Requires:       evas >= 1.0.0
474
475 %description input-evas
476 Ecore Input Evas extension library.
477
478 %description input-evas -l pl.UTF-8
479 Biblioteka rozszerzenia Ecore Input Evas.
480
481 %package input-evas-devel
482 Summary:        Header file for Ecore Input Evas extension library
483 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki rozszerzenia Ecore Input Evas
484 Group:          Development/Libraries
485 Requires:       %{name}-devel = %{version}-%{release}
486 Requires:       %{name}-input-devel = %{version}-%{release}
487 Requires:       evas-devel >= 1.0.0
488
489 %description input-evas-devel
490 Header file for Ecore Input Evas extension library.
491
492 %description input-evas-devel -l pl.UTF-8
493 Plik nagłówkowy biblioteki rozszerzenia Ecore Input Evas.
494
495 %package input-evas-static
496 Summary:        Static Ecore Input Evas extension library
497 Summary(pl.UTF-8):      Statyczna biblioteka rozszerzenia Ecore Input Evas
498 Group:          Libraries
499 Requires:       %{name}-input-evas-devel = %{version}-%{release}
500
501 %description input-evas-static
502 Static Ecore Input Evas extension library.
503
504 %description input-evas-static -l pl.UTF-8
505 Statyczna biblioteka rozszerzenia Ecore Input Evas.
506
507 %package ipc
508 Summary:        Ecore IPC (inter-process communication functions) library
509 Summary(pl.UTF-8):      Biblioteka Ecore IPC (funkcji komunikacji międzyprocesowej)
510 Group:          Libraries
511 Requires:       %{name} = %{version}-%{release}
512 Requires:       %{name}-con = %{version}-%{release}
513
514 %description ipc
515 Ecore IPC (inter-process communication functions) library.
516
517 %description ipc -l pl.UTF-8
518 Biblioteka Ecore IPC (funkcji komunikacji międzyprocesowej).
519
520 %package ipc-devel
521 Summary:        Header file for Ecore IPC library
522 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore IPC
523 Group:          Development/Libraries
524 Requires:       %{name}-devel = %{version}-%{release}
525 Requires:       %{name}-ipc = %{version}-%{release}
526
527 %description ipc-devel
528 Header file for Ecore IPC (inter-process communication functions)
529 library.
530
531 %description ipc-devel -l pl.UTF-8
532 Plik nagłówkowy biblioteki Ecore IPC (funkcji komunikacji
533 międzyprocesowej).
534
535 %package ipc-static
536 Summary:        Static Ecore IPC library
537 Summary(pl.UTF-8):      Statyczna biblioteka Ecore IPC
538 Group:          Development/Libraries
539 Requires:       %{name}-ipc-devel = %{version}-%{release}
540
541 %description ipc-static
542 Static Ecore IPC (inter-process communication functions) library.
543
544 %description ipc-static -l pl.UTF-8
545 Statyczna biblioteka Ecore IPC (funkcji komunikacji międzyprocesowej).
546
547 %package sdl
548 Summary:        Ecore SDL library
549 Summary(pl.UTF-8):      Biblioteka Ecore SDL
550 Group:          Libraries
551 Requires:       %{name} = %{version}-%{release}
552 Requires:       %{name}-input = %{version}-%{release}
553
554 %description sdl
555 Ecore SDL library.
556
557 %description sdl -l pl.UTF-8
558 Biblioteka Ecore SDL.
559
560 %package sdl-devel
561 Summary:        Header file for Ecore SDL library
562 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Ecore SDL
563 Group:          Development/Libraries
564 Requires:       %{name}-devel = %{version}-%{release}
565 Requires:       %{name}-input-devel = %{version}-%{release}
566 Requires:       SDL-devel >= 1.2.0
567
568 %description sdl-devel
569 Header file for Ecore SDL library.
570
571 %description sdl-devel -l pl.UTF-8
572 Plik nagłówkowy biblioteki Ecore SDL.
573
574 %package sdl-static
575 Summary:        Static Ecore SDL library
576 Summary(pl.UTF-8):      Statyczna biblioteka Ecore SDL
577 Group:          Development/Libraries
578 Requires:       %{name}-sdl-devel = %{version}-%{release}
579
580 %description sdl-static
581 Static Ecore SDL library.
582
583 %description sdl-static -l pl.UTF-8
584 Statyczna biblioteka Ecore SDL.
585
586 %package x
587 Summary:        Ecore X (functions for dealing with the X Window System) library
588 Summary(pl.UTF-8):      Biblioteka Ecore X (funkcji do obsługi X Window System)
589 Group:          X11/Libraries
590 Requires:       %{name} = %{version}-%{release}
591 Requires:       %{name}-input = %{version}-%{release}
592
593 %description x
594 Ecore X (functions for dealing with the X Window System) library.
595
596 %description x -l pl.UTF-8
597 Biblioteka Ecore X (funkcji do obsługi X Window System).
598
599 %package x-devel
600 Summary:        Header files for Ecore X library
601 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ecore X
602 Group:          Development/Libraries
603 Requires:       %{name}-devel = %{version}-%{release}
604 Requires:       %{name}-input-devel = %{version}-%{release}
605 Requires:       %{name}-x = %{version}-%{release}
606 %if %{with xcb}
607 Requires:       libxcb-devel
608 Requires:       xcb-util-devel
609 %else
610 Requires:       xorg-lib-libX11-devel
611 Requires:       xorg-lib-libXScrnSaver-devel
612 Requires:       xorg-lib-libXcomposite-devel
613 Requires:       xorg-lib-libXcursor-devel
614 Requires:       xorg-lib-libXdamage-devel
615 Requires:       xorg-lib-libXext-devel
616 Requires:       xorg-lib-libXfixes-devel
617 Requires:       xorg-lib-libXi-devel
618 Requires:       xorg-lib-libXinerama-devel
619 Requires:       xorg-lib-libXp-devel
620 Requires:       xorg-lib-libXrandr-devel
621 Requires:       xorg-lib-libXrender-devel
622 Requires:       xorg-lib-libXtst-devel
623 %endif
624
625 %description x-devel
626 Header files for Ecore X (functions for dealing with the X Window
627 System) library.
628
629 %description x-devel -l pl.UTF-8
630 Pliki nagłówkowe biblioteki Ecore X (funkcji do obsługi X Window
631 System).
632
633 %package x-static
634 Summary:        Static Ecore X library
635 Summary(pl.UTF-8):      Statyczna biblioteka Ecore X
636 Group:          Development/Libraries
637 Requires:       %{name}-x-devel = %{version}-%{release}
638
639 %description x-static
640 Static Ecore X (functions for dealing with the X Window System)
641 library.
642
643 %description x-static -l pl.UTF-8
644 Statyczna biblioteka Ecore X (funkcji do obsługi X Window System).
645
646 %prep
647 %setup -q -n %{name}-%{version}.%{subver}
648
649 %build
650 %{__libtoolize}
651 %{__aclocal} -I m4
652 %{__autoconf}
653 %{__autoheader}
654 %{__automake}
655 %configure \
656         --disable-silent-rules \
657         %{!?with_static_libs:--disable-static} \
658         --enable-ecore-con      \
659         --enable-ecore-directfb \
660         --enable-ecore-fb       \
661         --enable-ecore-file     \
662         --enable-ecore-ipc      \
663         --enable-ecore-sdl      \
664         --enable-ecore-x        \
665         %{?with_xcb:--enable-ecore-x-xcb}       \
666         --enable-ecore-evas     \
667         --enable-ecore-evas-fb  \
668         --enable-cares          \
669         --enable-curl           \
670         --enable-inotify        \
671         --enable-openssl        \
672         --enable-poll
673
674 %{__make}
675
676 %install
677 rm -rf $RPM_BUILD_ROOT
678
679 %{__make} install \
680         DESTDIR=$RPM_BUILD_ROOT
681
682 %find_lang %{name} --all-name
683
684 %clean
685 rm -rf $RPM_BUILD_ROOT
686
687 %post   -p /sbin/ldconfig
688 %postun -p /sbin/ldconfig
689 %post   con     -p /sbin/ldconfig
690 %postun con     -p /sbin/ldconfig
691 %post   config  -p /sbin/ldconfig
692 %postun config  -p /sbin/ldconfig
693 %post   directfb -p /sbin/ldconfig
694 %postun directfb -p /sbin/ldconfig
695 %post   evas    -p /sbin/ldconfig
696 %postun evas    -p /sbin/ldconfig
697 %post   fb      -p /sbin/ldconfig
698 %postun fb      -p /sbin/ldconfig
699 %post   file    -p /sbin/ldconfig
700 %postun file    -p /sbin/ldconfig
701 %post   imf     -p /sbin/ldconfig
702 %postun imf     -p /sbin/ldconfig
703 %post   imf-evas -p /sbin/ldconfig
704 %postun imf-evas -p /sbin/ldconfig
705 %post   input   -p /sbin/ldconfig
706 %postun input   -p /sbin/ldconfig
707 %post   input-evas -p /sbin/ldconfig
708 %postun input-evas -p /sbin/ldconfig
709 %post   ipc     -p /sbin/ldconfig
710 %postun ipc     -p /sbin/ldconfig
711 %post   sdl     -p /sbin/ldconfig
712 %postun sdl     -p /sbin/ldconfig
713 %post   x       -p /sbin/ldconfig
714 %postun x       -p /sbin/ldconfig
715
716 %files -f %{name}.lang
717 %defattr(644,root,root,755)
718 %doc AUTHORS COPYING ChangeLog README
719 %attr(755,root,root) %{_libdir}/libecore.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libecore.so.1
721
722 %files devel
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libecore.so
725 %{_libdir}/libecore.la
726 %dir %{_includedir}/ecore-1
727 %{_includedir}/ecore-1/Ecore.h
728 %{_includedir}/ecore-1/Ecore_Getopt.h
729 %{_pkgconfigdir}/ecore.pc
730
731 %if %{with static_libs}
732 %files static
733 %defattr(644,root,root,755)
734 %{_libdir}/libecore.a
735 %endif
736
737 %files con
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libecore_con.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libecore_con.so.1
741
742 %files con-devel
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libecore_con.so
745 %{_libdir}/libecore_con.la
746 %{_includedir}/ecore-1/Ecore_Con.h
747 %{_pkgconfigdir}/ecore-con.pc
748
749 %if %{with static_libs}
750 %files con-static
751 %defattr(644,root,root,755)
752 %{_libdir}/libecore_con.a
753 %endif
754
755 %if 0
756 %files config
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_bindir}/ecore_config
759 %attr(755,root,root) %{_libdir}/libecore_config.so.*.*.*
760 %attr(755,root,root) %ghost %{_libdir}/libecore_config.so.1
761
762 %files config-devel
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_libdir}/libecore_config.so
765 %{_libdir}/libecore_config.la
766 %{_includedir}/ecore-1/Ecore_Config.h
767 %{_pkgconfigdir}/ecore-config.pc
768
769 %if %{with static_libs}
770 %files config-static
771 %defattr(644,root,root,755)
772 %{_libdir}/libecore_config.a
773 %endif
774 %endif
775
776 %files directfb
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libecore_directfb.so.*.*.*
779 %attr(755,root,root) %ghost %{_libdir}/libecore_directfb.so.1
780
781 %files directfb-devel
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libecore_directfb.so
784 %{_libdir}/libecore_directfb.la
785 %{_includedir}/ecore-1/Ecore_DirectFB.h
786 %{_pkgconfigdir}/ecore-directfb.pc
787
788 %if %{with static_libs}
789 %files directfb-static
790 %defattr(644,root,root,755)
791 %{_libdir}/libecore_directfb.a
792 %endif
793
794 %files evas
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libecore_evas.so.*.*.*
797 %attr(755,root,root) %ghost %{_libdir}/libecore_evas.so.1
798
799 %files evas-devel
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libecore_evas.so
802 %{_libdir}/libecore_evas.la
803 %{_includedir}/ecore-1/Ecore_Evas.h
804 %{_pkgconfigdir}/ecore-evas.pc
805
806 %if %{with static_libs}
807 %files evas-static
808 %defattr(644,root,root,755)
809 %{_libdir}/libecore_evas.a
810 %endif
811
812 %files fb
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libecore_fb.so.*.*.*
815 %attr(755,root,root) %ghost %{_libdir}/libecore_fb.so.1
816
817 %files fb-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libecore_fb.so
820 %{_libdir}/libecore_fb.la
821 %{_includedir}/ecore-1/Ecore_Fb.h
822 %{_pkgconfigdir}/ecore-fb.pc
823
824 %if %{with static_libs}
825 %files fb-static
826 %defattr(644,root,root,755)
827 %{_libdir}/libecore_fb.a
828 %endif
829
830 %files file
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/libecore_file.so.*.*.*
833 %attr(755,root,root) %ghost %{_libdir}/libecore_file.so.1
834
835 %files file-devel
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libecore_file.so
838 %{_libdir}/libecore_file.la
839 %{_includedir}/ecore-1/Ecore_File.h
840 %{_pkgconfigdir}/ecore-file.pc
841
842 %if %{with static_libs}
843 %files file-static
844 %defattr(644,root,root,755)
845 %{_libdir}/libecore_file.a
846 %endif
847
848 %files imf
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libecore_imf.so.*.*.*
851 %attr(755,root,root) %ghost %{_libdir}/libecore_imf.so.1
852
853 %files imf-devel
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/libecore_imf.so
856 %{_libdir}/libecore_imf.la
857 %{_includedir}/ecore-1/Ecore_IMF.h
858 %{_pkgconfigdir}/ecore-imf.pc
859
860 %if %{with static_libs}
861 %files imf-static
862 %defattr(644,root,root,755)
863 %{_libdir}/libecore_imf.a
864 %endif
865
866 %files imf-evas
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/libecore_imf_evas.so.*.*.*
869 %attr(755,root,root) %ghost %{_libdir}/libecore_imf_evas.so.1
870
871 %files imf-evas-devel
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/libecore_imf_evas.so
874 %{_libdir}/libecore_imf_evas.la
875 %{_includedir}/ecore-1/Ecore_IMF_Evas.h
876 %{_pkgconfigdir}/ecore-imf-evas.pc
877
878 %if %{with static_libs}
879 %files imf-evas-static
880 %defattr(644,root,root,755)
881 %{_libdir}/libecore_imf_evas.a
882 %endif
883
884 %files input
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/libecore_input.so.*.*.*
887 %attr(755,root,root) %ghost %{_libdir}/libecore_input.so.1
888
889 %files input-devel
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/libecore_input.so
892 %{_libdir}/libecore_input.la
893 %{_includedir}/ecore-1/Ecore_Input.h
894 %{_pkgconfigdir}/ecore-input.pc
895
896 %if %{with static_libs}
897 %files input-static
898 %defattr(644,root,root,755)
899 %{_libdir}/libecore_input.a
900 %endif
901
902 %files input-evas
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/libecore_input_evas.so.*.*.*
905 %attr(755,root,root) %ghost %{_libdir}/libecore_input_evas.so.1
906
907 %files input-evas-devel
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/libecore_input_evas.so
910 %{_libdir}/libecore_input_evas.la
911 %{_includedir}/ecore-1/Ecore_Input_Evas.h
912 %{_pkgconfigdir}/ecore-input-evas.pc
913
914 %if %{with static_libs}
915 %files input-evas-static
916 %defattr(644,root,root,755)
917 %{_libdir}/libecore_input_evas.a
918 %endif
919
920 %files ipc
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/libecore_ipc.so.*.*.*
923 %attr(755,root,root) %ghost %{_libdir}/libecore_ipc.so.1
924
925 %files ipc-devel
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/libecore_ipc.so
928 %{_libdir}/libecore_ipc.la
929 %{_includedir}/ecore-1/Ecore_Ipc.h
930 %{_pkgconfigdir}/ecore-ipc.pc
931
932 %if %{with static_libs}
933 %files ipc-static
934 %defattr(644,root,root,755)
935 %{_libdir}/libecore_ipc.a
936 %endif
937
938 %files sdl
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/libecore_sdl.so.*.*.*
941 %attr(755,root,root) %ghost %{_libdir}/libecore_sdl.so.1
942
943 %files sdl-devel
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/libecore_sdl.so
946 %{_libdir}/libecore_sdl.la
947 %{_includedir}/ecore-1/Ecore_Sdl.h
948 %{_pkgconfigdir}/ecore-sdl.pc
949
950 %if %{with static_libs}
951 %files sdl-static
952 %defattr(644,root,root,755)
953 %{_libdir}/libecore_sdl.a
954 %endif
955
956 %files x
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/libecore_x.so.*.*.*
959 %attr(755,root,root) %ghost %{_libdir}/libecore_x.so.1
960
961 %files x-devel
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/libecore_x.so
964 %{_libdir}/libecore_x.la
965 %{_includedir}/ecore-1/Ecore_X.h
966 %{_includedir}/ecore-1/Ecore_X_Atoms.h
967 %{_includedir}/ecore-1/Ecore_X_Cursor.h
968 %{_pkgconfigdir}/ecore-x.pc
969
970 %if %{with static_libs}
971 %files x-static
972 %defattr(644,root,root,755)
973 %{_libdir}/libecore_x.a
974 %endif
This page took 0.15944 seconds and 4 git commands to generate.