]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
- up to 0.9.9.025; ecore_test segfaults, hmmm....
[packages/ecore.git] / ecore.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightened Core X interface library
6 Summary(pl):    Biblioteka interfejsu X Enlightened Core
7 Name:           ecore
8 Version:        0.9.9.025
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  c3a6f4392896defa4a768a13817e38d8
14 URL:            http://enlightenment.org/Libraries/Ecore/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  curl-devel
18 BuildRequires:  evas-devel
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  sed >= 4.0
23 Requires:       %{name}-libs = %{version}-%{release}
24 Requires:       fonts-TTF-bitstream-vera
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %undefine       __cxx
28
29 %description
30 Ecore is the event/X abstraction layer that makes doing selections,
31 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
32 optimized, and convenient. It's a separate library so anyone can make
33 use of the work put into Ecore to make this job easy for applications.
34
35 %description -l pl
36 Ecore to warstwa abstracji zdarzeñ/X, która powoduje, ¿e dokonywanie
37 zaznaczeñ, Xdnd, ogólne operacje X, pêtle zdarzeñ, obs³uga timeoutów i
38 bezczynno¶ci s± szybkie, zoptymalizowane i wygodne. Jest to wydzielona
39 biblioteka, wiêc ka¿dy mo¿e skorzystaæ z pracy w³o¿onej w Ecore do
40 u³atwienia swojej pracy przy aplikacjach.
41
42 %package libs
43 Summary:        Ecore library
44 Summary(pl):    Biblioteka ecore
45 Group:          X11/Libraries
46
47 %description libs
48 Ecore library.
49
50 %description libs -l pl
51 Biblioteka ecore.
52
53 %package devel
54 Summary:        Ecore header files
55 Summary(pl):    Pliki nag³ówkowe Ecore
56 Group:          Development/Libraries
57 Requires:       %{name}-libs = %{version}-%{release}
58 Requires:       curl-devel
59 Requires:       evas-devel
60 Requires:       openssl-devel
61
62 %description devel
63 Ecore development files.
64
65 %description devel -l pl
66 Pliki programistyczne Ecore.
67
68 %package static
69 Summary:        Static Ecore libraries
70 Summary(pl):    Statyczne biblioteki Ecore
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Ecore libraries.
76
77 %description static -l pl
78 Statyczne biblioteki Ecore.
79
80 %prep
81 %setup -q
82 sed -e 's/^@BUILD_ECORE_DIRECTFB_TRUE@/#/'      \
83     -e 's/^@BUILD_ECORE_DIRECTFB_FALSE@//'      \
84     -i src/lib/ecore_directfb/Makefile.in       \
85        src/lib/ecore_evas/Makefile.in
86
87 %build
88 %configure \
89         %{!?with_static_libs:--disable-static} \
90         --enable-ecore-txt      \
91         --enable-ecore-x        \
92         --enable-ecore-job      \
93         --enable-ecore-fb       \
94         --enable-ecore-evas     \
95         --enable-ecore-evas-gl  \
96         --enable-ecore-evas-xrender \
97         --disable-ecore-evas-dfb        \
98         --enable-ecore-evas-fb  \
99         --enable-ecore-evas-buffer \
100         --enable-ecore-con      \
101         --enable-openssl        \
102         --enable-ecore-ipc      \
103         --enable-ecore-dbus     \
104         --enable-ecore-config   \
105         --enable-ecore-file     \
106         --enable-inotify        \
107         --enable-poll           \
108         --enable-curl           \
109         --enable-pthreads
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 cd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
119 VERA=$(ls Vera*.ttf)
120 for FONT in $VERA; do
121         rm -f $FONT
122         ln -s %{_fontsdir}/TTF/$FONT .
123 done
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post libs      -p /sbin/ldconfig
129 %postun libs    -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
134 %attr(755,root,root) %{_bindir}/ecore_*
135 %{_datadir}/%{name}
136
137 %files libs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libecore*.so.*.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/ecore-config
144 %attr(755,root,root) %{_libdir}/libecore*.so
145 %{_libdir}/libecore*.la
146 %{_pkgconfigdir}/ecore.pc
147 %{_aclocaldir}/ecore.m4
148 %{_includedir}/Ecore*.h
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libecore*.a
154 %endif
This page took 0.045015 seconds and 3 git commands to generate.