]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
- regenerate auto* to force use of correct libtool
[packages/ecore.git] / ecore.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightened Core X interface library
6 Summary(pl):    Biblioteka interfejsu X Enlightened Core
7 Name:           ecore
8 Version:        0.9.9.036
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  b2f3ba94aa47a885c77c3ad7a686ee42
14 URL:            http://enlightenment.org/Libraries/Ecore/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  curl-devel
18 BuildRequires:  evas-devel
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %undefine       __cxx
26
27 %description
28 Ecore is the event/X abstraction layer that makes doing selections,
29 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
30 optimized, and convenient. It's a separate library so anyone can make
31 use of the work put into Ecore to make this job easy for applications.
32
33 %description -l pl
34 Ecore to warstwa abstracji zdarzeñ/X, która powoduje, ¿e dokonywanie
35 zaznaczeñ, Xdnd, ogólne operacje X, pêtle zdarzeñ, obs³uga timeoutów i
36 bezczynno¶ci s± szybkie, zoptymalizowane i wygodne. Jest to wydzielona
37 biblioteka, wiêc ka¿dy mo¿e skorzystaæ z pracy w³o¿onej w Ecore do
38 u³atwienia swojej pracy przy aplikacjach.
39
40 %package libs
41 Summary:        Ecore library
42 Summary(pl):    Biblioteka ecore
43 Group:          X11/Libraries
44
45 %description libs
46 Ecore library.
47
48 %description libs -l pl
49 Biblioteka ecore.
50
51 %package devel
52 Summary:        Ecore header files
53 Summary(pl):    Pliki nag³ówkowe Ecore
54 Group:          Development/Libraries
55 Requires:       %{name}-libs = %{version}-%{release}
56 Requires:       curl-devel
57 Requires:       evas-devel
58 Requires:       openssl-devel
59
60 %description devel
61 Ecore development files.
62
63 %description devel -l pl
64 Pliki programistyczne Ecore.
65
66 %package static
67 Summary:        Static Ecore libraries
68 Summary(pl):    Statyczne biblioteki Ecore
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Ecore libraries.
74
75 %description static -l pl
76 Statyczne biblioteki Ecore.
77
78 %prep
79 %setup -q
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         %{!?with_static_libs:--disable-static} \
89         --enable-ecore-txt      \
90         --enable-ecore-x        \
91         --enable-ecore-job      \
92         --enable-ecore-fb       \
93         --enable-ecore-evas     \
94         --enable-ecore-evas-gl  \
95         --enable-ecore-evas-xrender \
96         --enable-ecore-evas-dfb \
97         --enable-ecore-evas-fb  \
98         --enable-ecore-evas-buffer \
99         --enable-ecore-con      \
100         --enable-openssl        \
101         --enable-ecore-ipc      \
102         --enable-ecore-dbus     \
103         --enable-ecore-config   \
104         --enable-ecore-file     \
105         --enable-inotify        \
106         --enable-poll           \
107         --enable-curl           \
108         --enable-pthreads
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post libs      -p /sbin/ldconfig
121 %postun libs    -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
126 %attr(755,root,root) %{_bindir}/ecore_config
127
128 %files libs
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libecore.so.*.*.*
131 %attr(755,root,root) %{_libdir}/libecore_con.so.*.*.*
132 %attr(755,root,root) %{_libdir}/libecore_config.so.*.*.*
133 %attr(755,root,root) %{_libdir}/libecore_dbus.so.*.*.*
134 %attr(755,root,root) %{_libdir}/libecore_directfb.so.*.*.*
135 %attr(755,root,root) %{_libdir}/libecore_desktop.so.*.*.*
136 %attr(755,root,root) %{_libdir}/libecore_evas.so.*.*.*
137 %attr(755,root,root) %{_libdir}/libecore_fb.so.*.*.*
138 %attr(755,root,root) %{_libdir}/libecore_file.so.*.*.*
139 %attr(755,root,root) %{_libdir}/libecore_ipc.so.*.*.*
140 %attr(755,root,root) %{_libdir}/libecore_job.so.*.*.*
141 %attr(755,root,root) %{_libdir}/libecore_txt.so.*.*.*
142 %attr(755,root,root) %{_libdir}/libecore_x.so.*.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/ecore-config
147 %attr(755,root,root) %{_libdir}/libecore*.so
148 %{_libdir}/libecore*.la
149 %{_pkgconfigdir}/ecore.pc
150 %{_aclocaldir}/ecore.m4
151 %{_includedir}/Ecore*.h
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libecore*.a
157 %endif
This page took 0.056555 seconds and 3 git commands to generate.