]> git.pld-linux.org Git - packages/ecasound.git/commitdiff
- updated link patch:
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 15 Feb 2003 12:38:23 +0000 (12:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  - libecasoundc doesn't need -lecasound now, but libecasound need -lkvutils
  - only ecasound program needs -lreadline -lhistory, libecasound not
  - remove "-static" - don't link statically with libstdc++
- shared libraries are back (in main package) - needed by ecasound program
- added -devel and -static; now libecasoundc provides interface to ecasound
  program, so probably perl and pecl interfaces could be resurrected?

Changed files:
    ecasound-link.patch -> 1.3
    ecasound.spec -> 1.66

ecasound-link.patch
ecasound.spec

index f5e239f0ebaeef2c0e06308ea3d8b31e979152eb..3536821badbd97eadbdeb45330dad3b2fb6f2e3f 100644 (file)
@@ -1,12 +1,91 @@
-diff -Nur ecasound-2.2.0-pre3.orig/libecasoundc/Makefile.am ecasound-2.2.0-pre3/libecasoundc/Makefile.am
---- ecasound-2.2.0-pre3.orig/libecasoundc/Makefile.am  Thu Oct 17 18:49:29 2002
-+++ ecasound-2.2.0-pre3/libecasoundc/Makefile.am       Fri Oct 25 13:07:49 2002
-@@ -52,7 +52,7 @@
- # ----------------------------------------------------------------------
- libecasoundc_la_SOURCES = $(ecasoundc_src)
--libecasoundc_la_LIBADD =
-+libecasoundc_la_LIBADD = ../libecasound/libecasound.la
- libecasoundc_la_LDFLAGS = -export-dynamic $(eca_ldflags)
- libecasoundc_debug_la_SOURCES = $(libecasoundc_la_SOURCES)
- libecasoundc_debug_la_LIBADD =
+diff -Nur ecasound-2.2.0.orig/configure.in ecasound-2.2.0/configure.in
+--- ecasound-2.2.0.orig/configure.in   Thu Jan  9 21:24:30 2003
++++ ecasound-2.2.0/configure.in        Sat Feb 15 11:10:34 2003
+@@ -629,8 +629,8 @@
+      [AC_CHECK_HEADER(readline/history.h,,
+        AC_MSG_ERROR([*** readline history headers not installed ***]))])
+-  AC_CHECK_LIB(readline, main,, AC_MSG_ERROR([*** readline support not installed ***]))
+-  AC_CHECK_LIB(history, main,, AC_MSG_ERROR([*** readline history support not installed ***]))
++  AC_CHECK_LIB(readline, main, true, AC_MSG_ERROR([*** readline support not installed ***]))
++  AC_CHECK_LIB(history, main, true, AC_MSG_ERROR([*** readline history support not installed ***]))
+   AC_SUBST(ECA_S_READLINE_INCLUDES)
+ else
+   AC_CONFIG_SUBDIRS(readline-4.0)
+diff -Nur ecasound-2.2.0.orig/ecasound/Makefile.am ecasound-2.2.0/ecasound/Makefile.am
+--- ecasound-2.2.0.orig/ecasound/Makefile.am   Wed Oct 30 19:39:32 2002
++++ ecasound-2.2.0/ecasound/Makefile.am        Sat Feb 15 11:11:34 2003
+@@ -43,11 +43,11 @@
+ if ECA_AM_SYSTEM_READLINE
+ ecasound_LDFLAGS = -export-dynamic
+-ecasound_LDADD = $(termcap_library) \
++ecasound_LDADD = $(termcap_library) -lreadline -lhistory \
+               $(top_builddir)/libecasound/libecasound.la \
+               $(top_builddir)/kvutils/libkvutils.la
+ ecasound_debug_LDFLAGS = $(ecasound_LDFLAGS)
+-ecasound_debug_LDADD = $(termcap_library) \
++ecasound_debug_LDADD = $(termcap_library) -lreadline -lhistory \
+               $(top_builddir)/libecasound/libecasound_debug.la \
+               $(top_builddir)/kvutils/libkvutils_debug.la
+diff -Nur ecasound-2.2.0.orig/kvutils/Makefile.am ecasound-2.2.0/kvutils/Makefile.am
+--- ecasound-2.2.0.orig/kvutils/Makefile.am    Tue Nov  5 02:05:17 2002
++++ ecasound-2.2.0/kvutils/Makefile.am Sat Feb 15 11:07:24 2003
+@@ -41,13 +41,13 @@
+                       kvu_value_queue.h
+ libkvutils_la_SOURCES = $(kvutil_sources) $(kvutil_headers)
+-libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:0 -static
++libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:0
+ libkvutils_debug_la_SOURCES = $(libkvutils_la_SOURCES)
+ libkvutils_debug_la_LDFLAGS = $(libkvutils_la_LDFLAGS)
+ libkvutils_tester_SOURCES = libkvutils_tester.cpp
+-libkvutils_tester_LDFLAGS = $(lib_LTLIBRARIES) -static
++libkvutils_tester_LDFLAGS = $(lib_LTLIBRARIES)
+ noinst_HEADERS = $(kvutil_headers)
+diff -Nur ecasound-2.2.0.orig/libecasound/Makefile.am ecasound-2.2.0/libecasound/Makefile.am
+--- ecasound-2.2.0.orig/libecasound/Makefile.am        Tue Jan  7 23:35:13 2003
++++ ecasound-2.2.0/libecasound/Makefile.am     Sat Feb 15 11:12:58 2003
+@@ -315,8 +315,8 @@
+ libecasound_la_SOURCES = $(ecasound_common_src)
+ libecasound_debug_la_SOURCES = $(ecasound_common_src)
+ libecasound_la_CFLAGS = $(eca_cxxflags)
+-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
+-libecasound_la_LIBADD = $(eca_libadd)
++libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags)
++libecasound_la_LIBADD = $(eca_libadd) ../kvutils/libkvutils.la
+ libecasound_debug_la_CFLAGS = $(libecasound_la_CFLAGS)
+ libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
+ libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
+diff -Nur ecasound-2.2.0.orig/libecasound/plugins/Makefile.am ecasound-2.2.0/libecasound/plugins/Makefile.am
+--- ecasound-2.2.0.orig/libecasound/plugins/Makefile.am        Thu Oct 17 03:09:07 2002
++++ ecasound-2.2.0/libecasound/plugins/Makefile.am     Sat Feb 15 11:07:34 2003
+@@ -86,7 +86,7 @@
+ libecasound_plugins_la_SOURCES          = audioio_dummy.cpp $(plugin_cond_sources)
+ EXTRA_libecasound_plugins_la_SOURCES    = $(plugin_cond_sources)
+ libecasound_plugins_la_LIBADD         = $(af_libs) $(alsa_libs) $(arts_libs) $(jack_libs)
+-libecasound_plugins_la_LDFLAGS                = -static
++libecasound_plugins_la_LDFLAGS                =
+ libecasound_plugins_debug_la_SOURCES  = $(libecasound_plugins_la_SOURCES)
+ EXTRA_libecasound_plugins_debug_la_SOURCES = $(EXTRA_libecasound_plugins_la_SOURCES)
+diff -Nur ecasound-2.2.0.orig/libecasoundc/Makefile.am ecasound-2.2.0/libecasoundc/Makefile.am
+--- ecasound-2.2.0.orig/libecasoundc/Makefile.am       Mon Dec 16 05:20:39 2002
++++ ecasound-2.2.0/libecasoundc/Makefile.am    Sat Feb 15 11:07:07 2003
+@@ -8,9 +8,9 @@
+ # !!!
+ # remember to update eca-version.cpp
+ if ECA_AM_DEBUG_MODE
+-eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:0 -static
++eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:0
+ else
+-eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:0 -static
++eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:0
+ endif
+ INCLUDES = -I$(srcdir)
index 3e2660f954270060db515ebe6ce71837cfe38b73..8f67bf23d8ba5d2cc533b0e84830dca94100f329 100644 (file)
@@ -2,6 +2,7 @@
 #
 # todo:
 # - jack-audio-connection-kit support
+# - ladspa support? (configure checks for LADSPA)
 #
 
 #
@@ -15,7 +16,7 @@ Summary:      Software package for multitrack audio processing
 Summary(pl):   Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
 Name:          ecasound
 Version:       2.2.0
-Release:       2
+Release:       3
 License:       GPL
 Group:         Applications/Sound
 Source0:       http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
@@ -33,12 +34,7 @@ BuildRequires:       readline-devel >= 4.2
 BuildRequires: rpm-pythonprov
 Requires:      lame
 Requires:      mpg123
-# libecasound no longer supported
 Obsoletes:     libecasound
-Obsoletes:     libecasound-devel
-# packages depending on libecasound
-Obsoletes:     perl-Audio-Ecasound
-Obsoletes:     php-pecl-ecasound
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -74,6 +70,32 @@ tekstowy interfejs u
 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
 interfejs u¿ytkownika - qtecasound.
 
+%package devel
+Summary:       Header files for ecasound libraries
+Summary(pl):   Pliki nag³ówkowe bibliotek ecasound
+Group:         Development/Libraries
+Requires:      %{name} = %{version}
+Obsoletes:     libecasound-devel
+
+%description devel
+Header files for ecasound libraries.
+
+%description devel -l pl
+Pliki nag³ówkowe bibliotek ecasound.
+
+%package static
+Summary:       Static ecasound libraries
+Summary(pl):   Statyczne biblioteki ecasound
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+Obsoletes:     libecasound-static
+
+%description static
+Static ecasound libraries.
+
+%description static -l pl
+Statyczne biblioteki ecasound.
+
 %package -n python-%{name}
 Summary:       Python module for Ecasound
 Summary(pl):   Modu³ jêzyka Python dla programu ecasound
@@ -109,7 +131,8 @@ CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
        --disable-audiofile \
        --disable-arts \
        %{?_without_alsa:--disable-alsa} \
-       %{!?_without_alsa:--disable-oss}
+       %{!?_without_alsa:--disable-oss} \
+       --with-largefile
 
 %{__make}
 
@@ -126,15 +149,33 @@ install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc BUGS NEWS README TODO
 %attr(755,root,root) %{_bindir}/eca*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+
 %{_datadir}/ecasound
 
 %{_mandir}/man1/eca*
 %{_mandir}/man5/eca*
 
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/*-config
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/lib*.la
+%{_includedir}/kvutils
+%{_includedir}/libecasound
+%{_includedir}/libecasoundc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
+
 %files -n python-%{name}
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.137244 seconds and 4 git commands to generate.