]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- updated link patch:
[packages/ecasound.git] / ecasound.spec
1
2 #
3 # todo:
4 # - jack-audio-connection-kit support
5 # - ladspa support? (configure checks for LADSPA)
6 #
7
8 #
9 # Conditional build:
10 # _without_alsa - without ALSA support
11 #
12
13 %include        /usr/lib/rpm/macros.python
14
15 Summary:        Software package for multitrack audio processing
16 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
17 Name:           ecasound
18 Version:        2.2.0
19 Release:        3
20 License:        GPL
21 Group:          Applications/Sound
22 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
23 Patch0:         %{name}-link.patch
24 %ifnarch sparc sparc64
25 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
26 %endif
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:1.4d
31 BuildRequires:  python-devel >= 2.2
32 BuildRequires:  python-modules >= 2.2
33 BuildRequires:  readline-devel >= 4.2
34 BuildRequires:  rpm-pythonprov
35 Requires:       lame
36 Requires:       mpg123
37 Obsoletes:      libecasound
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Ecasound is a software package designed for multitrack audio
42 processing. It can be used for simple tasks like audio playback,
43 recording and format conversions, as well as for multitrack effect
44 processing, mixing, recording and signal recycling. Ecasound supports
45 a wide range of audio inputs, outputs and effect algorithms. Several
46 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
47 libaudiofile and MikMod, are directly supported. One of the advantages
48 of ecasound's chain-based design is that effects can easily be
49 combined both in series and in parallel. Oscillators and MIDI-CCs can
50 be used for controlling effect parameters. Included user-interfaces
51 are ecasound - a versatile console mode interface, qtecasound - a
52 Qt-based X-interface and various command-line utils suitable for batch
53 processing.
54
55 %description -l pl
56 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
57 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
58 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
59 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
60 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
61 wyrzucania zniekszta³ceñ) sygna³u.
62
63 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
64 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
65 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
66 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
67 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
68 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
69 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
70 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
71 interfejs u¿ytkownika - qtecasound.
72
73 %package devel
74 Summary:        Header files for ecasound libraries
75 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}
78 Obsoletes:      libecasound-devel
79
80 %description devel
81 Header files for ecasound libraries.
82
83 %description devel -l pl
84 Pliki nag³ówkowe bibliotek ecasound.
85
86 %package static
87 Summary:        Static ecasound libraries
88 Summary(pl):    Statyczne biblioteki ecasound
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}
91 Obsoletes:      libecasound-static
92
93 %description static
94 Static ecasound libraries.
95
96 %description static -l pl
97 Statyczne biblioteki ecasound.
98
99 %package -n python-%{name}
100 Summary:        Python module for Ecasound
101 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
102 Group:          Libraries/Python
103 %pyrequires_eq  python-modules
104
105 %description -n python-%{name}
106 Python module for Ecasound.
107
108 %description -n python-%{name} -l pl
109 Modu³ jêzyka Python dla programu ecasound.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 rm -f missing
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__automake}
121 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
122 # disable audiofile - ecasound has native support for wav and raw formats
123 # disable oss       - ecasound works nicely with alsa oss emulation;
124 #                     in case of alsa building conditional, the oss should
125 #                     be enabled
126 # disable arts      - 'not really useful' as said by ecasound author
127 %configure \
128         --enable-sys-readline \
129         --with-python-includes=%{py_incdir} \
130         --with-python-modules=%{py_libdir} \
131         --disable-audiofile \
132         --disable-arts \
133         %{?_without_alsa:--disable-alsa} \
134         %{!?_without_alsa:--disable-oss} \
135         --with-largefile
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{py_sitedir}
142
143 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
144
145 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
146 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
147 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc BUGS NEWS README TODO
158 %attr(755,root,root) %{_bindir}/eca*
159 %attr(755,root,root) %{_libdir}/lib*.so.*.*
160
161 %{_datadir}/ecasound
162
163 %{_mandir}/man1/eca*
164 %{_mandir}/man5/eca*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/*-config
169 %attr(755,root,root) %{_libdir}/lib*.so
170 %{_libdir}/lib*.la
171 %{_includedir}/kvutils
172 %{_includedir}/libecasound
173 %{_includedir}/libecasoundc
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/lib*.a
178
179 %files -n python-%{name}
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{py_sitedir}/*.so
182 %{py_sitedir}/*.py[co]
This page took 0.059018 seconds and 3 git commands to generate.