]> git.pld-linux.org Git - packages/dtc.git/blob - dtc.spec
- README.license is back as main <> devel don't depend on each other
[packages/dtc.git] / dtc.spec
1 # Conditional build:
2 %bcond_without  verbose         # verbose build (V=1)
3
4 Summary:        The Device Tree Compiler
5 Name:           dtc
6 Version:        1.1.0
7 Release:        0.1
8 License:        GPL v2 (dtc), GPL/BSD (fdt library)
9 Group:          Libraries
10 Source0:        http://www.jdl.com/software/%{name}-v%{version}.tgz
11 # Source0-md5:  46bcff355b60d85bd311fc95b9ff0630
12 URL:            http://git.jdl.com/gitweb/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %{?debug:%define with_verbose 1}
16
17 %description
18 The Device Tree Compiler, dtc, takes as input a device-tree in a given
19 format and outputs a device-tree in another format. Typically, the
20 input format is "dts", a human readable source format, and creates a
21 "dtb", or binary format as output.
22
23 %package devel
24 Summary:        Header files for fdt library
25 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fdt
26 Group:          Development/Libraries
27 # does not require base. see README.license
28
29 %description devel
30 Header files for fdt library.
31
32 %description devel -l pl.UTF-8
33 Pliki nagłówkowe biblioteki fdt.
34
35 %package static
36 Summary:        Static fdt library
37 Summary(pl.UTF-8):      Statyczna biblioteka fdt
38 Group:          Development/Libraries
39 Requires:       %{name}-devel = %{version}-%{release}
40
41 %description static
42 Static fdt library.
43
44 %description static -l pl.UTF-8
45 Statyczna biblioteka fdt.
46
47 %prep
48 %setup -q -n %{name}-v%{version}
49
50 %build
51 %{__make} \
52         %{?with_verbose:V=1} \
53         CC="%{__cc}" \
54         CFLAGS="%{rpmcflags}"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} install \
59         %{?with_verbose:V=1} \
60         PREFIX=%{_prefix} \
61         LIBDIR=%{_libdir} \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc TODO README.license Documentation/manual.txt
70 %attr(755,root,root) %{_bindir}/dtc
71
72 %files devel
73 %defattr(644,root,root,755)
74 %doc README.license
75 %{_includedir}/fdt.h
76 %{_includedir}/libfdt.h
77
78 %files static
79 %defattr(644,root,root,755)
80 %{_libdir}/libfdt.a
This page took 0.051011 seconds and 3 git commands to generate.