]> git.pld-linux.org Git - packages/dshowserver.git/blob - dshowserver.spec
- '#' is not rpm comment. It does not prevent macros from being expanded. Use
[packages/dshowserver.git] / dshowserver.spec
1 %define         svn                     101
2 Summary:        Win32 CoreAVC H.264 codec helper
3 Summary(pl.UTF-8):      Serwer windowsowego kodeka CoreAVC H.264.
4 Name:           dshowserver
5 Version:        0.%{svn}
6 Release:        0.1
7 License:        GPL v2
8 Group:          X11/Applications/Multimedia
9 Source0:        %{name}-0.svn%{svn}.tar.bz2
10 # Source0-md5:  9a5fefb6dc8e34114ae9ca99ee799eea
11 Patch0:         %{name}-codecspath.patch
12 Patch1:         %{name}-make.patch
13 URL:            http://code.google.com/p/coreavc-for-linux/
14 BuildRequires:  rpmbuild(macros) >= 1.453
15 BuildRequires:  sed >= 4.0
16 BuildRequires:  wine-devel
17 ExclusiveArch:  %{ix86}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         x8664_flags     -m32
21 %define         specflags_x86_64 %{x8664_flags}
22 %define         specflags_amd64 %{x8664_flags}
23 %define         specflags_ia32e %{x8664_flags}
24
25 %description
26 CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
27 much faster than any currently available open-source codecs. Being
28 multi-threaded, and able to play PAFF streams, it can handle HD
29 H.264/AVC streams that no freely available codecs can. CoreAVC is
30 reasonably priced, but it is Windows only. Dshowserver serves CoreAVC
31 for mythtv, mplayer and xine. Dshowserver can work under 32 or 64 bits
32 linux system. For 64 bits use static binary compiled in 32 bits
33 environement.
34
35 %description -l pl.UTF-8
36 CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie
37 szybszy od dowolnego wolnego kodeka. ObsÅ‚ugujac wielowatkowosc moze
38 odtwarzac strumienie zakodowane z uzyciem interlacingu PAFF. Odtwarza
39 strumienie HD H.264/AVC. Kosztuje rozsadnie, ale dostepny jest tylko
40 dla Windows. Dhowserevr implementuje obsluge tego kodeka przez mythtv,
41 mplayer i xine. Dshowserver moze byc uzyty w architekturach x86 i
42 x86_64. Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow
43 zbudowanych w 32 bitowym srodowisku.
44
45 %package -n registercodec
46 Summary:        Utility to register win32 CoreAVC H.264 codec
47 Summary(pl.UTF-8):      Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
48 Group:          X11/Applications/Multimedia
49
50 %description -n registercodec
51 Utility to register win32 CoreAVC H.264 codec for usage with
52 mythtv/mplayer/xine.
53
54 %description -n registercodec -l pl.UTF-8
55 Narzedzie do przeprowadzenia rejestracji komercyjnego kodeka CoreAVC
56 H.264.
57
58 %prep
59 %setup -q -n %{name}-svn%{svn}
60 %patch0 -p1
61 %patch1 -p1
62
63 %if "%{cc_version}" < "3.4"
64 # CC version is arbitary (just to be > 3.3)
65 %{__sed} -i -e 's/-Wno-pointer-sign//;s/-Wdeclaration-after-statement//' {loader,dshowserver}/Makefile
66 %endif
67
68 %build
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install -C dshowserver PREFIX=$RPM_BUILD_ROOT%{_prefix}
75 install  -d $RPM_BUILD_ROOT%{_mandir}/man1
76 #install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
77 #install dshowserver/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec
78 cp -a man/ds* $RPM_BUILD_ROOT%{_mandir}/man1
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %attr(755,root,video) %{_bindir}/dshowserver
87 %attr(755,root,video) %{_libdir}/dshowserver/dshowserver.exe.so
88 %{_mandir}/man1/ds*
89
90 %if 0
91 %files -n registercodec
92 %defattr(644,root,root,755)
93 %attr(755,root,video) %{_bindir}/registercodec
94 %{_mandir}/man1/re*
95 %endif
This page took 0.055172 seconds and 3 git commands to generate.