]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
BR unzip
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
2646c810 12Version: 2.8.2
77d2e1b5 13Release: 1
da4b87b9
ER
14License: Proprietary
15Group: Daemons
da4b87b9 16Source0: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
2646c810 17# NoSource0-md5: edd6e4dd3c4cf677668887ebbb7862c9
da4b87b9
ER
18NoSource: 0
19Source1: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
2646c810 20# NoSource1-md5: e5410eb64aa407be2d73c907417e75d3
da4b87b9 21NoSource: 1
284b53dc 22URL: http://www.dropbox.com/
da4b87b9
ER
23BuildRequires: rpmbuild(macros) >= 1.566
24BuildRequires: sed >= 4.0
25BuildRequires: tar >= 1:1.15.1
6b9a4628 26BuildRequires: unzip
5fe51dfe 27BuildRequires: zip
8c0a6f53 28Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
29ExclusiveArch: %{ix86} %{x8664}
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32# generate no Provides from private modules
33%define _noautoprovfiles %{_libdir}/%{name}
34
35# provided by package itself, but autodeps disabled
284b53dc 36%define _noautoreq libwx_.*.so librsync.so.1 libffi.so.6
da4b87b9
ER
37
38# a zip and executable at the same time
39%define _noautostrip .*/library.zip\\|.*/dropbox
40
41# debuginfo wouldn't be useful
42%define _enable_debug_packages 0
43
b70c96ae 44# prelinked library, it is missing some cairo symbols
45%define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
46
da4b87b9
ER
47%description
48Dropbox is software that syncs your files online and across your
49computers.
50
51Put your files into your Dropbox on one computer, and they'll be
52instantly available on any of your other computers that you've
53installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
54your files are stored on Dropbox's secure servers, you can also access
55them from any computer or mobile device using the Dropbox website.
56
eec680ba
ER
57%package gui
58Summary: Gtk+2 GUI of Dropbox
59Group: X11/Applications
60Requires: %{name} = %{version}-%{release}
61
62%description gui
63Gtk+2 Systray of Dropbox Daemon status.
64
da4b87b9
ER
65%prep
66%setup -qcT
67%ifarch %{ix86}
68%{__tar} --strip-components=1 -xzf %{SOURCE0}
69%endif
70%ifarch %{x8664}
71%{__tar} --strip-components=1 -xzf %{SOURCE1}
72%endif
73
84f5c3ef 74# no need to package this
284b53dc
ER
75# altho system python is also 2.7, don't know how to enforce using it system libs
76#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
77
78# libraries to be taken from system
79# for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
80%{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
84f5c3ef 81
da4b87b9
ER
82# make into symlink, looks cleaner than hardlink:
83# we can attach executable attrs to binary and leave no attrs for symlink in
84# %files section.
85ln -sf dropbox library.zip
86
84f5c3ef 87# fun, let's delete non-linux files from archive
9ece03ce
ER
88unzip -l library.zip | \
89 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pynt|pymac|ui/cocoa|unittest' | \
90 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
91 awk '{print $NF}' > lib.delete
77d2e1b5 92zip library.zip -d $(cat lib.delete)
f4d77724 93
da4b87b9
ER
94%install
95rm -rf $RPM_BUILD_ROOT
96install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 97ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
98
99# install everything else
77d2e1b5
ER
100install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
101cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
da4b87b9
ER
103
104# in doc
77d2e1b5 105%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(644,root,root,755)
14bae0cf 112%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 113%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5
ER
114%dir %{_libdir}/%{name}
115%attr(755,root,root) %{_libdir}/%{name}/*.so*
116%attr(755,root,root) %{_libdir}/%{name}/dropbox
117%attr(755,root,root) %{_libdir}/%{name}/dropboxd
118%{_libdir}/%{name}/library.zip
119
284b53dc
ER
120%{_libdir}/%{name}/cffi-*-py*.egg
121%{_libdir}/%{name}/distribute-*-py*.egg
122%{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
123%{_libdir}/%{name}/mock-*-py*.egg
124%{_libdir}/%{name}/pycparser-*-py*.egg-info
fae5f35a 125
eec680ba
ER
126%exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
127
128%files gui
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
77d2e1b5
ER
131%dir %{_libdir}/%{name}/images
132%{_libdir}/%{name}/images/emblems
133%{_libdir}/%{name}/images/hicolor
This page took 0.067377 seconds and 4 git commands to generate.