]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
cleanup more foreign py libraries
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
eec680ba 12Version: 2.6.33
77d2e1b5 13Release: 1
da4b87b9
ER
14License: Proprietary
15Group: Daemons
da4b87b9 16Source0: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
eec680ba 17# NoSource0-md5: 4155a85791150a40f97cff68ca2e0668
da4b87b9
ER
18NoSource: 0
19Source1: http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
eec680ba 20# NoSource1-md5: 72e52d33ab69f15be40247dd42c33d92
da4b87b9 21NoSource: 1
284b53dc 22URL: http://www.dropbox.com/
da4b87b9
ER
23BuildRequires: rpmbuild(macros) >= 1.566
24BuildRequires: sed >= 4.0
25BuildRequires: tar >= 1:1.15.1
5fe51dfe 26BuildRequires: zip
8c0a6f53 27Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
28ExclusiveArch: %{ix86} %{x8664}
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31# generate no Provides from private modules
32%define _noautoprovfiles %{_libdir}/%{name}
33
34# provided by package itself, but autodeps disabled
284b53dc 35%define _noautoreq libwx_.*.so librsync.so.1 libffi.so.6
da4b87b9
ER
36
37# a zip and executable at the same time
38%define _noautostrip .*/library.zip\\|.*/dropbox
39
40# debuginfo wouldn't be useful
41%define _enable_debug_packages 0
42
b70c96ae 43# prelinked library, it is missing some cairo symbols
44%define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
45
da4b87b9
ER
46%description
47Dropbox is software that syncs your files online and across your
48computers.
49
50Put your files into your Dropbox on one computer, and they'll be
51instantly available on any of your other computers that you've
52installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
53your files are stored on Dropbox's secure servers, you can also access
54them from any computer or mobile device using the Dropbox website.
55
eec680ba
ER
56%package gui
57Summary: Gtk+2 GUI of Dropbox
58Group: X11/Applications
59Requires: %{name} = %{version}-%{release}
60
61%description gui
62Gtk+2 Systray of Dropbox Daemon status.
63
da4b87b9
ER
64%prep
65%setup -qcT
66%ifarch %{ix86}
67%{__tar} --strip-components=1 -xzf %{SOURCE0}
68%endif
69%ifarch %{x8664}
70%{__tar} --strip-components=1 -xzf %{SOURCE1}
71%endif
72
84f5c3ef 73# no need to package this
284b53dc
ER
74# altho system python is also 2.7, don't know how to enforce using it system libs
75#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
76
77# libraries to be taken from system
78# for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
79%{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
84f5c3ef 80
da4b87b9
ER
81# make into symlink, looks cleaner than hardlink:
82# we can attach executable attrs to binary and leave no attrs for symlink in
83# %files section.
84ln -sf dropbox library.zip
85
84f5c3ef 86# fun, let's delete non-linux files from archive
9ece03ce
ER
87unzip -l library.zip | \
88 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pynt|pymac|ui/cocoa|unittest' | \
89 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
90 awk '{print $NF}' > lib.delete
77d2e1b5 91zip library.zip -d $(cat lib.delete)
f4d77724 92
da4b87b9
ER
93%install
94rm -rf $RPM_BUILD_ROOT
95install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 96ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
97
98# install everything else
77d2e1b5
ER
99install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
100cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
101%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
da4b87b9
ER
102
103# in doc
77d2e1b5 104%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
14bae0cf 111%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 112%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5
ER
113%dir %{_libdir}/%{name}
114%attr(755,root,root) %{_libdir}/%{name}/*.so*
115%attr(755,root,root) %{_libdir}/%{name}/dropbox
116%attr(755,root,root) %{_libdir}/%{name}/dropboxd
117%{_libdir}/%{name}/library.zip
118
284b53dc
ER
119%{_libdir}/%{name}/cffi-*-py*.egg
120%{_libdir}/%{name}/distribute-*-py*.egg
121%{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
122%{_libdir}/%{name}/mock-*-py*.egg
123%{_libdir}/%{name}/pycparser-*-py*.egg-info
fae5f35a 124
eec680ba
ER
125%exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
126
127%files gui
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
77d2e1b5
ER
130%dir %{_libdir}/%{name}/images
131%{_libdir}/%{name}/images/emblems
132%{_libdir}/%{name}/images/hicolor
This page took 0.105436 seconds and 4 git commands to generate.