]> git.pld-linux.org Git - packages/droidbattles.git/blob - droidbattles.spec
- removed two lines with define
[packages/droidbattles.git] / droidbattles.spec
1 Summary:        A game of programming
2 Summary(pl):    Gra w programowanie
3 Name:           droidbattles
4 Version:        1.0.4
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Games
8 Source0:        http://www.bluefire.nu/%{name}/%{name}-%{version}.tar.gz
9 Source1:        http://www.bluefire.nu/%{name}/bots-light-01-06-11.tar.gz
10 Source2:        %{name}.desktop
11 Source3:        %{name}.png
12 URL:            http://www.bluefire.nu/droidbattles/
13 BuildRequires:  qt-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16
17 %description
18 So, you're having this argument about who's the best programmer? Or
19 you just want to have some programming fun? What better way to do it
20 than a little game of AI programming.
21
22 In DroidBattles you design the bots by choosing which hardware they
23 should contain. Each bot can have up to 32 hardware devices that you
24 can choose freely from a list of available types. Examples include
25 weapons, armor, CPU:s, engines... etc.
26
27 When you have chosen the hardware it's time to program it. You make a
28 program (in an assembler like language) that is loaded into a virtual
29 RAM of the bot and then executed by the CPU device(s) you've included
30 with the bot. You communicate with your devices through simple in/out
31 instruktions.
32
33 Other features of DroidBattles includes team-battle and set up of
34 "rules" for a game, (you can enable/disable hardware devices and also
35 set the costs).
36
37 You can make the bot have it's own graphics that is shown when the
38 simulation runs. When everyhing is ready you assemble the program and
39 a .bot file is created. You can now test this bot against other bots
40 in the simulator, and hopefully your bot will crush it's opponents.
41
42 %description -l pl
43 A wiêc spierasz siê o to, kto jest najlepszym programist±? Lub po
44 prostu chcesz zaznaæ przyjemno¶ci programowania? Có¿ lepszego mo¿e byæ
45 od gry, w której programujesz Sztuczn± Inteligencjê.
46
47 W DroidBattles projektujesz boty wybieraj±c jaki hardware powinny
48 zawieraæ. Ka¿dy bot mo¿e pomie¶ciæ do 32 urz±dzeñ sprzêtowych, które
49 mo¿esz dowolnie wybieraæ z dostêpnej listy. Mog± to byæ bronie,
50 pancerz, CPU, silniki... etc.
51
52 Gdy wybra³e¶ ju¿ sprzêt, nadszed³ czas na zaprogramowanie. Tworzysz
53 program (w jêzyku podobnym do assemblera), który jest ³adowany do
54 wirtualnego RAMu bota, a nastêpnie wykonywany przez jednostki
55 przetwarzania, które zainstalowa³e¶ w bocie. Komunikujesz siê ze
56 swoimi urz±dzeniami za pomoc± prostych instrukcji wej¶cia/wyj¶cia.
57
58 W¶ród innych zalet DroidBattles mo¿na wymieniæ bitwy dru¿ynowe, jak i
59 zestawy "zasad" dla gry (mo¿esz w³±czaæ/wy³±czaæ urz±dzenia sprzêtowe,
60 a tak¿e ustawiaæ koszt.)
61
62 Mo¿esz stworzyæ dla bota jego w³asn± grafikê, która bêdzie pokazywana
63 podczas symulacji. Gdy wszystko jest gotowe, assemblujesz program i
64 utworzony zostaje plik .bot. Mo¿esz wtedy przetestowaæ bota w starciu
65 z innymi botami w symulatorze i przy dozie szczê¶cia zostaæ zwyciêzc±.
66
67 %prep
68 %setup -q
69 mkdir bots
70 cd bots
71 tar zxvf %{SOURCE1}
72
73 %build
74 find . -exec touch \{\} \;
75 %configure2_13 \
76         --enable-final
77
78 cd %{name}
79 cat installdir.cpp | sed 's@/usr/local/droidbattles@%{_datadir}/droidbattles@' > installdir.cpp.new
80 mv -f installdir.cpp.new installdir.cpp
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_applnkdir}/Games}
86
87 cd %{name}
88 %{__make} install DESTDIR=$RPM_BUILD_ROOT
89 rm docs/en/Makefile*
90 cd ..
91 for i in bots/*
92 do
93         mv $i $RPM_BUILD_ROOT/usr/local/%{name}/bots/
94 done
95 cd $RPM_BUILD_ROOT/usr
96 mv local/%{name} X11R6/share/
97 rm -rf X11R6/share/%{name}/doc
98 ln -s /usr/share/doc/%{name}-%{version} X11R6/share/%{name}/doc
99
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games
101 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS ChangeLog TODO
109 %doc %{name}/docs/en/*.html
110 %attr(755,root,root) %{_bindir}/*
111 %{_datadir}/droidbattles
112 %{_pixmapsdir}/*
113 %{_applnkdir}/Games/*
This page took 0.060103 seconds and 3 git commands to generate.