]> git.pld-linux.org Git - packages/dpx.git/blob - dpx.spec
- unconditional noarch subpackages
[packages/dpx.git] / dpx.spec
1 %define rel     4
2 %define subver  svn4
3 Summary:        SMPTE DPX v2 Image Format reader/writer library
4 Summary(pl.UTF-8):      Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2
5 Name:           dpx
6 Version:        0.5
7 Release:        0.%{subver}.%{rel}
8 License:        BSD
9 Group:          Libraries
10 # originally: svn checkout http://dpx.googlecode.com/svn/trunk/ dpx
11 Source0:        %{name}-%{subver}.tar.xz
12 # Source0-md5:  a6bf177cb29eaaefb5208f3dcf486658
13 Patch0:         %{name}-shared.patch
14 URL:            https://github.com/patrickpalmer/dpx
15 BuildRequires:  autoconf >= 2.61
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 SMPTE DPX v2 Image Format reader/writer library written in portable
26 C++.
27
28 %description -l pl.UTF-8
29 Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2, napisana
30 w przenośnym C++.
31
32 %package devel
33 Summary:        Header files for DPX library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DPX
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38
39 %description devel
40 Header files for DPX library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki DPX.
44
45 %package static
46 Summary:        Static DPX library
47 Summary(pl.UTF-8):      Statyczna biblioteka DPX
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static DPX library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka DPX.
56
57 %package apidocs
58 Summary:        DPX API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki DPX
60 Group:          Documentation
61 BuildArch:      noarch
62
63 %description apidocs
64 API and internal documentation for DPX library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki DPX.
68
69 %prep
70 %setup -q -n %{name}
71 %patch0 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__automake}
78 %configure \
79         --enable-shared
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS COPYING NEWS README
98 %attr(755,root,root) %{_bindir}/dpx2tiff
99 %attr(755,root,root) %{_bindir}/dpxheader
100 %attr(755,root,root) %{_libdir}/libdpx.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libdpx.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libdpx.so
106 %{_libdir}/libdpx.la
107 %{_includedir}/DPX*.h
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libdpx.a
112
113 %files apidocs
114 %defattr(644,root,root,755)
115 %doc doc/html/*.{css,html,png}
This page took 0.103412 seconds and 3 git commands to generate.