]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
- updated to 1.18.1
[packages/dpkg.git] / dpkg.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Package maintenance system for Debian Linux
3 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
4 Name:           dpkg
5 Version:        1.18.1
6 Release:        1
7 License:        GPL v2+
8 Group:          Applications/File
9 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
10 # Source0-md5:  809169e14489dbcc603dc011381fdc67
11 Patch0:         %{name}-md5.patch
12 URL:            http://packages.debian.org/search?keywords=dpkg
13 BuildRequires:  bzip2-devel
14 BuildRequires:  gettext-tools >= 0.18.2
15 BuildRequires:  libselinux-devel
16 BuildRequires:  perl-tools-pod
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.654
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRequires:  xz-devel
23 BuildRequires:  zlib-devel
24 Requires:       perl-base
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # blacklist false positives
28 %define         _noautoreq_perl         extra file in Tie::ExtraHash
29
30 %description
31 This package contains the programs to handle deb packages known from
32 Debian.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
36 Debiana.
37
38 %package -n libdpkg-devel
39 Summary:        dpkg library and header files
40 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
41 Group:          Development/Libraries
42 Requires:       bzip2-devel
43 Requires:       xz-devel
44 Requires:       zlib-devel
45
46 %description -n libdpkg-devel
47 dpkg library and header files.
48
49 %description -n libdpkg-devel -l pl.UTF-8
50 Biblioteka i pliki nagłówkowe dpkg.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 # "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
58 # (dpkg expects this header from FreeBSD-compatible libmd, having different API)
59 %configure \
60         ac_cv_header_md5_h=no \
61         PO4A="true" \
62         --disable-dselect \
63         --disable-silent-rules \
64         --disable-start-stop-daemon \
65         --with-admindir=/var/lib/%{name}
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
76
77 # obsoleted by pkg-config
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
79
80 # dpkg for main part, dpkg-dev for perl-based build script
81 # don't use --all-name to avoid e.g. dselect inclusion
82 %find_lang dpkg
83 %find_lang dpkg-dev
84 cat dpkg-dev.lang >>dpkg.lang
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files -f dpkg.lang
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog README THANKS TODO
92 %attr(755,root,root) %{_bindir}/dpkg*
93 %attr(755,root,root) %{_bindir}/update-alternatives
94 %dir %{_sysconfdir}/alternatives
95 %dir %{_sysconfdir}/dpkg
96 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
97
98 %dir %{_libdir}/dpkg
99 %dir %{_libdir}/dpkg/parsechangelog
100 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
101 %dir %{_datadir}/dpkg
102 %{_datadir}/dpkg/abitable
103 %{_datadir}/dpkg/cputable
104 %{_datadir}/dpkg/ostable
105 %{_datadir}/dpkg/triplettable
106 %{_datadir}/dpkg/*.mk
107
108 %{perl_vendorlib}/Dpkg.pm
109 %{perl_vendorlib}/Dpkg
110
111 %dir /var/lib/dpkg
112 %dir /var/lib/dpkg/alternatives
113 %dir /var/lib/dpkg/info
114 %dir /var/lib/dpkg/parts
115 %dir /var/lib/dpkg/updates
116
117 %{_mandir}/man1/dpkg*.1*
118 %{_mandir}/man1/update-alternatives.1*
119 %{_mandir}/man3/Dpkg.3*
120 %{_mandir}/man3/Dpkg::*.3*
121 %{_mandir}/man5/deb*.5*
122 %{_mandir}/man5/dpkg.cfg.5*
123 %lang(de) %{_mandir}/de/man1/dpkg*.1*
124 %lang(de) %{_mandir}/de/man1/update-alternatives.1*
125 %lang(de) %{_mandir}/de/man5/deb*.5*
126 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
127 %lang(es) %{_mandir}/es/man1/dpkg*.1*
128 %lang(es) %{_mandir}/es/man1/update-alternatives.1*
129 %lang(es) %{_mandir}/es/man5/deb*.5*
130 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
131 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
132 %lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
133 %lang(fr) %{_mandir}/fr/man5/deb*.5*
134 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
135 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
136 %lang(it) %{_mandir}/it/man1/dpkg*.1*
137 %lang(it) %{_mandir}/it/man1/update-alternatives.1*
138 %lang(it) %{_mandir}/it/man5/deb*.5*
139 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
140 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
141 %lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
142 %lang(ja) %{_mandir}/ja/man5/deb*.5*
143 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
144 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
145 %lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
146 %lang(pl) %{_mandir}/pl/man5/deb*.5*
147 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
148 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
149 %lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
150 %lang(sv) %{_mandir}/sv/man5/deb*.5*
151 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
152
153 %files -n libdpkg-devel
154 %defattr(644,root,root,755)
155 %{_libdir}/libdpkg.a
156 %{_includedir}/dpkg
157 %{_pkgconfigdir}/libdpkg.pc
This page took 0.174731 seconds and 3 git commands to generate.