]> git.pld-linux.org Git - packages/dpkg.git/blame - dpkg.spec
split "alternatives" subsystem not to conflict with chkconfig implementation
[packages/dpkg.git] / dpkg.spec
CommitLineData
1750f640
ER
1# TODO
2# - use same dir as chkconfig based "alternatives"-implementation for state dir?
3# - move it (/var/lib/dpkg/alternatives) to alternatives package?
1c3e1c0e 4%include /usr/lib/rpm/macros.perl
aea5b33f 5Summary: Package maintenance system for Debian Linux
b81e7419 6Summary(pl.UTF-8): Program do obsługi pakietów Debiana
aea5b33f 7Name: dpkg
8d2420e2 8Version: 1.18.4
1750f640 9Release: 2
99403999 10License: GPL v2+
71d0ff61 11Group: Applications/File
3477ad18 12Source0: ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
8d2420e2 13# Source0-md5: e95b513c89693f6ec3ab53b6b1c3defd
42d55ea9 14Patch0: %{name}-md5.patch
99403999 15URL: http://packages.debian.org/search?keywords=dpkg
dcaefd63 16BuildRequires: bzip2-devel
abb5ca11 17BuildRequires: gettext-tools >= 0.18.2
dcaefd63 18BuildRequires: libselinux-devel
dc9ed1c4 19BuildRequires: perl-tools-pod
1c3e1c0e 20BuildRequires: pkgconfig
1c3e1c0e 21BuildRequires: rpm-perlprov
1750f640 22BuildRequires: rpmbuild(macros) >= 1.654
3477ad18
JB
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
25BuildRequires: xz-devel
589726b5 26BuildRequires: zlib-devel
80622688 27Requires: perl-base
607070d7 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
aea5b33f 29
392fa822 30# blacklist false positives
c4540769 31%define _noautoreq_perl extra file in Tie::ExtraHash
392fa822 32
aea5b33f 33%description
99403999
JB
34This package contains the programs to handle deb packages known from
35Debian.
aea5b33f 36
f8701fb4
JR
37%description -l pl.UTF-8
38Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
71d0ff61 39Debiana.
289d26c0 40
99403999
JB
41%package -n libdpkg-devel
42Summary: dpkg library and header files
43Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
44Group: Development/Libraries
184a11e8
JB
45Requires: bzip2-devel
46Requires: xz-devel
47Requires: zlib-devel
99403999
JB
48
49%description -n libdpkg-devel
50dpkg library and header files.
51
52%description -n libdpkg-devel -l pl.UTF-8
53Biblioteka i pliki nagłówkowe dpkg.
54
1750f640
ER
55%package alternatives
56Summary: Maintain symbolic links determining default commands
57Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
58Group: Applications/System
59Requires: %{name} = %{version}-%{release}
60
61%description alternatives
62alternatives creates, removes, maintains and displays information
63about the symbolic links comprising the alternatives system. The
64alternatives system is a reimplementation of the Debian alternatives
65system.
66
67%description alternatives -l pl.UTF-8
68alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
69dowiązaniach symbolicznych obejmujących system alternatyw. System
70alternatyw to reimplementacja systemu alternatyw ("alternatives") z
71Debiana.
72
aea5b33f
JR
73%prep
74%setup -q
42d55ea9 75%patch0 -p1
aea5b33f
JR
76
77%build
663dd486
JB
78# "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
79# (dpkg expects this header from FreeBSD-compatible libmd, having different API)
71d0ff61 80%configure \
663dd486 81 ac_cv_header_md5_h=no \
e2582a24 82 PO4A="true" \
3477ad18 83 --disable-dselect \
99403999 84 --disable-silent-rules \
3477ad18 85 --disable-start-stop-daemon \
99403999 86 --with-admindir=/var/lib/%{name}
aea5b33f 87
dcaefd63 88%{__make}
aea5b33f
JR
89
90%install
91rm -rf $RPM_BUILD_ROOT
aea5b33f
JR
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
99403999 96%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
47be6b2f 97
ddae01a5
JB
98# obsoleted by pkg-config
99%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
100
99403999
JB
101# dpkg for main part, dpkg-dev for perl-based build script
102# don't use --all-name to avoid e.g. dselect inclusion
aea5b33f 103%find_lang dpkg
99403999
JB
104%find_lang dpkg-dev
105cat dpkg-dev.lang >>dpkg.lang
aea5b33f
JR
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files -f dpkg.lang
111%defattr(644,root,root,755)
99403999 112%doc AUTHORS ChangeLog README THANKS TODO
aea5b33f 113%attr(755,root,root) %{_bindir}/dpkg*
47be6b2f 114%dir %{_sysconfdir}/dpkg
99403999 115%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
47be6b2f 116
aea5b33f 117%dir %{_libdir}/dpkg
aea5b33f 118%dir %{_libdir}/dpkg/parsechangelog
47be6b2f 119%attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
47be6b2f 120%dir %{_datadir}/dpkg
fa52672c 121%{_datadir}/dpkg/abitable
47be6b2f
ER
122%{_datadir}/dpkg/cputable
123%{_datadir}/dpkg/ostable
124%{_datadir}/dpkg/triplettable
3e75a3a3 125%{_datadir}/dpkg/*.mk
99403999
JB
126
127%{perl_vendorlib}/Dpkg.pm
d52c6c83 128%{perl_vendorlib}/Dpkg
47be6b2f 129
aea5b33f 130%dir /var/lib/dpkg
99403999
JB
131%dir /var/lib/dpkg/alternatives
132%dir /var/lib/dpkg/info
133%dir /var/lib/dpkg/parts
134%dir /var/lib/dpkg/updates
135
136%{_mandir}/man1/dpkg*.1*
b8a00aaf 137%{_mandir}/man3/Dpkg.3*
99403999
JB
138%{_mandir}/man3/Dpkg::*.3*
139%{_mandir}/man5/deb*.5*
140%{_mandir}/man5/dpkg.cfg.5*
99403999
JB
141%lang(de) %{_mandir}/de/man1/dpkg*.1*
142%lang(de) %{_mandir}/de/man5/deb*.5*
143%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
99403999
JB
144%lang(es) %{_mandir}/es/man1/dpkg*.1*
145%lang(es) %{_mandir}/es/man5/deb*.5*
146%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
99403999
JB
147%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
148%lang(fr) %{_mandir}/fr/man5/deb*.5*
149%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
99403999 150%lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
42d55ea9
JB
151%lang(it) %{_mandir}/it/man1/dpkg*.1*
152%lang(it) %{_mandir}/it/man5/deb*.5*
153%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
3e75a3a3
JB
154%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
155%lang(ja) %{_mandir}/ja/man5/deb*.5*
156%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
99403999
JB
157%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
158%lang(pl) %{_mandir}/pl/man5/deb*.5*
159%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
99403999
JB
160%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
161%lang(sv) %{_mandir}/sv/man5/deb*.5*
162%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
99403999
JB
163
164%files -n libdpkg-devel
165%defattr(644,root,root,755)
166%{_libdir}/libdpkg.a
167%{_includedir}/dpkg
168%{_pkgconfigdir}/libdpkg.pc
1750f640
ER
169
170%files alternatives
171%defattr(644,root,root,755)
172%dir %{_sysconfdir}/alternatives
173%attr(755,root,root) %{_bindir}/update-alternatives
174%{_mandir}/man1/update-alternatives.1*
175%lang(de) %{_mandir}/de/man1/update-alternatives.1*
176%lang(es) %{_mandir}/es/man1/update-alternatives.1*
177%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
178%lang(it) %{_mandir}/it/man1/update-alternatives.1*
179%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
180%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
181%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
This page took 0.412235 seconds and 4 git commands to generate.