]> git.pld-linux.org Git - packages/dpkg.git/blame_incremental - dpkg.spec
split "alternatives" subsystem not to conflict with chkconfig implementation
[packages/dpkg.git] / dpkg.spec
... / ...
CommitLineData
1# TODO
2# - use same dir as chkconfig based "alternatives"-implementation for state dir?
3# - move it (/var/lib/dpkg/alternatives) to alternatives package?
4%include /usr/lib/rpm/macros.perl
5Summary: Package maintenance system for Debian Linux
6Summary(pl.UTF-8): Program do obsługi pakietów Debiana
7Name: dpkg
8Version: 1.18.4
9Release: 2
10License: GPL v2+
11Group: Applications/File
12Source0: ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
13# Source0-md5: e95b513c89693f6ec3ab53b6b1c3defd
14Patch0: %{name}-md5.patch
15URL: http://packages.debian.org/search?keywords=dpkg
16BuildRequires: bzip2-devel
17BuildRequires: gettext-tools >= 0.18.2
18BuildRequires: libselinux-devel
19BuildRequires: perl-tools-pod
20BuildRequires: pkgconfig
21BuildRequires: rpm-perlprov
22BuildRequires: rpmbuild(macros) >= 1.654
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
25BuildRequires: xz-devel
26BuildRequires: zlib-devel
27Requires: perl-base
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30# blacklist false positives
31%define _noautoreq_perl extra file in Tie::ExtraHash
32
33%description
34This package contains the programs to handle deb packages known from
35Debian.
36
37%description -l pl.UTF-8
38Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
39Debiana.
40
41%package -n libdpkg-devel
42Summary: dpkg library and header files
43Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
44Group: Development/Libraries
45Requires: bzip2-devel
46Requires: xz-devel
47Requires: zlib-devel
48
49%description -n libdpkg-devel
50dpkg library and header files.
51
52%description -n libdpkg-devel -l pl.UTF-8
53Biblioteka i pliki nagłówkowe dpkg.
54
55%package alternatives
56Summary: Maintain symbolic links determining default commands
57Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
58Group: Applications/System
59Requires: %{name} = %{version}-%{release}
60
61%description alternatives
62alternatives creates, removes, maintains and displays information
63about the symbolic links comprising the alternatives system. The
64alternatives system is a reimplementation of the Debian alternatives
65system.
66
67%description alternatives -l pl.UTF-8
68alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
69dowiązaniach symbolicznych obejmujących system alternatyw. System
70alternatyw to reimplementacja systemu alternatyw ("alternatives") z
71Debiana.
72
73%prep
74%setup -q
75%patch0 -p1
76
77%build
78# "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
79# (dpkg expects this header from FreeBSD-compatible libmd, having different API)
80%configure \
81 ac_cv_header_md5_h=no \
82 PO4A="true" \
83 --disable-dselect \
84 --disable-silent-rules \
85 --disable-start-stop-daemon \
86 --with-admindir=/var/lib/%{name}
87
88%{__make}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
96%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
97
98# obsoleted by pkg-config
99%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
100
101# dpkg for main part, dpkg-dev for perl-based build script
102# don't use --all-name to avoid e.g. dselect inclusion
103%find_lang dpkg
104%find_lang dpkg-dev
105cat dpkg-dev.lang >>dpkg.lang
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files -f dpkg.lang
111%defattr(644,root,root,755)
112%doc AUTHORS ChangeLog README THANKS TODO
113%attr(755,root,root) %{_bindir}/dpkg*
114%dir %{_sysconfdir}/dpkg
115%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
116
117%dir %{_libdir}/dpkg
118%dir %{_libdir}/dpkg/parsechangelog
119%attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
120%dir %{_datadir}/dpkg
121%{_datadir}/dpkg/abitable
122%{_datadir}/dpkg/cputable
123%{_datadir}/dpkg/ostable
124%{_datadir}/dpkg/triplettable
125%{_datadir}/dpkg/*.mk
126
127%{perl_vendorlib}/Dpkg.pm
128%{perl_vendorlib}/Dpkg
129
130%dir /var/lib/dpkg
131%dir /var/lib/dpkg/alternatives
132%dir /var/lib/dpkg/info
133%dir /var/lib/dpkg/parts
134%dir /var/lib/dpkg/updates
135
136%{_mandir}/man1/dpkg*.1*
137%{_mandir}/man3/Dpkg.3*
138%{_mandir}/man3/Dpkg::*.3*
139%{_mandir}/man5/deb*.5*
140%{_mandir}/man5/dpkg.cfg.5*
141%lang(de) %{_mandir}/de/man1/dpkg*.1*
142%lang(de) %{_mandir}/de/man5/deb*.5*
143%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
144%lang(es) %{_mandir}/es/man1/dpkg*.1*
145%lang(es) %{_mandir}/es/man5/deb*.5*
146%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
147%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
148%lang(fr) %{_mandir}/fr/man5/deb*.5*
149%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
150%lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
151%lang(it) %{_mandir}/it/man1/dpkg*.1*
152%lang(it) %{_mandir}/it/man5/deb*.5*
153%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
154%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
155%lang(ja) %{_mandir}/ja/man5/deb*.5*
156%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
157%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
158%lang(pl) %{_mandir}/pl/man5/deb*.5*
159%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
160%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
161%lang(sv) %{_mandir}/sv/man5/deb*.5*
162%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
163
164%files -n libdpkg-devel
165%defattr(644,root,root,755)
166%{_libdir}/libdpkg.a
167%{_includedir}/dpkg
168%{_pkgconfigdir}/libdpkg.pc
169
170%files alternatives
171%defattr(644,root,root,755)
172%dir %{_sysconfdir}/alternatives
173%attr(755,root,root) %{_bindir}/update-alternatives
174%{_mandir}/man1/update-alternatives.1*
175%lang(de) %{_mandir}/de/man1/update-alternatives.1*
176%lang(es) %{_mandir}/es/man1/update-alternatives.1*
177%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
178%lang(it) %{_mandir}/it/man1/update-alternatives.1*
179%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
180%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
181%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
This page took 0.064793 seconds and 4 git commands to generate.