]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- adaptarized
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP auth
4 %bcond_without  mysql   # without MySQL auth
5 %bcond_without  pgsql   # without PostgreSQL auth
6 %bcond_without  sasl    # without SASL auth
7 #
8 Summary:        IMAP and POP3 server written with security primarily in mind
9 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
10 Name:           dovecot
11 Version:        0.99.11
12 Release:        1
13 License:        LGPL v2.1
14 Group:          Networking/Daemons
15 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  05090ad784540b96c84f32080ada9f97
17 Source1:        %{name}.pamd
18 Source2:        %{name}.init
19 Source3:        %{name}.sysconfig
20 Patch0:         %{name}-config.patch
21 URL:            http://dovecot.procontrol.fi/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.0}
25 BuildRequires:  gettext-devel
26 BuildRequires:  libtool
27 %{?with_mysql:BuildRequires:    mysql-devel}
28 %{?with_ldap:BuildRequires:     openldap-devel}
29 BuildRequires:  openssl-devel >= 0.9.7d
30 BuildRequires:  pam-devel
31 BuildRequires:  pkgconfig
32 %{?with_pgsql:BuildRequires:    postgresql-devel}
33 Requires(post,preun):   /sbin/chkconfig
34 Requires:       pam >= 0.77.3
35 Provides:       imapdaemon
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
40 written with security primarily in mind. Although it's written with C,
41 it uses several coding techniques to avoid most of the common
42 pitfalls.
43
44 Dovecot can work with standard mbox and maildir formats and it's fully
45 compatible with UW-IMAP and Courier IMAP servers as well as mail
46 clients accessing the mailboxes directly. It's also planned to support
47 storing mails in SQL databases.
48
49 Dovecot is easy to set up and doesn't require special maintenance.
50 Only thing you need is to get the authentication working properly - if
51 your users are in /etc/passwd there's hardly anything you have to do.
52
53 Dovecot should be pretty fast, mostly because of index files that
54 Dovecot maintains; instead of having to scan through all the data in
55 mailbox, Dovecot can get most of the wanted information from index
56 with little effort.
57
58 Status:
59 - should be quite ready for use with normal IMAP clients
60 - complete IMAP4rev1 support
61 - supports THREAD and SORT extensions, required by many IMAP webmails
62 - complete TLS/SSL support, using either GNUTLS or OpenSSL
63 - IPv6 ready
64 - shared mailboxes aren't yet supported
65 - Maildir++ quota isn't yet supported; hard filesystem quota can also
66   be problematic
67 - mbox support isn't yet perfect - there's a few more or less
68   theoretical problems, but nothing too bad.
69
70 %description -l pl
71 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
72 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
73 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
74 pu³apek.
75
76 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
77 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
78 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
79 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
80
81 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
82 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
83 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
84 zmieniaæ.
85
86 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
87 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
88 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
89 wiêkszo¶æ potrzebnych informacji z indeksu.
90
91 Stan:
92 - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
93 - pe³na obs³uga IMAP4rev1
94 - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
95   IMAP
96 - obs³uga IPv6
97 - jeszcze nie ma wspó³dzielonych skrzynek
98 - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
99   systemach plików mo¿e sprawiaæ problemy
100 - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
101   lub bardziej teoretycznych problemów, ale nic strasznego.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{?debug:--enable-debug} \
115         %{?with_ldap:--with-ldap} \
116         %{?with_mysql:--with-mysql} \
117         %{?with_pgsql:--with-pgsql} \
118         %{?with_sasl:--with-cyrus-sasl2} \
119         --with-ssl=openssl \
120         --with-ssl-dir=/var/lib/openssl
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
132
133 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
134 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
135 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
136
137 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 /sbin/chkconfig --add dovecot
144 if [ -f /var/lock/subsys/dovecot ]; then
145         /etc/rc.d/init.d/dovecot restart >&2
146 else
147         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
148 fi
149
150 %preun
151 if [ "$1" = "0" ]; then
152         if [ -f /var/lock/subsys/dovecot ]; then
153                 /etc/rc.d/init.d/dovecot stop >&2
154         fi
155         /sbin/chkconfig --del dovecot
156 fi
157
158 %files
159 %defattr(644,root,root,755)
160 # COPYING contains some notes, not actual LGPL text
161 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
162 %attr(755,root,root) %{_sbindir}/%{name}
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
166 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
167 %attr(754,root,root) /etc/rc.d/init.d/%{name}
168 %attr(755,root,root) %{_libdir}/%{name}
This page took 0.051217 seconds and 4 git commands to generate.