]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- don't force dnotify; let configure choose best one; config moved to /etc/dovecot...
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP auth
4 %bcond_without  mysql   # without MySQL auth
5 %bcond_without  pgsql   # without PostgreSQL auth
6 %bcond_without  sqlite  # without  SQLite3 auth
7 %bcond_without  sasl    # without SASL auth
8 #
9 Summary:        IMAP and POP3 server written with security primarily in mind
10 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
11 Name:           dovecot
12 Version:        1.0.rc1
13 Release:        1
14 License:        LGPL v2.1
15 Group:          Networking/Daemons
16 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  44c5a528cb3b43089c1f4b562b660dc7
18 Source1:        %{name}.pamd
19 Source2:        %{name}.init
20 Source3:        %{name}.sysconfig
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-gssapi.patch
23 URL:            http://dovecot.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.0}
27 BuildRequires:  heimdal-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  libtool
30 %{?with_mysql:BuildRequires:    mysql-devel}
31 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
32 BuildRequires:  openssl-devel >= 0.9.7d
33 BuildRequires:  pam-devel
34 BuildRequires:  pkgconfig
35 %{?with_pgsql:BuildRequires:    postgresql-devel}
36 %{?with_sqlite:BuildRequires:   sqlite3-devel}
37 Requires(post,preun):   /sbin/chkconfig
38 Requires(postun):       /usr/sbin/groupdel
39 Requires(postun):       /usr/sbin/userdel
40 Requires(pre):  /bin/id
41 Requires(pre):  /usr/bin/getgid
42 Requires(pre):  /usr/sbin/groupadd
43 Requires(pre):  /usr/sbin/useradd
44 Requires:       pam >= 0.79.0
45 Provides:       group(dovecot)
46 Provides:       user(dovecot)
47 Provides:       imapdaemon
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
52 written with security primarily in mind. Although it's written with C,
53 it uses several coding techniques to avoid most of the common
54 pitfalls.
55
56 Dovecot can work with standard mbox and maildir formats and it's fully
57 compatible with UW-IMAP and Courier IMAP servers as well as mail
58 clients accessing the mailboxes directly. It's also planned to support
59 storing mails in SQL databases.
60
61 Dovecot is easy to set up and doesn't require special maintenance.
62 Only thing you need is to get the authentication working properly - if
63 your users are in /etc/passwd there's hardly anything you have to do.
64
65 Dovecot should be pretty fast, mostly because of index files that
66 Dovecot maintains; instead of having to scan through all the data in
67 mailbox, Dovecot can get most of the wanted information from index
68 with little effort.
69
70 Status:
71 - should be quite ready for use with normal IMAP clients
72 - complete IMAP4rev1 support
73 - supports THREAD and SORT extensions, required by many IMAP webmails
74 - complete TLS/SSL support, using either GNUTLS or OpenSSL
75 - IPv6 ready
76 - shared mailboxes aren't yet supported
77 - Maildir++ quota isn't yet supported; hard filesystem quota can also
78   be problematic
79 - mbox support isn't yet perfect - there's a few more or less
80   theoretical problems, but nothing too bad.
81
82 %description -l pl
83 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
84 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
85 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
86 pu³apek.
87
88 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
89 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
90 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
91 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
92
93 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
94 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
95 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
96 zmieniaæ.
97
98 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
99 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
100 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
101 wiêkszo¶æ potrzebnych informacji z indeksu.
102
103 Stan:
104 - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
105 - pe³na obs³uga IMAP4rev1
106 - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
107   IMAP
108 - obs³uga IPv6
109 - jeszcze nie ma wspó³dzielonych skrzynek
110 - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
111   systemach plików mo¿e sprawiaæ problemy
112 - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
113   lub bardziej teoretycznych problemów, ale nic strasznego.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119
120 %build
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         %{?debug:--enable-debug} \
128         %{?with_ldap:--with-ldap} \
129         %{?with_mysql:--with-mysql} \
130         %{?with_pgsql:--with-pgsql} \
131         %{?with_sasl:--with-cyrus-sasl2} \
132         %{?with_sqlite:--with-sqlite} \
133         --with-gssapi \
134         --with-ssl=openssl \
135         --with-ssl-dir=/var/lib/openssl \
136         --sysconfdir=/etc/%{name}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
143 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
144 install -d $RPM_BUILD_ROOT{/var/lib/dovecot,/var/run/dovecot/login}
145
146 %{__make} install \
147         moduledir=%{_libdir}/%{name}/plugins \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{dovecot-example.conf,dovecot.conf}
151
152 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
153 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
154 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
155
156 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %pre
162 %groupadd -g 172 dovecot
163 %useradd -u 172 -d /usr/share/empty -s /bin/false -c "Dovecot server" -g dovecot dovecot
164
165 %post
166 /sbin/chkconfig --add dovecot
167 if [ -f /var/lock/subsys/dovecot ]; then
168         /etc/rc.d/init.d/dovecot restart >&2
169 else
170         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
171 fi
172
173 %preun
174 if [ "$1" = "0" ]; then
175         if [ -f /var/lock/subsys/dovecot ]; then
176                 /etc/rc.d/init.d/dovecot stop >&2
177         fi
178         /sbin/chkconfig --del dovecot
179 fi
180
181 %postun
182 if [ "$1" = "0" ]; then
183         %userremove dovecot
184         %groupremove dovecot
185 fi
186
187 %files
188 %defattr(644,root,root,755)
189 # COPYING contains some notes, not actual LGPL text
190 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
191 %attr(755,root,root) %{_sbindir}/%{name}
192 %attr(755,root,root) %{_sbindir}/%{name}pw
193 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
196 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
198 %attr(754,root,root) /etc/rc.d/init.d/%{name}
199 %attr(755,root,root) %{_libdir}/%{name}
200 %dir /var/lib/dovecot
201 %dir /var/run/dovecot
202 %attr(750,root,dovecot) %dir /var/run/dovecot/login
This page took 0.057065 seconds and 4 git commands to generate.