]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- 1.0.2
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP auth
4 %bcond_without  mysql   # without MySQL auth
5 %bcond_without  pgsql   # without PostgreSQL auth
6 %bcond_without  sqlite  # without SQLite3 auth
7 %bcond_without  sasl    # without SASL auth
8 #
9 Summary:        IMAP and POP3 server written with security primarily in mind
10 Summary(pl.UTF-8):      Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
11 Name:           dovecot
12 Version:        1.0.2
13 Release:        1
14 License:        LGPL v2.1 and MIT
15 Group:          Networking/Daemons
16 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  769f0dd2750e7de521de3396999a09e5
18 Source1:        %{name}.pamd
19 Source2:        %{name}.init
20 Source3:        %{name}.sysconfig
21 Patch0:         %{name}-config.patch
22 #Patch1:                %{name}-branch.diff
23 Patch2:         %{name}-dspam-plugin.patch
24 URL:            http://dovecot.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.0}
28 BuildRequires:  krb5-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  libtool
31 %{?with_mysql:BuildRequires:    mysql-devel}
32 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
33 BuildRequires:  openssl-devel >= 0.9.7d
34 BuildRequires:  pam-devel
35 BuildRequires:  pkgconfig
36 %{?with_pgsql:BuildRequires:    postgresql-devel}
37 BuildRequires:  sed >= 4.0
38 %{?with_sqlite:BuildRequires:   sqlite3-devel}
39 Requires(post,preun):   /sbin/chkconfig
40 Requires(postun):       /usr/sbin/groupdel
41 Requires(postun):       /usr/sbin/userdel
42 Requires(pre):  /bin/id
43 Requires(pre):  /usr/bin/getgid
44 Requires(pre):  /usr/sbin/groupadd
45 Requires(pre):  /usr/sbin/useradd
46 Requires:       pam >= 0.79.0
47 Provides:       group(dovecot)
48 Provides:       user(dovecot)
49 Provides:       imapdaemon
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
54 written with security primarily in mind. Although it's written with C,
55 it uses several coding techniques to avoid most of the common
56 pitfalls.
57
58 Dovecot can work with standard mbox and maildir formats and it's fully
59 compatible with UW-IMAP and Courier IMAP servers as well as mail
60 clients accessing the mailboxes directly. It's also planned to support
61 storing mails in SQL databases.
62
63 Dovecot is easy to set up and doesn't require special maintenance.
64 Only thing you need is to get the authentication working properly - if
65 your users are in /etc/passwd there's hardly anything you have to do.
66
67 Dovecot should be pretty fast, mostly because of index files that
68 Dovecot maintains; instead of having to scan through all the data in
69 mailbox, Dovecot can get most of the wanted information from index
70 with little effort.
71
72 Status:
73 - should be quite ready for use with normal IMAP clients
74 - complete IMAP4rev1 and POP3 support
75 - supports THREAD, SORT and IDLE extensions, required by many IMAP
76   webmails
77 - complete TLS/SSL support
78 - IPv6 ready
79 - shared mailboxes aren't yet supported
80 - Maildir++ quota is supported, bad hard filesystem quota can be
81   problematic
82
83 %description -l pl.UTF-8
84 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
85 pisany głównie z myślą o bezpieczeństwie. Chociaż jest pisany w C,
86 używa kilku technik kodowania zapobiegających większości popularnych
87 pułapek.
88
89 Dovecot może działać ze standardowymi formatami mbox i maildir, jest
90 całkowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a także z
91 klientami pocztowymi bezpośrednio dostającymi się do skrzynek.
92 Planowana jest także obsługa przechowywania listów w bazach SQL.
93
94 Dovecot jest łatwy do skonfigurowania i nie wymaga specjalnego
95 nadzoru. Wystarczy tylko doprowadzić do działania uwierzytelnianie -
96 jeśli użytkownicy są w /etc/passwd, to właściwie nie trzeba nic
97 zmieniać.
98
99 Dovecot powinien być w miarę szybki, głównie z powodu plików
100 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
101 wszystkich danych w skrzynce, Dovecot może małym kosztem uzyskać
102 większość potrzebnych informacji z indeksu.
103
104 Stan:
105 - powinien być gotowy do użycia ze zwykłymi klientami IMAP
106 - pełna obsługa IMAP4rev1 i POP3
107 - obsługa rozszerzeń THREAD, SORT i IDLE, wymaganych przez wiele
108   webmaili IMAP
109 - obsługa IPv6
110 - pełna obsługa TLS/SSL
111 - quota Maildir++ jest obsługiwana, ale twarda quota na systemach
112   plików może być problematyczna
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 #%patch1 -p1
118 %patch2 -p1
119
120 %{__sed} -i 's,/usr/lib/dovecot,%{_libdir}/dovecot,g' dovecot-example.conf
121
122 %build
123 touch config.rpath
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         %{?debug:--enable-debug} \
131         %{?with_ldap:--with-ldap} \
132         %{?with_mysql:--with-mysql} \
133         %{?with_pgsql:--with-pgsql} \
134         %{?with_sasl:--with-cyrus-sasl2} \
135         %{?with_sqlite:--with-sqlite} \
136         --with-gssapi \
137         --with-ssl=openssl \
138         --with-ssl-dir=/var/lib/openssl \
139         --sysconfdir=/etc/%{name}
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
146 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
147 install -d $RPM_BUILD_ROOT{/var/lib/dovecot,/var/run/dovecot/login}
148
149 %{__make} install \
150         moduledir=%{_libdir}/%{name}/plugins \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{dovecot-example.conf,dovecot.conf}
154
155 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
156 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
157 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
158
159 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %pre
165 %groupadd -g 172 dovecot
166 %useradd -u 172 -d /usr/share/empty -s /bin/false -c "Dovecot server" -g dovecot dovecot
167
168 %post
169 /sbin/chkconfig --add dovecot
170 if [ -f /var/lock/subsys/dovecot ]; then
171         /etc/rc.d/init.d/dovecot restart >&2
172 else
173         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
174 fi
175
176 %preun
177 if [ "$1" = "0" ]; then
178         if [ -f /var/lock/subsys/dovecot ]; then
179                 /etc/rc.d/init.d/dovecot stop >&2
180         fi
181         /sbin/chkconfig --del dovecot
182 fi
183
184 %postun
185 if [ "$1" = "0" ]; then
186         %userremove dovecot
187         %groupremove dovecot
188 fi
189
190 %files
191 %defattr(644,root,root,755)
192 # COPYING contains some notes, not actual LGPL text
193 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f doc/wiki/*.txt
194 %attr(755,root,root) %{_sbindir}/%{name}
195 %attr(755,root,root) %{_sbindir}/%{name}pw
196 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
199 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
201 %attr(754,root,root) /etc/rc.d/init.d/%{name}
202 %attr(755,root,root) %{_libdir}/%{name}
203 %dir /var/lib/dovecot
204 %dir /var/run/dovecot
205 %attr(750,root,dovecot) %dir /var/run/dovecot/login
This page took 0.037208 seconds and 4 git commands to generate.