]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- up to 0.99.10.7
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 # _without_ldap         - without LDAP auth
4 # _without_pgsql        - without PostgreSQL auth
5 # _without_sasl         - without SASL auth
6 #
7 Summary:        IMAP and POP3 server written with security primarily in mind
8 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
9 Name:           dovecot
10 Version:        0.99.10.7
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Networking/Daemons
14 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  6e5f32be84901bf0f8c027f4a5a999ad
16 Source1:        %{name}.pamd
17 Source2:        %{name}.init
18 Source3:        %{name}.sysconfig
19 Patch0:         %{name}-config.patch
20 URL:            http://dovecot.procontrol.fi/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel >= 2.0}
24 BuildRequires:  libtool
25 %{!?_without_ldap:BuildRequires:        openldap-devel}
26 BuildRequires:  openssl-devel >= 0.9.7d
27 BuildRequires:  pam-devel
28 %{!?_without_pgsql:BuildRequires:       postgresql-devel}
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       pam >= 0.77.3
31 Provides:       imapdaemon
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
36 written with security primarily in mind. Although it's written with C,
37 it uses several coding techniques to avoid most of the common
38 pitfalls.
39
40 Dovecot can work with standard mbox and maildir formats and it's fully
41 compatible with UW-IMAP and Courier IMAP servers as well as mail
42 clients accessing the mailboxes directly. It's also planned to support
43 storing mails in SQL databases.
44
45 Dovecot is easy to set up and doesn't require special maintenance.
46 Only thing you need is to get the authentication working properly - if
47 your users are in /etc/passwd there's hardly anything you have to do.
48
49 Dovecot should be pretty fast, mostly because of index files that
50 Dovecot maintains; instead of having to scan through all the data in
51 mailbox, Dovecot can get most of the wanted information from index
52 with little effort.
53
54 Status:
55  - should be quite ready for use with normal IMAP clients
56  - complete IMAP4rev1 support
57  - supports THREAD and SORT extensions, required by many IMAP webmails
58  - complete TLS/SSL support, using either GNUTLS or OpenSSL
59  - IPv6 ready
60  - shared mailboxes aren't yet supported
61  - Maildir++ quota isn't yet supported; hard filesystem quota can also
62    be problematic
63  - mbox support isn't yet perfect - there's a few more or less
64    theoretical problems, but nothing too bad.
65
66 %description -l pl
67 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
68 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
69 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
70 pu³apek.
71
72 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
73 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
74 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
75 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
76
77 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
78 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
79 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
80 zmieniaæ.
81
82 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
83 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
84 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
85 wiêkszo¶æ potrzebnych informacji z indeksu.
86
87 Stan:
88  - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
89  - pe³na obs³uga IMAP4rev1
90  - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
91    IMAP
92  - obs³uga IPv6
93  - jeszcze nie ma wspó³dzielonych skrzynek
94  - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
95    systemach plików mo¿e sprawiaæ problemy
96  - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
97    lub bardziej teoretycznych problemów, ale nic strasznego.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         %{?debug:--enable-debug} \
111         %{!?_without_ldap:--with-ldap} \
112         %{!?_without_pgsql:--with-pgsql} \
113         %{!?_without_sasl:--with-cyrus-sasl2} \
114         --with-ssl=openssl \
115         --with-ssl-dir=/var/lib/openssl
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
127
128 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
129 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
130 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
131
132 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 /sbin/chkconfig --add dovecot
139 if [ -f /var/lock/subsys/dovecot ]; then
140         /etc/rc.d/init.d/dovecot restart >&2
141 else
142         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
143 fi
144
145 %preun
146 if [ "$1" = "0" ]; then
147         if [ -f /var/lock/subsys/dovecot ]; then
148                 /etc/rc.d/init.d/dovecot stop >&2
149         fi
150         /sbin/chkconfig --del dovecot
151 fi
152
153 %files
154 %defattr(644,root,root,755)
155 # COPYING contains some notes, not actual LGPL text
156 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
157 %attr(755,root,root) %{_sbindir}/%{name}
158 %config(noreplace) %verify(not size mtime md5) /etc/%{name}.conf
159 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/%{name}
160 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.imap
161 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
162 %attr(754,root,root) /etc/rc.d/init.d/%{name}
163 %attr(755,root,root) %{_libdir}/%{name}
This page took 0.0548 seconds and 4 git commands to generate.