]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- more auth mechanisms+bconds
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 # _without_ldap         - without LDAP auth
4 # _without_pgsql        - without PostgreSQL auth
5 # _without_sasl         - without SASL auth
6 #
7 Summary:        IMAP and POP3 server written with security primarily in mind
8 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
9 Name:           dovecot
10 Version:        0.99.10
11 Release:        0.1
12 License:        LGPL v2.1
13 Group:          Networking/Daemons
14 Source0:        http://dovecot.procontrol.fi/%{name}-%{version}.tar.gz
15 # Source0-md5:  26d8452366a28418cc8a114781a721b6
16 URL:            http://dovecot.procontrol.fi/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{!?_without_sasl:BuildRequires:        cyrus-sasl-devel >= 2.0}
20 BuildRequires:  libtool
21 %{!?_without_ldap:BuildRequires:        openldap-devel}
22 BuildRequires:  openssl-devel
23 BuildRequires:  pam-devel
24 %{!?_without_pgsql:BuildRequires:       postgresql-devel}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
29 written with security primarily in mind. Although it's written with C,
30 it uses several coding techniques to avoid most of the common
31 pitfalls.
32
33 Dovecot can work with standard mbox and maildir formats and it's fully
34 compatible with UW-IMAP and Courier IMAP servers as well as mail
35 clients accessing the mailboxes directly. It's also planned to support
36 storing mails in SQL databases.
37
38 Dovecot is easy to set up and doesn't require special maintenance.
39 Only thing you need is to get the authentication working properly - if
40 your users are in /etc/passwd there's hardly anything you have to do.
41
42 Dovecot should be pretty fast, mostly because of index files that
43 Dovecot maintains; instead of having to scan through all the data in
44 mailbox, Dovecot can get most of the wanted information from index with
45 little effort.
46
47 Status:
48  - should be quite ready for use with normal IMAP clients
49  - complete IMAP4rev1 support
50  - supports THREAD and SORT extensions, required by many IMAP webmails
51  - complete TLS/SSL support, using either GNUTLS or OpenSSL
52  - IPv6 ready
53  - shared mailboxes aren't yet supported
54  - Maildir++ quota isn't yet supported; hard filesystem quota can also
55    be problematic
56  - mbox support isn't yet perfect - there's a few more or less
57    theoretical problems, but nothing too bad.
58
59 %description -l pl
60 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
61 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
62 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
63 pu³apek.
64
65 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
66 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
67 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
68 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
69
70 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
71 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
72 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
73 zmieniaæ.
74
75 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
76 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
77 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
78 wiêkszo¶æ potrzebnych informacji z indeksu.
79
80 Stan:
81  - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
82  - pe³na obs³uga IMAP4rev1
83  - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
84    IMAP
85  - obs³uga IPv6
86  - jeszcze nie ma wspó³dzielonych skrzynek
87  - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
88    systemach plików mo¿e sprawiaæ problemy
89  - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka
90    mniej lub bardziej teoretycznych problemów, ale nic strasznego.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{?debug:--enable-debug} \
103         %{!?_without_ldap:--with-ldap} \
104         %{!?_without_pgsql:--with-pgsql} \
105         %{!?_without_sasl:--with-cyrus-sasl2} \
106         --with-ssl=openssl \
107         --with-ssl-dir=/var/lib/openssl
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 # COPYING contains some notes, not actual LGPL text
125 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
126 %attr(755,root,root) %{_sbindir}/dovecot
127 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dovecot.conf
128 %attr(755,root,root) %{_libdir}/dovecot
This page took 0.041903 seconds and 4 git commands to generate.