]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- up to 1.0.alpha5 (recommended stable version)
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP auth
4 %bcond_without  mysql   # without MySQL auth
5 %bcond_without  pgsql   # without PostgreSQL auth
6 %bcond_without  sasl    # without SASL auth
7 #
8 Summary:        IMAP and POP3 server written with security primarily in mind
9 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
10 Name:           dovecot
11 Version:        1.0.alpha5
12 Release:        1
13 License:        LGPL v2.1
14 Group:          Networking/Daemons
15 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  a3277835f04d73485ff5ce3cc3daeea7
17 Source1:        %{name}.pamd
18 Source2:        %{name}.init
19 Source3:        %{name}.sysconfig
20 Patch0:         %{name}-config.patch
21 Patch1: %{name}-gssapi.patch
22 URL:            http://dovecot.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.0}
26 BuildRequires:  gettext-devel
27 BuildRequires:  libtool
28 %{?with_mysql:BuildRequires:    mysql-devel}
29 %{?with_ldap:BuildRequires:     openldap-devel}
30 BuildRequires:  openssl-devel >= 0.9.7d
31 BuildRequires:  pam-devel
32 BuildRequires:  pkgconfig
33 %{?with_pgsql:BuildRequires:    postgresql-devel}
34 Requires(post,preun):   /sbin/chkconfig
35 Requires:       pam >= 0.79.0
36 Provides:       imapdaemon
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
41 written with security primarily in mind. Although it's written with C,
42 it uses several coding techniques to avoid most of the common
43 pitfalls.
44
45 Dovecot can work with standard mbox and maildir formats and it's fully
46 compatible with UW-IMAP and Courier IMAP servers as well as mail
47 clients accessing the mailboxes directly. It's also planned to support
48 storing mails in SQL databases.
49
50 Dovecot is easy to set up and doesn't require special maintenance.
51 Only thing you need is to get the authentication working properly - if
52 your users are in /etc/passwd there's hardly anything you have to do.
53
54 Dovecot should be pretty fast, mostly because of index files that
55 Dovecot maintains; instead of having to scan through all the data in
56 mailbox, Dovecot can get most of the wanted information from index
57 with little effort.
58
59 Status:
60 - should be quite ready for use with normal IMAP clients
61 - complete IMAP4rev1 support
62 - supports THREAD and SORT extensions, required by many IMAP webmails
63 - complete TLS/SSL support, using either GNUTLS or OpenSSL
64 - IPv6 ready
65 - shared mailboxes aren't yet supported
66 - Maildir++ quota isn't yet supported; hard filesystem quota can also
67   be problematic
68 - mbox support isn't yet perfect - there's a few more or less
69   theoretical problems, but nothing too bad.
70
71 %description -l pl
72 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
73 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
74 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
75 pu³apek.
76
77 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
78 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
79 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
80 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
81
82 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
83 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
84 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
85 zmieniaæ.
86
87 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
88 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
89 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
90 wiêkszo¶æ potrzebnych informacji z indeksu.
91
92 Stan:
93 - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
94 - pe³na obs³uga IMAP4rev1
95 - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
96   IMAP
97 - obs³uga IPv6
98 - jeszcze nie ma wspó³dzielonych skrzynek
99 - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
100   systemach plików mo¿e sprawiaæ problemy
101 - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
102   lub bardziej teoretycznych problemów, ale nic strasznego.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         %{?debug:--enable-debug} \
117         %{?with_ldap:--with-ldap} \
118         %{?with_mysql:--with-mysql} \
119         %{?with_pgsql:--with-pgsql} \
120         %{?with_sasl:--with-cyrus-sasl2} \
121         --with-ssl=openssl \
122         --with-ssl-dir=/var/lib/openssl
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
129 install -d $RPM_BUILD_ROOT/{%{_libdir},%{_bindir}
130
131 %{__make} install \
132         moduledir=%{_libdir}/%{name}/plugins \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
136
137 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
138 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
139 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
140
141 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/chkconfig --add dovecot
148 if [ -f /var/lock/subsys/dovecot ]; then
149         /etc/rc.d/init.d/dovecot restart >&2
150 else
151         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
152 fi
153
154 %preun
155 if [ "$1" = "0" ]; then
156         if [ -f /var/lock/subsys/dovecot ]; then
157                 /etc/rc.d/init.d/dovecot stop >&2
158         fi
159         /sbin/chkconfig --del dovecot
160 fi
161
162 %files
163 %defattr(644,root,root,755)
164 # COPYING contains some notes, not actual LGPL text
165 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
166 %attr(755,root,root) %{_sbindir}/%{name}
167 %attr(755,root,root) %{_sbindir}/%{name}pw
168 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
169 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
170 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
171 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
172 %attr(754,root,root) /etc/rc.d/init.d/%{name}
173 %attr(755,root,root) %{_libdir}/%{name}
This page took 0.04206 seconds and 4 git commands to generate.