]> git.pld-linux.org Git - packages/dovecot.git/blob - dovecot.spec
- up to beta3
[packages/dovecot.git] / dovecot.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP auth
4 %bcond_without  mysql   # without MySQL auth
5 %bcond_without  pgsql   # without PostgreSQL auth
6 %bcond_without  sqlite  # without  SQLite3 auth
7 %bcond_without  sasl    # without SASL auth
8 #
9 Summary:        IMAP and POP3 server written with security primarily in mind
10 Summary(pl):    Serwer IMAP i POP3 pisany g³ównie z my¶l± o bezpieczeñstwie
11 Name:           dovecot
12 Version:        1.0.beta3
13 Release:        1
14 License:        LGPL v2.1
15 Group:          Networking/Daemons
16 Source0:        http://dovecot.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  5418f9f7fe99e4f10bb82d9fe504138a
18 Source1:        %{name}.pamd
19 Source2:        %{name}.init
20 Source3:        %{name}.sysconfig
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-gssapi.patch
23 URL:            http://dovecot.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?with_sasl:BuildRequires:     cyrus-sasl-devel >= 2.0}
27 BuildRequires:  gettext-devel
28 BuildRequires:  libtool
29 %{?with_mysql:BuildRequires:    mysql-devel}
30 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
31 BuildRequires:  openssl-devel >= 0.9.7d
32 BuildRequires:  pam-devel
33 BuildRequires:  pkgconfig
34 %{?with_pgsql:BuildRequires:    postgresql-devel}
35 %{?with_sqlite:BuildRequires:   sqlite3-devel}
36 Requires(post,preun):   /sbin/chkconfig
37 Requires:       pam >= 0.79.0
38 Provides:       imapdaemon
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
43 written with security primarily in mind. Although it's written with C,
44 it uses several coding techniques to avoid most of the common
45 pitfalls.
46
47 Dovecot can work with standard mbox and maildir formats and it's fully
48 compatible with UW-IMAP and Courier IMAP servers as well as mail
49 clients accessing the mailboxes directly. It's also planned to support
50 storing mails in SQL databases.
51
52 Dovecot is easy to set up and doesn't require special maintenance.
53 Only thing you need is to get the authentication working properly - if
54 your users are in /etc/passwd there's hardly anything you have to do.
55
56 Dovecot should be pretty fast, mostly because of index files that
57 Dovecot maintains; instead of having to scan through all the data in
58 mailbox, Dovecot can get most of the wanted information from index
59 with little effort.
60
61 Status:
62 - should be quite ready for use with normal IMAP clients
63 - complete IMAP4rev1 support
64 - supports THREAD and SORT extensions, required by many IMAP webmails
65 - complete TLS/SSL support, using either GNUTLS or OpenSSL
66 - IPv6 ready
67 - shared mailboxes aren't yet supported
68 - Maildir++ quota isn't yet supported; hard filesystem quota can also
69   be problematic
70 - mbox support isn't yet perfect - there's a few more or less
71   theoretical problems, but nothing too bad.
72
73 %description -l pl
74 Dovecot to serwer IMAP i POP3 dla systemów linuksowych/uniksowych,
75 pisany g³ównie z my¶l± o bezpieczeñstwie. Chocia¿ jest pisany w C,
76 u¿ywa kilku technik kodowania zapobiegaj±cych wiêkszo¶ci popularnych
77 pu³apek.
78
79 Dovecot mo¿e dzia³aæ ze standardowymi formatami mbox i maildir, jest
80 ca³kowicie kompatybilny z serwerami UW-IMAP i Courier IMAP, a tak¿e z
81 klientami pocztowymi bezpo¶rednio dostaj±cymi siê do skrzynek.
82 Planowana jest tak¿e obs³uga przechowywania listów w bazach SQL.
83
84 Dovecot jest ³atwy do skonfigurowania i nie wymaga specjalnego
85 nadzoru. Wystarczy tylko doprowadziæ do dzia³ania uwierzytelnianie -
86 je¶li u¿ytkownicy s± w /etc/passwd, to w³a¶ciwie nie trzeba nic
87 zmieniaæ.
88
89 Dovecot powinien byæ w miarê szybki, g³ównie z powodu plików
90 indeksowych utrzymywanych przez serwer; zamiast potrzeby skanowania
91 wszystkich danych w skrzynce, Dovecot mo¿e ma³ym kosztem uzyskaæ
92 wiêkszo¶æ potrzebnych informacji z indeksu.
93
94 Stan:
95 - powinien byæ gotowy do u¿ycia ze zwyk³ymi klientami IMAP
96 - pe³na obs³uga IMAP4rev1
97 - obs³uga rozszerzeñ THREAD i SORT, wymaganych przez wiele webmaili
98   IMAP
99 - obs³uga IPv6
100 - jeszcze nie ma wspó³dzielonych skrzynek
101 - quota Maildir++ jeszcze nie jest obs³ugiwana; twarda quota na
102   systemach plików mo¿e sprawiaæ problemy
103 - obs³uga mboksów jeszcze nie jest idealna - jest jeszcze kilka mniej
104   lub bardziej teoretycznych problemów, ale nic strasznego.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         %{?debug:--enable-debug} \
119         %{?with_ldap:--with-ldap} \
120         %{?with_mysql:--with-mysql} \
121         %{?with_pgsql:--with-pgsql} \
122         %{?with_sasl:--with-cyrus-sasl2} \
123         %{?with_sqlite:--with-sqlite} \
124         --with-notify=dnotify \
125         --with-ssl=openssl \
126         --with-ssl-dir=/var/lib/openssl
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
133 install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir},/var/run/dovecot/login}
134
135 %{__make} install \
136         moduledir=%{_libdir}/%{name}/plugins \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{dovecot-example.conf,dovecot.conf}
140
141 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
142 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
143 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
144
145 touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 /sbin/chkconfig --add dovecot
152 if [ -f /var/lock/subsys/dovecot ]; then
153         /etc/rc.d/init.d/dovecot restart >&2
154 else
155         echo "Run \"/etc/rc.d/init.d/dovecot start\" to start dovecot daemon."
156 fi
157
158 %preun
159 if [ "$1" = "0" ]; then
160         if [ -f /var/lock/subsys/dovecot ]; then
161                 /etc/rc.d/init.d/dovecot stop >&2
162         fi
163         /sbin/chkconfig --del dovecot
164 fi
165
166 %files
167 %defattr(644,root,root,755)
168 # COPYING contains some notes, not actual LGPL text
169 %doc AUTHORS COPYING ChangeLog NEWS README TODO doc/*.txt doc/*.c*f
170 %attr(755,root,root) %{_sbindir}/%{name}
171 %attr(755,root,root) %{_sbindir}/%{name}pw
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
173 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
174 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
175 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
176 %attr(754,root,root) /etc/rc.d/init.d/%{name}
177 %attr(755,root,root) %{_libdir}/%{name}
178 %attr(700,root,root) %dir /var/run/dovecot
179 %attr(755,root,root) %dir /var/run/dovecot/login
This page took 0.07682 seconds and 3 git commands to generate.