]> git.pld-linux.org Git - packages/double-conversion.git/blob - double-conversion.spec
- x32 rebuild
[packages/double-conversion.git] / double-conversion.spec
1 #
2 # TODO
3 # - versioning in shared lib
4
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7
8 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
9 Name:           double-conversion
10 Version:        1.1.5
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  bf019021765fa346f85e46c6abf7c945
16 URL:            https://github.com/floitsch/double-conversion
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  scons >= 2.3.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This project (double-conversion) provides binary-decimal and
23 decimal-binary routines for IEEE doubles.
24
25 The library consists of efficient conversion routines that have been
26 extracted from the V8 JavaScript engine. The code has been refactored
27 and improved so that it can be used more easily in other projects.
28
29 %package devel
30 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Contains header files for developing applications that use the %{name}
36 library.
37
38 There is extensive documentation in src/double-conversion.h. Other
39 examples can be found in test/cctest/test-conversions.cc.
40
41 %package static
42 Summary:        Static %{name} library
43 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static %{name} library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka %{name}.
52
53 %prep
54 %setup -qc
55
56 %build
57 %scons \
58         CXX="%{__cxx}"
59         CXXFLAGS="%{__cxx}"
60
61 # avoid file exists errors, when entering install
62 rm -f libdouble-conversion.so libdouble-conversion.so.0
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
67 %scons install \
68         DESTDIR=$RPM_BUILD_ROOT \
69
70 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
71
72 %clean
73 %{__rm} -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc LICENSE README AUTHORS Changelog
81 %attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
82 %ghost %{_libdir}/libdouble-conversion.so.0
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_libdir}/libdouble-conversion.so
87 %{_includedir}/%{name}
88
89 %if %{with static_libs}
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libdouble-conversion.a
93 %{_libdir}/libdouble-conversion_pic.a
94 %endif
This page took 0.396833 seconds and 3 git commands to generate.