]> git.pld-linux.org Git - packages/double-conversion.git/blob - double-conversion.spec
- updated to 3.3.0
[packages/double-conversion.git] / double-conversion.spec
1 #
2 # TODO
3 # - versioning in shared lib
4
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_without  tests           # build without tests
8
9 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
10 Name:           double-conversion
11 Version:        1.1.5
12 Release:        2
13 License:        BSD
14 Group:          Libraries
15 Source0:        http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
16 # Source0-md5:  bf019021765fa346f85e46c6abf7c945
17 URL:            https://github.com/google/double-conversion
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  scons >= 2.3.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This project (double-conversion) provides binary-decimal and
24 decimal-binary routines for IEEE doubles.
25
26 The library consists of efficient conversion routines that have been
27 extracted from the V8 JavaScript engine. The code has been refactored
28 and improved so that it can be used more easily in other projects.
29
30 %package devel
31 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Contains header files for developing applications that use the %{name}
37 library.
38
39 There is extensive documentation in src/double-conversion.h. Other
40 examples can be found in test/cctest/test-conversions.cc.
41
42 %package static
43 Summary:        Static %{name} library
44 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static %{name} library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka %{name}.
53
54 %prep
55 %setup -qc
56
57 %build
58 %scons \
59         CXX="%{__cxx}"
60         CXXFLAGS="%{__cxx}"
61
62 %{?with_tests:%{__make} test}
63
64 # avoid file exists errors, when entering install
65 rm -f libdouble-conversion.so libdouble-conversion.so.0
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
70 %scons install \
71         DESTDIR=$RPM_BUILD_ROOT \
72
73 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
74
75 %clean
76 %{__rm} -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc LICENSE README AUTHORS Changelog
84 %attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
85 %ghost %{_libdir}/libdouble-conversion.so.0
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_libdir}/libdouble-conversion.so
90 %{_includedir}/%{name}
91
92 %if %{with static_libs}
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/libdouble-conversion.a
96 %{_libdir}/libdouble-conversion_pic.a
97 %endif
This page took 0.081905 seconds and 3 git commands to generate.