]> git.pld-linux.org Git - packages/double-conversion.git/blame - double-conversion.spec
- x32 rebuild
[packages/double-conversion.git] / double-conversion.spec
CommitLineData
a6527f0c
ER
1#
2# TODO
3# - versioning in shared lib
4
5# Conditional build:
6%bcond_without static_libs # don't build static libraries
7
002c3a9e
ER
8Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
9Name: double-conversion
0f85dd04 10Version: 1.1.5
8cea968b 11Release: 2
002c3a9e
ER
12License: BSD
13Group: Libraries
14Source0: http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
0f85dd04 15# Source0-md5: bf019021765fa346f85e46c6abf7c945
79650efe 16URL: https://github.com/floitsch/double-conversion
002c3a9e 17BuildRequires: libstdc++-devel
09cc3773 18BuildRequires: scons >= 2.3.0
002c3a9e
ER
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
95c391f9
ER
22This project (double-conversion) provides binary-decimal and
23decimal-binary routines for IEEE doubles.
24
25The library consists of efficient conversion routines that have been
26extracted from the V8 JavaScript engine. The code has been refactored
27and improved so that it can be used more easily in other projects.
002c3a9e
ER
28
29%package devel
30Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description devel
95c391f9
ER
35Contains header files for developing applications that use the %{name}
36library.
37
38There is extensive documentation in src/double-conversion.h. Other
39examples can be found in test/cctest/test-conversions.cc.
002c3a9e 40
af4206ea
ER
41%package static
42Summary: Static %{name} library
43Summary(pl.UTF-8): Statyczna biblioteka %{name}
44Group: Development/Libraries
45Requires: %{name}-devel = %{version}-%{release}
46
47%description static
48Static %{name} library.
49
50%description static -l pl.UTF-8
51Statyczna biblioteka %{name}.
52
002c3a9e 53%prep
48fe636d 54%setup -qc
002c3a9e
ER
55
56%build
3a886c7c 57%scons \
3a886c7c
ER
58 CXX="%{__cxx}"
59 CXXFLAGS="%{__cxx}"
002c3a9e 60
09cc3773 61# avoid file exists errors, when entering install
48fe636d 62rm -f libdouble-conversion.so libdouble-conversion.so.0
09cc3773 63
002c3a9e
ER
64%install
65rm -rf $RPM_BUILD_ROOT
66install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
a6527f0c
ER
67%scons install \
68 DESTDIR=$RPM_BUILD_ROOT \
002c3a9e 69
a54fc8c4 70cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
002c3a9e
ER
71
72%clean
73%{__rm} -rf $RPM_BUILD_ROOT
74
a6527f0c
ER
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
002c3a9e
ER
78%files
79%defattr(644,root,root,755)
7a858767 80%doc LICENSE README AUTHORS Changelog
48fe636d
ER
81%attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
82%ghost %{_libdir}/libdouble-conversion.so.0
002c3a9e
ER
83
84%files devel
85%defattr(644,root,root,755)
48fe636d 86%{_libdir}/libdouble-conversion.so
a6527f0c
ER
87%{_includedir}/%{name}
88
89%if %{with static_libs}
90%files static
91%defattr(644,root,root,755)
48fe636d
ER
92%{_libdir}/libdouble-conversion.a
93%{_libdir}/libdouble-conversion_pic.a
a6527f0c 94%endif
This page took 0.105458 seconds and 4 git commands to generate.