]> git.pld-linux.org Git - packages/dotnet-webkitgtk-sharp.git/blob - dotnet-webkitgtk-sharp.spec
update BR
[packages/dotnet-webkitgtk-sharp.git] / dotnet-webkitgtk-sharp.spec
1 # TODO
2 # - fix docs build
3 # - update descs (this is dor gtk3)
4 # - cleanup/update deps
5 #
6 # Conditional build:
7 %bcond_with     doc             # build with tests
8
9 %include        /usr/lib/rpm/macros.mono
10 Summary:        C# bindings for WebKitGTK+ 3.0 using GObject Introspection
11 Summary(pl.UTF-8):      WebKit# - wiązanie WebKit dla Mono
12 Name:           dotnet-webkitgtk-sharp
13 Version:        2.0.0
14 Release:        0.5
15 License:        LGPL v3
16 Group:          Libraries
17 Source0:        https://github.com/xDarkice/webkitgtk-sharp/releases/download/%{version}/webkitgtk-sharp-%{version}.tar.gz
18 # Source0-md5:  259d1b85975a93b878fa1bdc4254e83f
19 Patch0:         pkgconfig.patch
20 URL:            https://github.com/xDarkice/webkitgtk-sharp/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  dotnet-gtk-sharp3-devel >= 2.99.2
24 BuildRequires:  dotnet-soup-sharp-devel
25 BuildRequires:  gtk-webkit3-devel >= 2.0
26 BuildRequires:  mono-csharp >= 1.1.0
27 BuildRequires:  mono-devel
28 BuildRequires:  monodoc >= 2.6
29 BuildRequires:  pkgconfig
30 BuildRequires:  sed >= 4.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 WebKit is a web content engine, derived from KHTML and KJS from KDE,
35 and used primarily in Apple's Safari browser. It is made to be
36 embedded in other applications, such as mail readers, or web browsers.
37
38 This package provides Mono bindings for WebKit libraries.
39
40 %description -l pl.UTF-8
41 WebKit to silnik przeglądarki internetowej, wywodzący się z projektów
42 KHTML i KJS dla platformy KDE, używany głównie w przeglądarce Safari
43 firmy Apple. Stworzony został aby móc osadzać go w innych aplikacjach,
44 takich jak czytniki poczty czy przeglądarki stron internetowych.
45
46 Ten pakiet dostarcza dowiązań Mono do bibliotek WebKit.
47
48 %package devel
49 Summary:        WebKit# development files
50 Summary(pl.UTF-8):      Pliki programistyczne WebKit#
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       monodoc >= 2.6
54
55 %description devel
56 WebKit# development files.
57
58 %description devel -l pl.UTF-8
59 Pliki programistyczne WebKit#.
60
61 %prep
62 %setup -q -n webkitgtk-sharp-%{version}
63 %patch0 -p1
64
65 %{__sed} -i -e '/SUBDIRS/ s/doc//' Makefile.am
66
67 %build
68 %{__aclocal} -I m4
69 %{__autoconf}
70 %{__automake}
71 %configure \
72         --disable-static
73 %{__make}
74 %{?with_doc:%{__make} -C doc}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtksharpglue-*.la
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog
89 %{_prefix}/lib/mono/gac/webkitgtk-sharp
90 %attr(755,root,root) %{_libdir}/libwebkitgtksharpglue-1.10.2.so
91 # -devel or runtime resource?
92 %{_datadir}/gapi-3.0/webkitgtk-sharp-api.xml
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_prefix}/lib/mono/webkitgtk-sharp
97 %{_pkgconfigdir}/webkitgtk-sharp-3.0.pc
98 # docs subpackage?
99 %{?with_doc:%{_prefix}/lib/monodoc/sources/webkit-sharp-docs*}
This page took 0.072244 seconds and 3 git commands to generate.