]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
- BR: libpng-devel, ncurses-devel, python, python-modules
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3
4 %define         subver  beta6.7
5 %define         rel             1
6 Summary:        jDoom, jHeretic and jHexen for Linux
7 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
8 Name:           doomsday
9 Version:        1.9.0
10 Release:        0.%{subver}.%{rel}
11 License:        GPL v2 / CC 3.0 (icons)
12 Group:          Applications/Games
13 Source0:        http://dl.sourceforge.net/project/deng/Doomsday%20Engine/%{version}-%{subver}/deng-%{version}-%{subver}.tar.gz
14 # Source0-md5:  9c706df9a3f078b9b62af842e09b088e
15 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
16 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
17 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
18 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
19 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
20 # Source3-md5:  c89e36c49eabe2846137f313a5250308
21 URL:            http://www.doomsdayhq.com/
22 BuildRequires:  OpenAL-devel
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel >= 1.2.0
26 BuildRequires:  SDL_mixer-devel
27 BuildRequires:  SDL_net-devel
28 BuildRequires:  cmake >= 2.4
29 BuildRequires:  curl-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  python
33 BuildRequires:  python-modules
34 BuildRequires:  rpmbuild(macros) >= 1.213
35 BuildRequires:  zip
36 Requires:       TiMidity++
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 jDoom, jHeretic and jHexen for Linux.
41
42 %description -l pl.UTF-8
43 jDoom, jHeretic i jHexen dla Linuksa.
44
45 %prep
46 %setup -q -n deng-%{version}-%{subver}
47
48 %build
49 install -d build
50 cd build
51 %cmake \
52         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
53         -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
54         -Dlibdir=%{_libdir} \
55         ../doomsday
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_desktopdir}
61
62 %{__make} -C build install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
66 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
67 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
68 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
69
70 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
71 [Desktop Entry]
72 Name=Doom
73 Comment=Doom for linux
74 Exec=doomsday -game jdoom
75 Icon=doom.png
76 Terminal=false
77 Type=Application
78 Categories=Game;FirstPersonGame;
79 Encoding=UTF-8
80 # vi: encoding=utf-8
81 EOF
82
83 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
84 [Desktop Entry]
85 Name=Hexen
86 Comment=Hexen for linux
87 Exec=doomsday -game jhexen
88 Icon=hexen.png
89 Terminal=false
90 Type=Application
91 Categories=Game;FirstPersonGame;
92 Encoding=UTF-8
93 # vi: encoding=utf-8
94 EOF
95
96 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
97 [Desktop Entry]
98 Name=Heretic
99 Comment=Heretic for linux
100 Exec=doomsday -game jheretic
101 Icon=heretic.png
102 Terminal=false
103 Type=Application
104 Categories=Game;FirstPersonGame;
105 Encoding=UTF-8
106 # vi: encoding=utf-8
107 EOF
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 if [ "$1" = "1" ]; then
114         %banner -e %{name} <<-EOF
115         To run doomsday you need some WAD file: either freedoom package
116         or some shareware or commercial WAD from Doom or Heretic:
117         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
118         Heretic.wad or Heretic1.wad.
119         When you have them, run doomsday with:
120         doomsday -game [ jdoom | jheretic | jhexen ]
121 EOF
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %doc doomsday/build/README
127 %attr(755,root,root) %{_bindir}/doomsday
128 %attr(755,root,root) %{_libdir}/libdpdehread.so
129 %attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
130 %attr(755,root,root) %{_libdir}/libjdoom.so
131 %attr(755,root,root) %{_libdir}/libjheretic.so
132 %attr(755,root,root) %{_libdir}/libjhexen.so
133 %{_datadir}/deng
134 %{_desktopdir}/*.desktop
135 %{_pixmapsdir}/*.png
This page took 0.0788720000000001 seconds and 3 git commands to generate.