]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
- use %banner
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3 Summary:        jDoom, jHeretic and jHexen for Linux
4 Summary(pl):    jDoom, jHeretic i jHexen dla Linuksa
5 Name:           doomsday
6 Version:        1.8.5
7 Release:        0.4
8 License:        GPL v2
9 Group:          Applications/Games
10 Source0:        http://dl.sourceforge.net/deng/deng-%{version}.tar.gz
11 # Source0-md5:  0e1f34ebddae77315765ce089e88a9f3
12 Patch0:         %{name}-ncurses.patch
13 Patch1:         %{name}-runtimedir.patch
14 URL:            http://www.doomsdayhq.com/
15 BuildRequires:  OpenAL-devel
16 BuildRequires:  OpenGL-devel
17 BuildRequires:  SDL-devel >= 1.2.0
18 BuildRequires:  SDL_mixer-devel
19 BuildRequires:  SDL_net-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  rpmbuild(macros) >= 1.194
23 Requires(post): /sbin/ldconfig
24 Requires:               TiMidity++
25 # it's FUBAR by storing pointers in int struct fields
26 ExcludeArch:    alpha amd64 ia64 ppc64 s390x sparc64
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 jDoom, jHeretic and jHexen for Linux.
33
34 %description -l pl
35 jDoom, jHeretic i jHexen dla Linuksa.
36
37 %prep
38 %setup -q -n deng-%{version}
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 %{__aclocal}
44 %{__autoconf}
45 %{__automake}
46
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_desktopdir}
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
58 [Desktop Entry]
59 Name=Doom
60 Comment=Doom for linux
61 Exec=doomsday -game jdoom
62 #Icon=hexen.png
63 Terminal=false
64 Type=Application
65 Category=Game;FPP;
66 Encoding=UTF-8
67 # vi: encoding=utf-8
68 EOF
69
70 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
71 [Desktop Entry]
72 Name=Hexen
73 Comment=Hexen for linux
74 Exec=doomsday -game jhexen
75 #Icon=heretic.png
76 Terminal=false
77 Type=Application
78 Category=Game;FPP;
79 Encoding=UTF-8
80 # vi: encoding=utf-8
81 EOF
82
83 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
84 [Desktop Entry]
85 Name=Heretic
86 Comment=Heretic for linux
87 Exec=doomsday -game jheretic
88 #Icon=heretic.png
89 Terminal=false
90 Type=Application
91 Category=Game;FPP;
92 Encoding=UTF-8
93 # vi: encoding=utf-8
94 EOF
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/ldconfig
101 if [ "$1" = "1" ]; then
102         %banner -e %{name} <<-EOF
103         To run doomsday you need some WAD file: either freedoom package
104         or some shareware or commercial WAD from Doom or Heretic:
105         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
106         Heretic.wad or Heretic1.wad.
107         When you have them, run doomsday with:
108         doomsday -game [ jdoom | jheretic | jhexen ]
109 EOF
110 fi
111
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc Doc/*
117 %attr(755,root,root) %{_bindir}/doomsday
118 %attr(755,root,root) %{_libdir}/*.so.*.*.*
119 %{_libdir}/*.la
120 %{_datadir}/deng
121 %{_desktopdir}/*.desktop
This page took 0.400925 seconds and 3 git commands to generate.