]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
- works for me; rel 1
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3
4 %define         subver  beta6.4
5 %define         rel             1
6 Summary:        jDoom, jHeretic and jHexen for Linux
7 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
8 Name:           doomsday
9 Version:        1.9.0
10 Release:        0.%{subver}.%{rel}
11 License:        GPL v2
12 Group:          Applications/Games
13 Source0:        http://dl.sourceforge.net/deng/deng-%{version}-%{subver}.tar.gz
14 # Source0-md5:  63fdbc11f0473535f7206f62952a1e2e
15 URL:            http://www.doomsdayhq.com/
16 BuildRequires:  OpenAL-devel
17 BuildRequires:  OpenGL-GLU-devel
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  SDL_net-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  cmake >= 2.4
25 BuildRequires:  curl-devel
26 BuildRequires:  rpmbuild(macros) >= 1.213
27 BuildRequires:  zip
28 Requires:       TiMidity++
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 jDoom, jHeretic and jHexen for Linux.
33
34 %description -l pl.UTF-8
35 jDoom, jHeretic i jHexen dla Linuksa.
36
37 %prep
38 %setup -q -n deng-%{version}-%{subver}
39
40 %build
41 install -d build
42 cd build
43 %cmake \
44         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
45         -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
46         -Dlibdir=%{_libdir} \
47         ../doomsday
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_desktopdir}
53
54 %{__make} -C build install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
58 [Desktop Entry]
59 Name=Doom
60 Comment=Doom for linux
61 Exec=doomsday -game jdoom
62 #Icon=hexen.png
63 Terminal=false
64 Type=Application
65 Categories=Game;FirstPersonGame;
66 Encoding=UTF-8
67 # vi: encoding=utf-8
68 EOF
69
70 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
71 [Desktop Entry]
72 Name=Hexen
73 Comment=Hexen for linux
74 Exec=doomsday -game jhexen
75 #Icon=heretic.png
76 Terminal=false
77 Type=Application
78 Categories=Game;FirstPersonGame;
79 Encoding=UTF-8
80 # vi: encoding=utf-8
81 EOF
82
83 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
84 [Desktop Entry]
85 Name=Heretic
86 Comment=Heretic for linux
87 Exec=doomsday -game jheretic
88 #Icon=heretic.png
89 Terminal=false
90 Type=Application
91 Categories=Game;FirstPersonGame;
92 Encoding=UTF-8
93 # vi: encoding=utf-8
94 EOF
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 if [ "$1" = "1" ]; then
101         %banner -e %{name} <<-EOF
102         To run doomsday you need some WAD file: either freedoom package
103         or some shareware or commercial WAD from Doom or Heretic:
104         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
105         Heretic.wad or Heretic1.wad.
106         When you have them, run doomsday with:
107         doomsday -game [ jdoom | jheretic | jhexen ]
108 EOF
109 fi
110
111 %files
112 %defattr(644,root,root,755)
113 %doc doomsday/build/README
114 %attr(755,root,root) %{_bindir}/doomsday
115 %attr(755,root,root) %{_libdir}/libdpdehread.so
116 %attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
117 %attr(755,root,root) %{_libdir}/libjdoom.so
118 %attr(755,root,root) %{_libdir}/libjheretic.so
119 %attr(755,root,root) %{_libdir}/libjhexen.so
120 %{_datadir}/deng
121 %{_desktopdir}/*.desktop
This page took 0.071057 seconds and 3 git commands to generate.