]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
cleanup
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - sync pl
3 # - clean up spec. cleanup what?
4 %define         subver  stable
5 Summary:        jDoom, jHeretic and jHexen for Linux
6 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
7 Name:           doomsday
8 Version:        1.15.4
9 Release:        0.1
10 License:        GPL v2 / CC 3.0 (icons)
11 Group:          Applications/Games
12 Source0:        http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
13 # Source0-md5:  8329eacdea73edca7aea4034ca8d78aa
14 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
15 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
16 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
17 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
18 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
19 # Source3-md5:  c89e36c49eabe2846137f313a5250308
20 Source4:        %{name}-doom.desktop
21 Source5:        %{name}-heretic.desktop
22 Source6:        %{name}-hexen.desktop
23 #Patch0:                %{name}-libpng15.patch
24 #Patch1:                %{name}-format.patch
25 URL:            http://www.dengine.net/
26 BuildRequires:  OpenGL-devel
27 BuildRequires:  QtCore-devel
28 BuildRequires:  QtNetwork-devel
29 BuildRequires:  QtOpenGL-devel
30 BuildRequires:  SDL2-devel
31 BuildRequires:  SDL2_mixer-devel
32 BuildRequires:  assimp-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  ncurses-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python
38 BuildRequires:  python-modules
39 BuildRequires:  qt4-build
40 BuildRequires:  qt4-qmake
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.595
43 BuildRequires:  xorg-lib-libXrandr-devel
44 Requires(post): /sbin/ldconfig
45 Requires:       TiMidity++
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 The Doomsday Engine allows you to play the classic first-person
50 shooters DOOM, Heretic, and Hexen using modern technology, with
51 hardware accelerated 3D graphics, surround sound and much more.
52
53 %description -l pl.UTF-8
54 jDoom, jHeretic i jHexen dla Linuksa.
55
56 %prep
57 %setup -q -n %{name}-%{subver}-%{version}
58 #%patch0 -p1
59 #%patch1 -p1
60
61 %build
62 install -d build
63 cd build
64 LDFLAGS="-lm"
65 qmake-qt4 CONFIG+=deng_notools \
66         -r ../doomsday/doomsday.pro
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_desktopdir}
72 %{__make} -C build install \
73         INSTALL_ROOT=$RPM_BUILD_ROOT
74
75 # no -devel package. cleanup
76 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so
77 # junk links
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so.1.15
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_core.so.2.0
80
81 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
82 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
83 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
84 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
85
86 cp -p %{_sourcedir}/%{name}-doom.desktop $RPM_BUILD_ROOT%{_desktopdir}
87 cp -p %{_sourcedir}/%{name}-hexen.desktop $RPM_BUILD_ROOT%{_desktopdir}
88 cp -p %{_sourcedir}/%{name}-heretic.desktop $RPM_BUILD_ROOT%{_desktopdir}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/ldconfig
95 %banner -o -e %{name} <<-EOF
96 To run doomsday you need some WAD file: either freedoom package
97 or some shareware or commercial WAD from Doom or Heretic:
98 Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
99 Heretic.wad or Heretic1.wad.
100 When you have them, run doomsday with:
101 doomsday -game [ jdoom | jheretic | jhexen ]
102 EOF
103
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 #%doc doomsday/build/README
109 %attr(755,root,root) %{_bindir}/doomsday
110 %attr(755,root,root) %{_bindir}/doomsday-server
111 %attr(755,root,root) %{_bindir}/launch-doomsday
112
113 %attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
115 %attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
117 %attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
119 %attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
121 %attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
123 %attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
125
126
127 %{_libdir}/doomsday
128 %{_datadir}/doomsday
129 %{_desktopdir}/*.desktop
130 %{_pixmapsdir}/*.png
131 %{_mandir}/man6/*
This page took 0.043854 seconds and 3 git commands to generate.