]> git.pld-linux.org Git - packages/domoticz.git/commitdiff
up to 2024.1 auto/th/domoticz-2024.1-1
authorJan Palus <atler@pld-linux.org>
Mon, 1 Jan 2024 13:11:41 +0000 (14:11 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 1 Jan 2024 13:11:41 +0000 (14:11 +0100)
domoticz-python.patch
domoticz-tinyxpath.patch
domoticz.spec

index 1f09cf4a9d3b0ef7c1fd88e7df44ecef07fbe390..6047ea155102a15d551946b0b12c3944ada6a51f 100644 (file)
@@ -1,9 +1,10 @@
 --- domoticz-2021.1/hardware/plugins/DelayedLink.h.orig        2021-04-17 17:50:55.000000000 +0200
 +++ domoticz-2021.1/hardware/plugins/DelayedLink.h     2021-04-20 12:36:46.238826640 +0200
-@@ -155,23 +155,9 @@
+@@ -155,25 +155,9 @@
                        shared_lib_ = nullptr;
                        if (!shared_lib_) {
  #ifdef WIN32
+-                              if (!shared_lib_) shared_lib_ = LoadLibrary("python312.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python311.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python310.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python39.dll");
@@ -14,6 +15,7 @@
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python34.dll");
 +                              if (!shared_lib_) shared_lib_ = LoadLibrary("python.dll");
  #else
+-                              if (!shared_lib_) FindLibrary("python3.12", true);
 -                              if (!shared_lib_) FindLibrary("python3.11", true);
 -                              if (!shared_lib_) FindLibrary("python3.10", true);
 -                              if (!shared_lib_) FindLibrary("python3.9", true);
@@ -24,8 +26,8 @@
 -                              if (!shared_lib_) FindLibrary("python3.4", true);
 +                              if (!shared_lib_) FindLibrary(PYTHON_LIBDIR, false);
  #ifdef __FreeBSD__
-                               if (!shared_lib_) FindLibrary("python3.7m", true);
-                               if (!shared_lib_) FindLibrary("python3.6m", true);
+                               if (!shared_lib_) FindLibrary("python3.12m", true);
+                               if (!shared_lib_) FindLibrary("python3.11m", true);
 @@ -355,34 +327,20 @@
                                else
                                {
index 89ed522cd702480111f728c2b60d1c5c924279e4..82ef5ef35b93418ce9790f29c043994dd905f03f 100644 (file)
@@ -88,36 +88,9 @@ index bc231d8f6..334f203a6 100644
 +  ENDIF(TinyXML_FOUND)
 +ENDIF(USE_BUILTIN_TINYXPATH)
 +
- #
- # OpenZWave
- # try to find open-zwave, if found, include support
---- a/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-22 09:16:16.000000000 -0500
-+++ b/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-24 10:53:04.968630391 -0500
-@@ -49,7 +49,7 @@
- #include <sys/stat.h>
- #include <fstream>
- #include <iostream>
--#include "../../../tinyxpath/tinyxml.h"
-+#include <tinyxml.h>
- //#include "microhttpd.h"
- #include "ozwcp.h"
---- a/hardware/plugins/PluginManager.cpp       2020-03-22 09:16:16.000000000 -0500
-+++ b/hardware/plugins/PluginManager.cpp       2020-03-24 13:53:05.305852598 -0500
-@@ -21,11 +21,12 @@
- #include "../../main/Logger.h"
- #include "../../main/SQLHelper.h"
- #include "../../main/WebServer.h"
--#include "../../tinyxpath/tinyxml.h"
- #ifdef WIN32
-+#       include "../../tinyxpath/tinyxml.h"
- #     include <direct.h>
- #else
- #     include <sys/stat.h>
-+#       include <tinyxml.h>
- #endif
- #include "DelayedLink.h"
+ IF(EXISTS /sys/class/gpio OR FORCE_WITH_GPIO)
+   message(STATUS "GPIO is available")
+   add_definitions(-DWITH_GPIO)
 --- a/hardware/plugins/Plugins.cpp     2020-03-22 09:16:16.000000000 -0500
 +++ b/hardware/plugins/Plugins.cpp     2020-03-24 13:45:46.056965796 -0500
 @@ -16,10 +16,11 @@
index e4b1d6ff9617e8d75dc26c13986a0d1173764d50..26697e4dcc376299ef496a16b4d15b7a7cdf8f91 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       2023.2
+Version:       2024.1
 Release:       1
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
 Source0:       https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ea8089e5b49a33e60ecc2ce0052e32c5
+# Source0-md5: 35b60b24ab2e1cf6d721d6720ae8a670
 Source1:       %{name}.service
 Source2:       %{name}.conf
 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
@@ -22,7 +22,6 @@ BuildRequires:        cmake >= 3.16.0
 BuildRequires: curl-devel
 BuildRequires: jsoncpp-devel
 BuildRequires: libmosquitto-devel
-BuildRequires: libopenzwave-devel >= 1.5.0
 BuildRequires: libstdc++-devel >= 6:4.9
 BuildRequires: libusb-compat-devel
 BuildRequires: linux-libc-headers
@@ -42,7 +41,6 @@ Requires(pre):        /usr/sbin/useradd
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      fonts-TTF-Google-Droid
 Requires:      fonts-TTF-OpenSans
-Requires:      libopenzwave >= 1.5.0
 Requires:      setup >= 2.10.1
 Suggests:      python3-libs
 Provides:      group(domoticz)
@@ -84,7 +82,6 @@ export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
        -DUSE_OPENSSL_STATIC=NO \
        -DUSE_STATIC_BOOST=NO \
        -DUSE_STATIC_LIBSTDCXX=NO \
-       -DUSE_STATIC_OPENZWAVE=NO \
        -DFORCE_WITH_GPIO:BOOL=TRUE \
        -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
        ..
@@ -124,10 +121,6 @@ ln -s %{_fontsdir}/TTF/DroidSans.ttf \
 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
        $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
 
-# OpenZWave Control Panel temp file
-ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
-       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.203825 seconds and 4 git commands to generate.