]> git.pld-linux.org Git - packages/domoticz.git/commitdiff
up to 2023.2 auto/th/domoticz-2023.2-1
authorJan Palus <atler@pld-linux.org>
Fri, 21 Jul 2023 20:08:31 +0000 (22:08 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 21 Jul 2023 20:08:31 +0000 (22:08 +0200)
domoticz-python.patch
domoticz-tinyxpath.patch
domoticz.spec

index 5c245c01e68ca90f4248572ec73da7ffe4847e05..1f09cf4a9d3b0ef7c1fd88e7df44ecef07fbe390 100644 (file)
@@ -1,9 +1,10 @@
 --- domoticz-2021.1/hardware/plugins/DelayedLink.h.orig        2021-04-17 17:50:55.000000000 +0200
 +++ domoticz-2021.1/hardware/plugins/DelayedLink.h     2021-04-20 12:36:46.238826640 +0200
-@@ -155,21 +155,9 @@
+@@ -155,23 +155,9 @@
                        shared_lib_ = nullptr;
                        if (!shared_lib_) {
  #ifdef WIN32
+-                              if (!shared_lib_) shared_lib_ = LoadLibrary("python311.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python310.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python39.dll");
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python38.dll");
@@ -13,6 +14,7 @@
 -                              if (!shared_lib_) shared_lib_ = LoadLibrary("python34.dll");
 +                              if (!shared_lib_) shared_lib_ = LoadLibrary("python.dll");
  #else
+-                              if (!shared_lib_) FindLibrary("python3.11", true);
 -                              if (!shared_lib_) FindLibrary("python3.10", true);
 -                              if (!shared_lib_) FindLibrary("python3.9", true);
 -                              if (!shared_lib_) FindLibrary("python3.8", true);
index ab45407230ed1de72f141ad08555d7a7258e8ec4..89ed522cd702480111f728c2b60d1c5c924279e4 100644 (file)
@@ -121,9 +121,9 @@ index bc231d8f6..334f203a6 100644
 --- a/hardware/plugins/Plugins.cpp     2020-03-22 09:16:16.000000000 -0500
 +++ b/hardware/plugins/Plugins.cpp     2020-03-24 13:45:46.056965796 -0500
 @@ -16,10 +16,11 @@
+ #include "../../main/Logger.h"
  #include "../../main/SQLHelper.h"
  #include "../../main/mainworker.h"
- #include "../../main/localtime_r.h"
 -#include "../../tinyxpath/tinyxml.h"
  
  #include "../../notifications/NotificationHelper.h"
@@ -147,8 +147,8 @@ index bc231d8f6..334f203a6 100644
 --- a/hardware/EcoDevices.cpp  2020-03-22 09:16:16.000000000 -0500
 +++ b/hardware/EcoDevices.cpp  2020-03-24 10:47:20.095926641 -0500
 @@ -33,11 +33,11 @@
+ #include "../main/Logger.h"
  #include "hardwaretypes.h"
- #include "../main/localtime_r.h"
  #include "../httpclient/HTTPClient.h"
 -#include "../tinyxpath/tinyxml.h"
 -#include "../tinyxpath/xpath_static.h"
@@ -162,12 +162,11 @@ index bc231d8f6..334f203a6 100644
  #define MAJOR 1
 --- a/hardware/OnkyoAVTCP.cpp  2018-06-23 09:18:06.000000000 -0500
 +++ b/hardware/OnkyoAVTCP.cpp  2018-07-08 14:21:06.884163094 -0500
-@@ -3,15 +3,15 @@
+@@ -3,14 +3,14 @@
  #include "../main/Logger.h"
  #include "../main/Helper.h"
  #include "../main/SQLHelper.h"
 -#include <iostream>
- #include "../main/localtime_r.h"
  #include "../main/mainworker.h"
  #include "../hardware/hardwaretypes.h"
 -#include <json/json.h>
@@ -201,6 +200,17 @@ index bc231d8f6..334f203a6 100644
  #include "../notifications/NotificationHelper.h"
 -#include "../tinyxpath/tinyxml.h"
 +#include <tinyxml.h>
+ #include "../webserver/Base64.h"
+ #include "hardwaretypes.h"
+ #include <iostream>
+--- domoticz-2023.2/hardware/Enever.cpp.orig   2023-07-21 17:23:44.000000000 +0200
++++ domoticz-2023.2/hardware/Enever.cpp        2023-07-21 20:39:42.240298598 +0200
+@@ -9,7 +9,7 @@
+ #include "../main/RFXtrx.h"
+ #include "../main/SQLHelper.h"
+ #include "../notifications/NotificationHelper.h"
+-#include "../tinyxpath/tinyxml.h"
++#include <tinyxml.h>
+ #include "../webserver/Base64.h"
  #include "hardwaretypes.h"
  #include <iostream>
index 60b9067e6100d15f31f95b1dcbee7dfeb8ecbfdf..e4b1d6ff9617e8d75dc26c13986a0d1173764d50 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       2023.1
-Release:       2
+Version:       2023.2
+Release:       1
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
 Source0:       https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: fd2d853be241fb13e3582d5499c414ac
+# Source0-md5: ea8089e5b49a33e60ecc2ce0052e32c5
 Source1:       %{name}.service
 Source2:       %{name}.conf
 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
This page took 0.21578 seconds and 4 git commands to generate.