]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
- up to 2020.2
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2020.2
4 Release:        1
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  fd383a13d13d0976c72f332d6db1d24e
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12
13 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
14 Patch2:         %{name}-tinyxpath.patch
15 # Use system openzwave includes
16 Patch3:         %{name}-openzwave.patch
17 # Work against Dev branch of OpenZWave upstream
18 Patch4:         %{name}-openzwave-Dev.patch
19 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
20 Patch5:         %{name}-python.patch
21 BuildRequires:  boost-devel
22 BuildRequires:  cereal-devel
23 BuildRequires:  cmake
24 BuildRequires:  curl-devel
25 BuildRequires:  libmosquitto-devel
26 BuildRequires:  libmosquittopp-devel
27 BuildRequires:  libopenzwave-devel >= 1.5.0
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libusb-devel
30 BuildRequires:  lua-devel
31 BuildRequires:  minizip-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  python3-devel
34 BuildRequires:  sqlite-devel
35 BuildRequires:  systemd-devel
36 BuildRequires:  tinyxpath-devel
37 BuildRequires:  zlib-devel
38 Requires(pre):  /usr/sbin/groupadd
39 Requires(pre):  /usr/sbin/useradd
40 Requires(post): systemd
41 Requires(postun):       systemd
42 Requires(preun):        systemd
43 Requires:       fonts-TTF-Google-Droid
44 Provides:       bundled(js-ace)
45 Provides:       bundled(js-angular-ui-bootstrap) = 0.13.4
46 Provides:       bundled(js-angularamd) = 0.2.1
47 Provides:       bundled(js-angularjs) = 1.5.8
48 Provides:       bundled(js-blockly)
49 Provides:       bundled(js-bootbox)
50 Provides:       bundled(js-bootstrap) = 3.2.0
51 Provides:       bundled(js-colpick)
52 Provides:       bundled(js-d3)
53 Provides:       bundled(js-datatables-datatools) = 2.2.3
54 Provides:       bundled(js-dateformat) = 1.2.3
55 Provides:       bundled(js-filesaver) = 0.0-git20140725
56 Provides:       bundled(js-highcharts) = 4.2.6
57 Provides:       bundled(js-html5shiv) = 3.6.2
58 Provides:       bundled(js-i18next) = 1.8.0
59 Provides:       bundled(js-ion-sound) = 3.0.6
60 Provides:       bundled(js-jquery) = 1.12.0
61 Provides:       bundled(js-jquery-noty) = 2.1.0
62 Provides:       bundled(js-less) = 1.3.0
63 Provides:       bundled(js-ngdraggable)
64 Provides:       bundled(js-nggrid)
65 Provides:       bundled(js-ozwcp)
66 Provides:       bundled(js-require) = 2.1.14
67 Provides:       bundled(js-respond) = 1.1.0
68 Provides:       bundled(js-wow) = 0.1.9
69 Provides:       bundled(js-zeroclipboard) = 1.0.4
70
71 %description
72 Domoticz is a Home Automation System that lets you monitor and
73 configure various devices like: Lights, Switches, various
74 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
75 and much more. Notifications/Alerts can be sent to any mobile device
76
77 %prep
78 %setup -q
79
80 APPVERSION="%{version}"
81 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
82 echo '#define APPHASH "%{snap}"' >> appversion.h
83 APPDATE=$(date --date="%{date}" "+%s")
84 echo "#define APPDATE ${APPDATE}" >> appversion.h
85
86 %patch2 -p1 -b.tinyxpath
87 %patch3 -p1 -b.openzwave
88 #%patch4 -p1 -b.openzwave-Dev
89 %patch5 -p1 -b.python
90
91 rm -f hardware/openzwave/*.h
92 rm -rf hardware/openzwave/aes
93 rm -rf hardware/openzwave/command_classes
94 rm -rf hardware/openzwave/platform
95 rm -rf hardware/openzwave/value_classes
96 rm -rf sqlite/
97 rm -rf tinyxpath/
98
99 %build
100 install -d build && cd build
101 %cmake \
102         -DUSE_OPENSSL_STATIC=NO \
103         -DUSE_STATIC_LIBSTDCXX=NO \
104         -DUSE_STATIC_OPENZWAVE=NO \
105         -DUSE_OPENSSL_STATIC=NO \
106         -DUSE_BUILTIN_JSONCPP=NO \
107         -DUSE_BUILTIN_LUA=NO \
108         -DUSE_BUILTIN_MINIZIP=NO \
109         -DUSE_BUILTIN_MQTT=NO \
110         -DUSE_BUILTIN_SQLITE=NO \
111         -DUSE_BUILTIN_TINYXPATH=NO \
112         -DUSE_STATIC_BOOST=NO \
113         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
114         ..
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} -C build install \
121       DESTDIR=$RPM_BUILD_ROOT
122
123 # remove docs, we grab them in files below
124 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
125
126 # move binary to standard directory
127 install -d $RPM_BUILD_ROOT%{_bindir}/
128 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
129
130 # install systemd service and config
131 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
132 install -d $RPM_BUILD_ROOT%{systemdunitdir}/
133 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
134 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
135
136 # create database/ssl cert directory
137 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
138
139 # Disable the app's self-update script
140
141 # Unbundle DroidSans.ttf
142 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
143 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
144       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
145 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
146 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
147       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
148 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
149 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
150       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
151
152 # OpenZWave Control Panel temp file
153 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
154       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %pre
160 getent group domoticz >/dev/null || groupadd -r domoticz
161 getent passwd domoticz >/dev/null || \
162 useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
163 -c "Domoticz Home Automation Server" domoticz
164 # For OpenZWave USB access (/dev/ttyACM#)
165 usermod -G domoticz,dialout domoticz
166
167 %post
168 %systemd_post %{name}.service
169
170 %preun
171 %systemd_preun %{name}.service
172
173 %postun
174 %systemd_reload
175
176 %files
177 %defattr(644,root,root,755)
178 %doc License.txt
179 %doc README.md History.txt
180 %attr(755,root,root) %{_bindir}/%{name}
181 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
182 %{_datadir}/%{name}/
183 %attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
184 %{systemdunitdir}/%{name}.service
This page took 0.039712 seconds and 4 git commands to generate.