]> git.pld-linux.org Git - packages/domoticz.git/commitdiff
- up to 2020.2 auto/th/domoticz-2020.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 25 May 2020 18:55:06 +0000 (20:55 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 25 May 2020 18:55:06 +0000 (20:55 +0200)
domoticz-openzwave.patch
domoticz-tinyxpath.patch
domoticz.spec

index c53bb90beeb04c688ffcf2321dce9428ab5d4d2a..b5371527b116df0ccc2a80d98f438524c869622a 100644 (file)
@@ -1,62 +1,19 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 42082192..f16726f8 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -298,9 +298,9 @@
- ADD_CUSTOM_TARGET(revisiontag ALL)
- # creates appversion.h using cmake script
--ADD_CUSTOM_COMMAND(TARGET revisiontag COMMAND ${CMAKE_COMMAND}
--   -DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR}
--   -P ${CMAKE_CURRENT_SOURCE_DIR}/getgit.cmake)
-+#ADD_CUSTOM_COMMAND(TARGET revisiontag COMMAND ${CMAKE_COMMAND}
-+#   -DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR}
-+#   -P ${CMAKE_CURRENT_SOURCE_DIR}/getgit.cmake)
- ## Target
- set(
-@@ -700,7 +700,7 @@
- IF(OpenZWave)
-   message(STATUS ${OpenZWave})
+@@ -707,13 +707,9 @@
+   message(STATUS "OpenZWave library found at: ${OpenZWave}")
    target_link_libraries(domoticz ${OpenZWave})
--  include_directories(${CMAKE_SOURCE_DIR}/hardware/openzwave)
-+  include_directories(${OPENZWAVE_INCLUDE_DIRS})
-   add_definitions(-DWITH_OPENZWAVE)
- ELSE()
-   MESSAGE(STATUS "==== OpenZWave not found, support disabled!")
-diff --git a/hardware/openzwave/control_panel/ozwcp.cpp b/hardware/openzwave/control_panel/ozwcp.cpp
-index ffd8d742..79c708ce 100644
---- a/hardware/openzwave/control_panel/ozwcp.cpp
-+++ b/hardware/openzwave/control_panel/ozwcp.cpp
-@@ -39,11 +39,11 @@
- #include <stdlib.h>
- #include <time.h>
- #include <string.h>
--#include "../Options.h"
--#include "../Manager.h"
--#include "../Node.h"
--#include "../Group.h"
--#include "../Notification.h"
-+#include <Options.h>
-+#include <Manager.h>
-+#include <Node.h>
-+#include <Group.h>
-+#include <Notification.h>
- #include "..//main/Logger.h"
- #include <sys/stat.h>
-diff --git a/hardware/openzwave/control_panel/ozwcp.h b/hardware/openzwave/control_panel/ozwcp.h
-index 29ebc0e3..7a027815 100644
---- a/hardware/openzwave/control_panel/ozwcp.h
-+++ b/hardware/openzwave/control_panel/ozwcp.h
-@@ -37,8 +37,8 @@
- #include <list>
- #include <algorithm>
--#include "Driver.h"
--#include "Notification.h"
-+#include <Driver.h>
-+#include <Notification.h>
- #define MAX_NODES 255
+
+-  find_path(OPENZWAVE_INCLUDE_DIRS NAMES openzwave/Manager.h)
++  find_path(OPENZWAVE_INCLUDE_DIRS NAMES Manager.h)
+   if (OPENZWAVE_INCLUDE_DIRS)
+-    IF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+-      include_directories(${OPENZWAVE_INCLUDE_DIRS})
+-    ELSE()
+-      include_directories(${OPENZWAVE_INCLUDE_DIRS}/openzwave)
+-    ENDIF()
++    include_directories(${OPENZWAVE_INCLUDE_DIRS})
+     message(STATUS "OpenZWave includes found at: ${OPENZWAVE_INCLUDE_DIRS}")
+   else()
+     message(FATAL_ERROR "OpenZWave includes not found. Did you not issue 'sudo make install' after building OpenZWave?")
+
index 84874c03ad4502d47e73fee8e4fd51a6c06255a9..f80751cab6077ffb5a33d703d1916876168f7daf 100644 (file)
@@ -20,10 +20,10 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
 index bc231d8f6..334f203a6 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -512,22 +512,6 @@
json/json_reader.cpp
json/json_value.cpp
json/json_writer.cpp
+@@ -365,22 +365,6 @@
webserver/server.cpp
webserver/Websockets.cpp
webserver/WebsocketHandler.cpp
 -tinyxpath/action_store.cpp
 -tinyxpath/htmlutil.cpp
 -tinyxpath/lex_util.cpp
@@ -41,9 +41,9 @@ index bc231d8f6..334f203a6 100644
 -tinyxpath/xpath_static.cpp
 -tinyxpath/xpath_syntax.cpp
  )
- add_executable(domoticz ${domoticz_SRCS})
  
-@@ -658,6 +642,47 @@
+ add_executable(domoticz ${domoticz_SRCS})
+@@ -682,6 +666,47 @@
    ENDIF(LIBUSB_FOUND)
  endif(WITH_LIBUSB)
  
@@ -91,6 +91,75 @@ index bc231d8f6..334f203a6 100644
  ## support lua popen on Linux platforms
  #IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
  # SET(OperatingSystem "Linux")
+--- a/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-24 10:53:04.968630391 -0500
+@@ -49,7 +49,7 @@
+ #include <sys/stat.h>
+ #include <fstream>
+ #include <iostream>
+-#include "../../../tinyxpath/tinyxml.h"
++#include <tinyxml.h>
+ //#include "microhttpd.h"
+ #include "ozwcp.h"
+--- a/hardware/plugins/PluginManager.cpp       2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/plugins/PluginManager.cpp       2020-03-24 13:53:05.305852598 -0500
+@@ -21,11 +21,12 @@
+ #include "../../main/Logger.h"
+ #include "../../main/SQLHelper.h"
+ #include "../../main/WebServer.h"
+-#include "../../tinyxpath/tinyxml.h"
+ #ifdef WIN32
++#       include "../../tinyxpath/tinyxml.h"
+ #     include <direct.h>
+ #else
+ #     include <sys/stat.h>
++#       include <tinyxml.h>
+ #endif
+ #include "DelayedLink.h"
+--- a/hardware/plugins/Plugins.cpp     2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/plugins/Plugins.cpp     2020-03-24 13:45:46.056965796 -0500
+@@ -16,10 +16,11 @@
+ #include "../../main/SQLHelper.h"
+ #include "../../main/mainworker.h"
+ #include "../../main/localtime_r.h"
+-#include "../../tinyxpath/tinyxml.h"
+ #include "../../notifications/NotificationHelper.h"
++#include <tinyxml.h>
++
+ #define ADD_STRING_TO_DICT(pDict, key, value) \
+               {       \
+                       PyObject*       pObj = Py_BuildValue("s", value.c_str());       \
+--- a/hardware/AnnaThermostat.cpp      2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/AnnaThermostat.cpp      2020-03-24 10:41:00.530030798 -0500
+@@ -9,7 +9,7 @@
+ #include "../httpclient/HTTPClient.h"
+ #include "../main/mainworker.h"
+-#include "../tinyxpath/tinyxml.h"
++#include <tinyxml.h>
+ #define round(a) ( int ) ( a + .5 )
+--- a/hardware/EcoDevices.cpp  2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/EcoDevices.cpp  2020-03-24 10:47:20.095926641 -0500
+@@ -33,11 +33,11 @@
+ #include "hardwaretypes.h"
+ #include "../main/localtime_r.h"
+ #include "../httpclient/HTTPClient.h"
+-#include "../tinyxpath/tinyxml.h"
+-#include "../tinyxpath/xpath_static.h"
+ #include "../webserver/Base64.h"
+ #include "../main/json_helper.h"
+ #include <sstream>
++#include <tinyxml.h>
++#include <xpath_static.h>
+ #ifdef _DEBUG
+ #define DEBUG_EcoDevices
 --- a/hardware/OnkyoAVTCP.cpp  2018-06-23 09:18:06.000000000 -0500
 +++ b/hardware/OnkyoAVTCP.cpp  2018-07-08 14:21:06.884163094 -0500
 @@ -3,15 +3,15 @@
@@ -101,13 +170,26 @@ index bc231d8f6..334f203a6 100644
  #include "../main/localtime_r.h"
  #include "../main/mainworker.h"
  #include "../hardware/hardwaretypes.h"
- #include "../json/json.h"
+-#include <json/json.h>
 -#include "../tinyxpath/tinyxml.h"
  #include "../main/WebServer.h"
  
 +#include <iostream>
  #include <sstream>
++#include <json/json.h>
 +#include <tinyxml.h>
  
  #define RETRY_DELAY 30
  
+--- a/hardware/RAVEn.cpp       2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/RAVEn.cpp       2020-03-24 12:55:59.616310732 -0500
+@@ -5,8 +5,8 @@
+ #include "../main/Logger.h"
+ #include "../main/mainworker.h"
+ #include "../main/RFXtrx.h"
+-#include "../tinyxpath/tinyxml.h"
+ #include "hardwaretypes.h"
++#include <tinyxml.h>
+ //Rainforest RAVEn USB ZigBee Smart Meter Adapter
+ //https://rainforestautomation.com/rfa-z106-raven/
index e8402f16b0ab7bcc67651e02c8d18031aa4eefe5..72aa9fe113a6a2fb5f9392eac38e96cc76a1dfb9 100644 (file)
@@ -1,16 +1,12 @@
-%define                snap    d5e8a14bf
-%define                date    20191209
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       4.11563
+Version:       2020.2
 Release:       1
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
-# Source0:     https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
-# https://www.domoticz.com/wiki/Domoticz_versions_-_Commits
-Source0:       https://github.com/domoticz/domoticz/archive/%{snap}.tar.gz
-# Source0-md5: 376611fe9d5a8fb7febd71be8addc4ce
+Source0:       https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
+# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
 Source1:       %{name}.service
 Source2:       %{name}.conf
 
@@ -23,6 +19,7 @@ Patch4:               %{name}-openzwave-Dev.patch
 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
 Patch5:                %{name}-python.patch
 BuildRequires: boost-devel
+BuildRequires: cereal-devel
 BuildRequires: cmake
 BuildRequires: curl-devel
 BuildRequires: libmosquitto-devel
@@ -31,6 +28,7 @@ BuildRequires:        libopenzwave-devel >= 1.5.0
 BuildRequires: libstdc++-devel
 BuildRequires: libusb-devel
 BuildRequires: lua-devel
+BuildRequires: minizip-devel
 BuildRequires: openssl-devel
 BuildRequires: python3-devel
 BuildRequires: sqlite-devel
@@ -77,8 +75,7 @@ sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
 and much more. Notifications/Alerts can be sent to any mobile device
 
 %prep
-%setup -q -c
-mv %{name}-%{snap}*/* .
+%setup -q
 
 APPVERSION="%{version}"
 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
@@ -105,7 +102,10 @@ install -d build && cd build
        -DUSE_OPENSSL_STATIC=NO \
        -DUSE_STATIC_LIBSTDCXX=NO \
        -DUSE_STATIC_OPENZWAVE=NO \
+        -DUSE_OPENSSL_STATIC=NO \
+        -DUSE_BUILTIN_JSONCPP=NO \
        -DUSE_BUILTIN_LUA=NO \
+        -DUSE_BUILTIN_MINIZIP=NO \
        -DUSE_BUILTIN_MQTT=NO \
        -DUSE_BUILTIN_SQLITE=NO \
        -DUSE_BUILTIN_TINYXPATH=NO \
This page took 0.267683 seconds and 4 git commands to generate.