]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
Up to 2023-04-04
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 5 Apr 2023 12:40:07 +0000 (15:40 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 28 Apr 2023 17:29:06 +0000 (20:29 +0300)
- https://www.dokuwiki.org/changes#release_2023-04-04_jack_jackrum

dokuwiki-http_auth-option.patch
dokuwiki.spec

index 3b8fbbe5e9c7ba9841f907b9acdf8e0c9a6fb9da..462b13939229677fb9eb373000f1e7fcdfbef735 100644 (file)
  $conf['securecookie'] = 1;               //never send HTTPS cookies via HTTP
  $conf['remote']      = 0;                //Enable/disable remote interfaces
  $conf['remoteuser']  = '!!not set!!';    //user/groups that have access to remote interface (comma separated). leave empty to allow all users
---- dokuwiki-2018-04-22c.org/inc/auth.php      2020-05-01 12:38:20.000000000 +0200
-+++ dokuwiki-2018-04-22c/inc/auth.php  2022-09-27 22:46:31.557879706 +0200
-@@ -84,7 +84,7 @@ function auth_setup() {
+--- dokuwiki-2023-04-04/inc/auth.php~  2023-04-04 19:21:21.000000000 +0300
++++ dokuwiki-2023-04-04/inc/auth.php   2023-04-05 15:43:33.873377532 +0300
+@@ -75,7 +75,7 @@
      }
  
      // if no credentials were given try to use HTTP auth (for SSO)
--    if(!$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])) {
-+    if($conf['http_auth'] && !$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($_SERVER['PHP_AUTH_USER'])) {
-         $INPUT->set('u', $_SERVER['PHP_AUTH_USER']);
-         $INPUT->set('p', $_SERVER['PHP_AUTH_PW']);
+-    if (!$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($INPUT->server->str('PHP_AUTH_USER'))) {
++    if ($conf['http_auth'] && !$INPUT->str('u') && empty($_COOKIE[DOKU_COOKIE]) && !empty($INPUT->server->str('PHP_AUTH_USER'))) {
+         $INPUT->set('u', $INPUT->server->str('PHP_AUTH_USER'));
+         $INPUT->set('p', $INPUT->server->str('PHP_AUTH_PW'));
          $INPUT->set('http_credentials', true);
index e79a25d97588791f581a5af027f27d6973906f94..537a59810876c29382580350e8db3c294fcc3022 100644 (file)
@@ -1,4 +1,4 @@
-%define                subver  2022-07-31a
+%define                subver  2023-04-04
 %define                ver             %(echo %{subver} | tr -d -)
 #define                snap    1
 #define                rc_     1
@@ -7,12 +7,12 @@ Summary:      PHP-based Wiki webapplication
 Summary(pl.UTF-8):     Aplikacja WWW Wiki oparta na PHP
 Name:          dokuwiki
 Version:       %{ver}
-Release:       2
+Release:       1
 License:       GPL v2
 Group:         Applications/WWW
 # Source0Download: https://download.dokuwiki.org/archive
-Source0:       https://download.dokuwiki.org/src/dokuwiki/%{name}-%{subver}.tgz
-# Source0-md5: 4459ea99e3a4ce2b767482f505724dcc
+Source0:       https://github.com/dokuwiki/dokuwiki/releases/download/release-%{subver}/dokuwiki-%{subver}.tgz
+# Source0-md5: a112952394f3d4b76efb9dc2f985f99f
 Source1:       %{name}-apache.conf
 Source2:       %{name}-lighttpd.conf
 Source3:       http://glen.alkohol.ee/pld/jude.png
@@ -148,7 +148,6 @@ find -name _dummy | xargs %{__rm}
 %{__rm} {conf,inc,bin,data}/.htaccess
 %{__rm} vendor/.htaccess
 %{__rm} lib/plugins/styling/.travis.yml
-%{__rm} -r lib/plugins/testing
 %{__rm} -r lib/plugins/*/_test
 
 # we just don't package deleted files, these get removed automatically on rpm upgrades
@@ -163,6 +162,9 @@ find -name _dummy | xargs %{__rm}
 install -d vendor/geshi/geshi/src
 %{__ln} -snf %{php_data_dir}/geshi.php vendor/geshi/geshi/src/geshi.php
 
+# generic vendor cleanup
+%{__rm} -v vendor/*/*/composer.*
+
 # use system simplepie package
 #%{__rm} inc/SimplePie.php
 
@@ -380,6 +382,7 @@ exit 0
 %{_appdir}/vendor/simplepie/simplepie
 %{_appdir}/vendor/splitbrain/php-archive
 %{_appdir}/vendor/splitbrain/php-cli
+%{_appdir}/vendor/splitbrain/php-jsstrip
 %{_appdir}/vendor/splitbrain/slika
 
 %dir %{_appdir}/lib
This page took 0.100698 seconds and 4 git commands to generate.