]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
Remove -notifyns.patch patch; rel 2 auto/th/dokuwiki-20220731a-2
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 20 Apr 2023 17:03:22 +0000 (20:03 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Thu, 20 Apr 2023 17:03:24 +0000 (20:03 +0300)
Broken and unmaintained

dokuwiki-notifyns.patch [deleted file]
dokuwiki.spec

diff --git a/dokuwiki-notifyns.patch b/dokuwiki-notifyns.patch
deleted file mode 100644 (file)
index 6531099..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
---- dokuwiki-2022-07-31a/inc/common.php~       2023-03-30 18:04:18.000000000 +0300
-+++ dokuwiki-2022-07-31a/inc/common.php        2023-03-30 18:05:59.000277451 +0300
-@@ -897,6 +897,34 @@ function gethostsbyaddrs($ips) {
-     }
- }
-+
-+/**
-+ * Returns notify address for page $id
-+ *
-+ * @param  string  $id       The changed page
-+ * @param  mixed   $notify   The address (string) or rules where to notify
-+ *
-+ * @author Elan Ruusamäe <glen@delfi.ee>
-+ */
-+function notifyNS($id, $notify) {
-+  if (empty($notify)) {
-+    return '';
-+  }
-+
-+  if (is_string($notify)) {
-+    return $notify;
-+  }
-+
-+  // process $notify for pages
-+  foreach ($notify as $rule => $address) {
-+    if (preg_match('/'.$rule.'/ui',':'.$id)) {
-+      return $address;
-+    }
-+  }
-+
-+  return '';
-+}
-+
- /**
-  * Checks if a given page is currently locked.
-  *
-@@ -1346,10 +1346,10 @@
-     // decide if there is something to do, eg. whom to mail
-     if ($who == 'admin') {
--        if (empty($conf['notify'])) return false; //notify enabled?
-         if ($conf['useacl'] && $INPUT->server->str('REMOTE_USER') && $minor) return false; //skip minors
-         $tpl = 'mailtext';
--        $to  = $conf['notify'];
-+        $to  = notifyNS($id, $conf['notify']);
-+        if (empty($to)) return false; //notify enabled?
-     } elseif ($who == 'subscribers') {
-         if (!actionOK('subscribe')) return false; //subscribers enabled?
-         if ($conf['useacl'] && $INPUT->server->str('REMOTE_USER') && $minor) return false; //skip minors
---- dokuwiki-2022-07-31a/inc/media.php~        2022-09-03 20:15:22.000000000 +0300
-+++ dokuwiki-2022-07-31a/inc/media.php 2023-03-30 18:08:07.797735926 +0300
-@@ -668,10 +668,11 @@
-  */
- function media_notify($id,$file,$mime,$old_rev=false,$current_rev=false){
-     global $conf;
--    if(empty($conf['notify'])) return; //notify enabled?
-+    $to = notifyNS($id, $conf['notify']);
-+    if (empty($to)) return; //notify enabled?
-     $subscription = new MediaSubscriptionSender();
--    $subscription->sendMediaDiff($conf['notify'], 'uploadmail', $id, $old_rev, $current_rev);
-+    $subscription->sendMediaDiff($to, 'uploadmail', $id, $old_rev, $current_rev);
- }
- /**
---- dokuwiki-2020-07-29a/inc/Subscriptions/RegistrationSubscriptionSender.php~ 2022-09-03 19:58:24.000000000 +0300
-+++ dokuwiki-2020-07-29a/inc/Subscriptions/RegistrationSubscriptionSender.php  2023-03-27 11:37:39.640069460 +0300
-@@ -19,7 +19,8 @@
-     public function sendRegister($login, $fullname, $email)
-     {
-         global $conf;
--        if (empty($conf['registernotify'])) {
-+        $to = notifyNS($id, $conf['registernotify']); // XXX $id undefined
-+        if (empty($to)) {
-             return false;
-         }
-@@ -30,7 +31,7 @@
-         ];
-         return $this->send(
--            $conf['registernotify'],
-+            $to,
-             'new_user',
-             $login,
-             'registermail',
---- dokuwiki-2020-07-29a/./inc/Subscriptions/SubscriberManager.php~    2022-09-03 19:58:24.000000000 +0300
-+++ dokuwiki-2020-07-29a/./inc/Subscriptions/SubscriberManager.php     2023-03-27 11:38:57.900505224 +0300
-@@ -257,7 +257,8 @@
-                 $level = auth_aclcheck($id, $user, $userinfo['grps']);
-                 if ($level >= AUTH_READ) {
--                    if (strcasecmp($userinfo['mail'], $conf['notify']) != 0) { //skip user who get notified elsewhere
-+                    $to = notifyNS($id, $conf['notify']);
-+                    if (strcasecmp($userinfo['mail'], $to) != 0) { //skip user who get notified elsewhere
-                         $result[$user] = $userinfo['mail'];
-                     }
-                 }
index 501247dd37c7d4c97ee4158ae991e8c9b3364ea0..e79a25d97588791f581a5af027f27d6973906f94 100644 (file)
@@ -7,7 +7,7 @@ Summary:        PHP-based Wiki webapplication
 Summary(pl.UTF-8):     Aplikacja WWW Wiki oparta na PHP
 Name:          dokuwiki
 Version:       %{ver}
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Applications/WWW
 # Source0Download: https://download.dokuwiki.org/archive
@@ -37,7 +37,6 @@ Patch2:               style-width.patch
 Patch5:                %{name}-http_auth-option.patch
 Patch8:                %{name}-notify-respect-minor.patch
 Patch10:       %{name}-mailtext.patch
-Patch11:       %{name}-notifyns.patch
 Patch19:       pld-branding.patch
 Patch21:       task-1821.patch
 Patch24:       more-buttons.patch
@@ -132,7 +131,6 @@ echo '====== PlayGround ======' >  data/pages/playground/playground.txt
 %patch5 -p1
 %patch8 -p1
 %patch10 -p1
-%patch11 -p1
 %patch19 -p1
 #%patch21 -p1
 #%patch24 -p1
This page took 0.102086 seconds and 4 git commands to generate.