]> git.pld-linux.org Git - packages/dokuwiki-plugin-vcard.git/blob - dokuwiki-plugin-vcard.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dokuwiki-plugin-vcard.git] / dokuwiki-plugin-vcard.spec
1 %define         plugin          vcard
2 %define         php_min_version 5.0.0
3 Summary:        DokuWiki vCard/hCard plugin
4 Name:           dokuwiki-plugin-%{plugin}
5 Version:        20070516
6 Release:        2
7 License:        GPL v2
8 Group:          Applications/WWW
9 Source0:        http://tomas.valenta.cz/dokuwiki/vcard-plugin.zip
10 # Source0-md5:  a0d6543e1317debfb3b03bb9ffc7a603
11 URL:            http://www.dokuwiki.org/plugin:vcard
12 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
13 BuildRequires:  rpmbuild(macros) >= 1.520
14 Requires:       dokuwiki >= 20061106
15 Requires:       php(core) >= %{php_min_version}
16 Requires:       php(date)
17 Requires:       php(pcre)
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         dokuconf        /etc/webapps/dokuwiki
22 %define         dokudir         /usr/share/dokuwiki
23 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
24
25 %description
26 This plugin lets you create vCard files on the fly in your wiki, which
27 other users can download and add to their addressbook. With the folded
28 plugin installed, you can unfold information about the person right in
29 your wiki.
30
31 %prep
32 %setup -qc
33 mv %{plugin}/* .
34
35 version=$(awk -F"'" '/date/&&/=>/{print $4}' syntax.php)
36 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
37         : %%{version} mismatch
38         exit 1
39 fi
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{plugindir}
44 cp -a . $RPM_BUILD_ROOT%{plugindir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %dir %{plugindir}
52 %{plugindir}/*.php
53 %{plugindir}/*.gif
This page took 0.107259 seconds and 4 git commands to generate.