]> git.pld-linux.org Git - packages/dokuwiki-plugin-vcard.git/blob - dokuwiki-plugin-vcard.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dokuwiki-plugin-vcard.git] / dokuwiki-plugin-vcard.spec
1 %define         plugin          vcard
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki vCard/hCard plugin
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        20070516
7 Release:        2
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        http://tomas.valenta.cz/dokuwiki/vcard-plugin.zip
11 # Source0-md5:  a0d6543e1317debfb3b03bb9ffc7a603
12 URL:            http://www.dokuwiki.org/plugin:vcard
13 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
14 BuildRequires:  rpmbuild(macros) >= 1.520
15 Requires:       dokuwiki >= 20061106
16 Requires:       php(core) >= %{php_min_version}
17 Requires:       php(date)
18 Requires:       php(pcre)
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dokuconf        /etc/webapps/dokuwiki
23 %define         dokudir         /usr/share/dokuwiki
24 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
25
26 %description
27 This plugin lets you create vCard files on the fly in your wiki, which
28 other users can download and add to their addressbook. With the folded
29 plugin installed, you can unfold information about the person right in
30 your wiki.
31
32 %prep
33 %setup -qc
34 mv %{plugin}/* .
35
36 version=$(awk -F"'" '/date/&&/=>/{print $4}' syntax.php)
37 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
38         : %%{version} mismatch
39         exit 1
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{plugindir}
45 cp -a . $RPM_BUILD_ROOT%{plugindir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %dir %{plugindir}
53 %{plugindir}/*.php
54 %{plugindir}/*.gif
This page took 0.211901 seconds and 3 git commands to generate.