]> git.pld-linux.org Git - packages/dokuwiki-plugin-vcard.git/blob - dokuwiki-plugin-vcard.spec
- new
[packages/dokuwiki-plugin-vcard.git] / dokuwiki-plugin-vcard.spec
1 %define         plugin          vcard
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki vCard/hCard plugin
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        20070516
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        http://tomas.valenta.cz/dokuwiki/vcard-plugin.zip
11 # Source0-md5:  a0d6543e1317debfb3b03bb9ffc7a603
12 URL:            http://www.dokuwiki.org/plugin:vcard
13 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
14 BuildRequires:  rpmbuild(macros) >= 1.520
15 Requires:       dokuwiki >= 20061106
16 Requires:       php-common >= 4:%{php_min_version}
17 Requires:       php-date
18 Requires:       php-pcre
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dokuconf        /etc/webapps/dokuwiki
23 %define         dokudir         /usr/share/dokuwiki
24 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
25
26 # no pear deps
27 %define         _noautopear     pear
28
29 # exclude optional php dependencies
30 %define         _noautophp      php-someext
31
32 # put it together for rpmbuild
33 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
34
35 %description
36 This plugin lets you create vCard files on the fly in your wiki, which
37 other users can download and add to their addressbook. With the folded
38 plugin installed, you can unfold information about the person right in
39 your wiki.
40
41 %prep
42 %setup -qc
43 mv %{plugin}/* .
44
45 version=$(awk -F"'" '/date/&&/=>/{print $4}' syntax.php)
46 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
47         : %%{version} mismatch
48         exit 1
49 fi
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{plugindir}
54 cp -a . $RPM_BUILD_ROOT%{plugindir}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %dir %{plugindir}
62 %{plugindir}/*.php
63 %{plugindir}/*.gif
This page took 0.075164 seconds and 3 git commands to generate.