]> git.pld-linux.org Git - packages/dokuwiki-plugin-tag.git/blob - dokuwiki-plugin-tag.spec
- add ca-va -> ca_VA
[packages/dokuwiki-plugin-tag.git] / dokuwiki-plugin-tag.spec
1 %define         plugin          tag
2 Summary:        DokuWiki Tag Plugin
3 Name:           dokuwiki-plugin-%{plugin}
4 Version:        20080707
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://www.chimeric.de/_src/plugin-tag.tgz
9 # Source0-md5:  6f9bc7915fc273a161c093ce525f0abc
10 Source1:        dokuwiki-find-lang.sh
11 URL:            http://www.dokuwiki.org/plugin:tag
12 Requires:       dokuwiki >= 20070626
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         dokuconf        /etc/webapps/dokuwiki
17 %define         dokudir         /usr/share/dokuwiki
18 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
19
20 %description
21 The Tag Plugin lets you assign category tags to wiki pages. It will
22 display a list of links to the tag pages in the tag namespace
23 specified in the configuration.
24
25 %prep
26 %setup -q -n %{plugin}
27 if [ $(cat VERSION | tr -d -) != %{version} ]; then
28         : %%{version} mismatch, should be: $(cat VERSION | tr -d -)
29         exit 1
30 fi
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{plugindir}
35 cp -a . $RPM_BUILD_ROOT%{plugindir}
36 rm -f $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
37
38 # find locales
39 sh %{SOURCE1} %{name}.lang
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 # force css cache refresh
46 if [ -f %{dokuconf}/local.php ]; then
47         touch %{dokuconf}/local.php
48 fi
49
50 %files -f %{name}.lang
51 %defattr(644,root,root,755)
52 %doc README VERSION
53 %dir %{plugindir}
54 %{plugindir}/*.php
55 %{plugindir}/*.css
56 %{plugindir}/*.js
57 %{plugindir}/conf
58 %{plugindir}/images
59 %{plugindir}/syntax
This page took 0.066313 seconds and 4 git commands to generate.