]> git.pld-linux.org Git - packages/dokuwiki-plugin-tag.git/blob - dokuwiki-plugin-tag.spec
up to 20160116
[packages/dokuwiki-plugin-tag.git] / dokuwiki-plugin-tag.spec
1 %define         plugin          tag
2 Summary:        DokuWiki Tag Plugin
3 Name:           dokuwiki-plugin-%{plugin}
4 Version:        20160116
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        https://github.com/dokufreaks/plugin-tag/archive/39c0568/%{name}-%{version}.tar.gz
9 # Source0-md5:  cc1b3fd8eabd3fbf468d04e1c7e467b5
10 URL:            https://www.dokuwiki.org/plugin:tag
11 Requires:       dokuwiki >= 20131208
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         dokuconf        /etc/webapps/dokuwiki
16 %define         dokudir         /usr/share/dokuwiki
17 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
18 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
19
20 %description
21 The Tag Plugin lets you assign category tags to wiki pages. It will
22 display a list of links to the tag pages in the tag namespace
23 specified in the configuration.
24
25 %prep
26 %setup -qc
27 mv *-%{plugin}-*/* .
28 rm -r _test
29
30 %build
31 version=$(awk '/^date/{print $2}' plugin.info.txt)
32 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
33         : %%{version} mismatch
34 fi
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{plugindir}
39 cp -a . $RPM_BUILD_ROOT%{plugindir}
40 rm $RPM_BUILD_ROOT%{plugindir}/{COPYING,README}
41
42 %find_lang %{name}.lang
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 # force css cache refresh
49 if [ -f %{dokuconf}/local.php ]; then
50         touch %{dokuconf}/local.php
51 fi
52
53 %files -f %{name}.lang
54 %defattr(644,root,root,755)
55 %doc README
56 %dir %{plugindir}
57 %{plugindir}/*.css
58 %{plugindir}/*.js
59 %{plugindir}/*.php
60 %{plugindir}/*.txt
61 %{plugindir}/conf
62 %{plugindir}/images
63 %{plugindir}/syntax
This page took 0.086367 seconds and 4 git commands to generate.