]> git.pld-linux.org Git - packages/dokuwiki-plugin-searchindex.git/blob - dokuwiki-plugin-searchindex.spec
- use php(core) as dependency to require php version
[packages/dokuwiki-plugin-searchindex.git] / dokuwiki-plugin-searchindex.spec
1 %define         plugin          searchindex
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki Searchindex Manager
5 Summary(pl.UTF-8):      Zarządca indeksu wyszukiwania dla DokuWiki
6 Name:           dokuwiki-plugin-%{plugin}
7 Version:        20110502
8 Release:        6
9 License:        GPL v2
10 Group:          Applications/WWW
11 Source0:        http://github.com/splitbrain/dokuwiki-plugin-%{plugin}/zipball/master#/%{plugin}.zip
12 # Source0-md5:  ecf9e27851b6ef33df6e75ce144076a5
13 URL:            http://www.dokuwiki.org/plugin:searchindex
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.520
16 Requires:       dokuwiki >= 20090214
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php(session)
19 Requires:       php-date
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         dokuconf        /etc/webapps/dokuwiki
24 %define         dokudir         /usr/share/dokuwiki
25 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
26 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
27
28 %description
29 This admin plugin allows you to rebuild the index used by the fulltext
30 search. This isn't needed generally as the index builds and updates
31 itself while users browse your wiki. However if you just upgraded,
32 added or removed a lot of files it may be a good idea to cleanup the
33 index.
34
35 This Plugin needs a recent Browser as it makes use of modern
36 JavaScript to carry out multiple tasks in the background (using AJAX).
37
38 %description -l pl.UTF-8
39 Wtyczka administratora pozwalająca przebudować indeks używany przez
40 wyszukiwanie pełnotekstowe. Nie jest niezbędna w ogólnym przypadku,
41 jako że indeks buduje się i uaktualnia sam w czasie przeglądania wiki.
42 Jednakże po uaktualnieniu, dodaniu lub usunięciu wielu plików
43 wyczyszczenie indeksu może być dobrym pomysłem.
44
45 Wtyczka ta wymaga aktualnej przeglądarki, jako że wykorzystuje nową
46 wersję JavaScriptu do wykonywania wielu zadań w tle (z użyciem
47 AJAX-a).
48
49 %prep
50 %setup -qc
51 # for githug urls:
52 mv *-%{plugin}-*/* .
53
54 version=$(awk '/^date/{print $2}' plugin.info.txt)
55 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
56         : %%{version} mismatch
57         exit 1
58 fi
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{plugindir}
63 cp -a . $RPM_BUILD_ROOT%{plugindir}
64 %{__rm} $RPM_BUILD_ROOT%{plugindir}/README
65
66 %find_lang %{name}.lang
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 # force js/css cache refresh
73 if [ -f %{dokuconf}/local.php ]; then
74         touch %{dokuconf}/local.php
75 fi
76
77 %files -f %{name}.lang
78 %defattr(644,root,root,755)
79 %doc README
80 %dir %{plugindir}
81 %{plugindir}/*.css
82 %{plugindir}/*.js
83 %{plugindir}/*.php
84 %{plugindir}/*.txt
This page took 0.05184 seconds and 3 git commands to generate.