]> git.pld-linux.org Git - packages/dokuwiki-plugin-move.git/blob - dokuwiki-plugin-move.spec
New version 2015-10-17 released. Bug fixes and translation updates.
[packages/dokuwiki-plugin-move.git] / dokuwiki-plugin-move.spec
1 %define         plugin          move
2 Summary:        Move pages, media files and namespaces while maintaining the link structure
3 Name:           dokuwiki-plugin-%{plugin}
4 Version:        20151017
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        https://github.com/michitux/dokuwiki-plugin-move/archive/master/%{plugin}-%{version}.tar.gz
9 # Source0-md5:  65d57798bd6059f0c0ab6be5cc0390a6
10 URL:            https://www.dokuwiki.org/plugin:move
11 BuildRequires:  sed >= 4.0
12 BuildRequires:  unzip
13 Requires:       dokuwiki >= 20131208
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         dokuconf        /etc/webapps/dokuwiki
18 %define         dokudir         /usr/share/dokuwiki
19 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
20
21 %description
22 This plugin allows to move pages and namespaces including media files
23 and automatically adjusts all links and media references that point to
24 these pages. Unlike the old pagemove plugin this plugin uses the
25 DokuWiki parser which allows it to correctly identify all links and
26 nothing else.
27
28 Parts of this plugin like some of the translated strings, some parts
29 of the structure of the code and parts of the user interface have been
30 taken from the old pagemove plugin by Gary Owen, Arno Puschmann and
31 Christoph Jähnigen.
32
33 Warning: This plugin does not update ACL rules. For example if you had
34 an ACL rule that read-protected a certain wiki page this rule won't
35 have any effect anymore after moving that page.
36
37 %prep
38 %setup -qc
39 mv dokuwiki-plugin-move-*/* .
40
41 # cleanup backups after patching
42 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
43
44 %build
45 version=$(awk '/^date/{print $2}' plugin.info.txt)
46 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
47         : %%{version} mismatch
48         exit 1
49 fi
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{plugindir}
54 cp -a . $RPM_BUILD_ROOT%{plugindir}
55
56 %{__rm} $RPM_BUILD_ROOT%{plugindir}/README
57 %{__rm} -r $RPM_BUILD_ROOT%{plugindir}/_test
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README
65 %dir %{plugindir}
66 %{plugindir}/*.js
67 %{plugindir}/*.less
68 %{plugindir}/*.txt
69 %{plugindir}/action
70 %{plugindir}/admin
71 %{plugindir}/conf
72 %{plugindir}/helper
73 %{plugindir}/images
74 %{plugindir}/script
75
76 %dir %{plugindir}/lang
77 %{plugindir}/lang/en
78 %lang(cs) %{plugindir}/lang/cs
79 %lang(de) %{plugindir}/lang/de
80 %lang(es) %{plugindir}/lang/es
81 %lang(fr) %{plugindir}/lang/fr
82 %lang(it) %{plugindir}/lang/it
83 %lang(ja) %{plugindir}/lang/ja
84 %lang(ko) %{plugindir}/lang/ko
85 %lang(lv) %{plugindir}/lang/lv
86 %lang(nl) %{plugindir}/lang/nl
87 %lang(no) %{plugindir}/lang/no
88 %lang(pl) %{plugindir}/lang/pl
89 %lang(ru) %{plugindir}/lang/ru
90 %lang(sl) %{plugindir}/lang/sl
91 %lang(sv) %{plugindir}/lang/sv
92 %lang(zh_CN) %{plugindir}/lang/zh
This page took 0.058253 seconds and 3 git commands to generate.