]> git.pld-linux.org Git - packages/dokuwiki-plugin-icalevents.git/blob - dokuwiki-plugin-icalevents.spec
- reset error state when fetching next calendar
[packages/dokuwiki-plugin-icalevents.git] / dokuwiki-plugin-icalevents.spec
1 %define         plugin  iCalEvents
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Parses an iCal calendar .ics file and renders it as an HTML table
5 Name:           dokuwiki-plugin-icalevents
6 Version:        20100501
7 Release:        0.6
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        http://public.doogie.de/projects/dokuwiki/plugin_iCalEvents_2.0.zip
11 # Source0-md5:  abef6798132ba03b74afd72ea62678ca
12 URL:            http://www.dokuwiki.org/plugin:icalevents
13 Patch0:         dformat.patch
14 Patch1:         reset-error.patch
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.553
17 Requires:       dokuwiki >= 20080505
18 Requires:       php-common >= 4:%{php_min_version}
19 Requires:       php-date
20 Requires:       php-pcre
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         dokuconf        /etc/webapps/dokuwiki
25 %define         dokudir         /usr/share/dokuwiki
26 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
27 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
28
29 %description
30 Many calendars can export their entries in the iCalendar (RFC 2445)
31 format. This plugin can read such an *.ics file from an URL, parse it
32 and display upcoming events as an HTML table.
33
34 %prep
35 %setup -qc
36 mv iCalEvents/* .
37 %undos -f php
38 %patch0 -p1
39 %patch1 -p1
40
41 version=$(awk -F"'" '/date/&&/=>/{print $4}' syntax.php)
42 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
43         : %%{version} mismatch
44 #       exit 1
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{plugindir}
50 cp -a . $RPM_BUILD_ROOT%{plugindir}
51
52 %find_lang %{name}.lang
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files -f %{name}.lang
58 %defattr(644,root,root,755)
59 %dir %{plugindir}
60 %{plugindir}/*.php
61 %{plugindir}/conf
This page took 0.096393 seconds and 3 git commands to generate.