]> git.pld-linux.org Git - packages/dokuwiki-plugin-comment.git/blob - dokuwiki-plugin-comment.spec
- new
[packages/dokuwiki-plugin-comment.git] / dokuwiki-plugin-comment.spec
1 %define         plugin          comment
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki plugin to add Add comments/notes to your wiki source
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        20090206
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        https://github.com/dokufreaks/plugin-comment/tarball/2009-02-06/%{plugin}-%{version}.tgz
11 # Source0-md5:  aded94aa800d880bf48a0f135ccc34a6
12 URL:            http://www.dokuwiki.org/plugin:comment
13 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
14 BuildRequires:  rpmbuild(macros) >= 1.520
15 Requires:       dokuwiki >= 20061106
16 Requires:       php-common >= 4:%{php_min_version}
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         dokuconf        /etc/webapps/dokuwiki
21 %define         dokudir         /usr/share/dokuwiki
22 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
23
24 %description
25 This tiny plugin allows you to leave notes to yourself (and other
26 authors of your wiki) in the wiki source code that won't be shown on
27 the wiki page. The syntax is like C and PHP.
28
29 %prep
30 %setup -qc
31 mv *-%{plugin}-*/* .
32
33 version=$(cat VERSION)
34 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
35         : %%{version} mismatch
36         exit 1
37 fi
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{plugindir}
42 cp -a . $RPM_BUILD_ROOT%{plugindir}
43 %{__rm} $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README
51 %dir %{plugindir}
52 %{plugindir}/*.php
This page took 0.053377 seconds and 3 git commands to generate.