]> git.pld-linux.org Git - packages/docutils.git/blob - docutils.spec
- rel 3; 2to3 from 3.3
[packages/docutils.git] / docutils.spec
1 Summary:        Documentation Utilities
2 Summary(pl.UTF-8):      Narzędzia do tworzenia dokumentacji
3 Name:           docutils
4 Version:        0.8.1
5 Release:        3
6 License:        Public Domain, BSD, GPL (see COPYING.txt)
7 Group:          Development/Tools
8 Source0:        http://downloads.sourceforge.net/docutils/%{name}-%{version}.tar.gz
9 # Source0-md5:  2ecf8ba3ece1be1ed666150a80c838c8
10 URL:            http://docutils.sourceforge.net/
11 BuildRequires:  python-devel >= 2.3
12 BuildRequires:  python3-2to3 >= 3.3
13 BuildRequires:  python3-2to3 < 3.4
14 BuildRequires:  python3-devel >= 3.3
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.219
17 Requires:       python-%{name} = %{version}-%{release}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Utilities for general- and special-purpose documentation, including
23 autodocumentation of Python modules. Includes reStructuredText, the
24 easy to read, easy to use, what-you-see-is-what-you-get plaintext
25 markup language.
26
27 %description -l pl.UTF-8
28 Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
29 autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
30 do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
31
32 %package -n python-%{name}
33 Summary:        Text documents processing modules for Python 2.x
34 Summary(pl.UTF-8):      Moduły Pythona 2.x do przetwarzania dokumentów tekstowych
35 Group:          Development/Languages/Python
36 %pyrequires_eq  python-libs
37
38 %description -n python-%{name}
39 Docutils are utilities for general- and special-purpose documentation,
40 including autodocumentation of Python modules. Includes
41 reStructuredText, the easy to read, easy to use,
42 what-you-see-is-what-you-get plaintext markup language.
43
44 This package provides the Docutils modules for Python 2.
45
46 %description -n python-%{name} -l pl.UTF-8
47 Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
48 autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
49 do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
50
51 Ten pakiet dostarcza moduły Docutils dla Pythona 2.
52
53 %package -n python3-%{name}
54 Summary:        Text documents processing modules for Python 3.x
55 Summary(pl.UTF-8):      Moduły Pythona 3.x do przetwarzania dokumentów tekstowych
56 Group:          Development/Languages/Python
57
58 %description -n python3-%{name}
59 Docutils are utilities for general- and special-purpose documentation,
60 including autodocumentation of Python modules. Includes
61 reStructuredText, the easy to read, easy to use,
62 what-you-see-is-what-you-get plaintext markup language.
63
64 This package provides the Docutils modules for Python 3.
65
66 %description -n python3-%{name} -l pl.UTF-8
67 Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
68 autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
69 do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
70
71 Ten pakiet dostarcza moduły Docutils dla Pythona 3.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__python} setup.py config build -b build-2
78 %{__python3} setup.py config build -b build-3
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__python} setup.py build -b build-2 install \
84         --optimize=2 \
85         --root=$RPM_BUILD_ROOT
86
87 for f in $RPM_BUILD_ROOT%{_bindir}/*.py ; do
88         mv "${f}" "${f%.py}"
89 done
90
91 %{__python3} setup.py build -b build-3 install \
92         --optimize=2 \
93         --root=$RPM_BUILD_ROOT
94
95 for f in $RPM_BUILD_ROOT%{_bindir}/*.py ; do
96         mv "${f}" "${f%.py}-3"
97 done
98
99 install extras/roman.py $RPM_BUILD_ROOT%{py_sitescriptdir}
100 install extras/roman.py $RPM_BUILD_ROOT%{py3_sitescriptdir}
101 2to3-3.3 -n -w $RPM_BUILD_ROOT%{py3_sitescriptdir}/roman.py
102 # clean some 2to3 leftovers
103 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/{test,tools}
104
105 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
106 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
107 %py_postclean
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc PKG-INFO *.txt docs
115 %attr(755,root,root) %{_bindir}/rst2html
116 %attr(755,root,root) %{_bindir}/rst2latex
117 %attr(755,root,root) %{_bindir}/rst2man
118 %attr(755,root,root) %{_bindir}/rst2odt
119 %attr(755,root,root) %{_bindir}/rst2odt_prepstyles
120 %attr(755,root,root) %{_bindir}/rst2pseudoxml
121 %attr(755,root,root) %{_bindir}/rst2s5
122 %attr(755,root,root) %{_bindir}/rst2xetex
123 %attr(755,root,root) %{_bindir}/rst2xml
124 %attr(755,root,root) %{_bindir}/rstpep2html
125
126 %files -n python-%{name}
127 %defattr(644,root,root,755)
128 %{py_sitescriptdir}/roman.py[oc]
129 %{py_sitescriptdir}/docutils
130 %{py_sitescriptdir}/docutils-%{version}-py*.egg-info
131
132 %files -n python3-%{name}
133 %defattr(644,root,root,755)
134 %{py3_sitescriptdir}/roman.py
135 %{py3_sitescriptdir}/__pycache__/roman.cpython-*.py[co]
136 %{py3_sitescriptdir}/docutils
137 %{py3_sitescriptdir}/docutils-%{version}-py*.egg-info
This page took 0.080288 seconds and 3 git commands to generate.