]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
add initscript for docker daemon
[packages/docker.git] / lxc-docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Docker: the Linux container engine
6 Name:           lxc-docker
7 Version:        0.6.1
8 Release:        3
9 License:        Apache v2.0
10 Group:          Applications/System
11 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
12 # Source0-md5:  487262eae6627971e9181886d65fae1a
13 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
15 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
17 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
19 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
20 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
21 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
23 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24 Source5:        go.net.tar.bz2
25 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
26 Source6:        %{name}.init
27 Patch0:         bash-comp-2.patch
28 URL:            http://github.com/dotcloud/docker
29 BuildRequires:  golang >= 1.1
30 BuildRequires:  rpmbuild(macros) >= 1.228
31 Requires:       iptables
32 Requires:       lxc
33 Requires:       rc-scripts >= 0.4.0.10
34 Requires:       tar
35 Requires:       uname(release) >= 3.8
36 Requires:       xz
37 Requires(post,preun):   /sbin/chkconfig
38 # only runs on x64 hosts for now:
39 # https://github.com/dotcloud/docker/issues/136
40 # https://github.com/dotcloud/docker/issues/611
41 ExclusiveArch:  %{x8664}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         bash_compdir    %{_datadir}/bash-completion/completions
45
46 # binary stripped or something
47 %define         _enable_debug_packages 0
48
49 %description
50 Docker complements LXC with a high-level API which operates at the
51 process level. It runs unix processes with strong guarantees of
52 isolation and repeatability across servers.
53
54 Docker is a great building block for automating distributed systems:
55 large-scale web deployments, database clusters, continuous deployment
56 systems, private PaaS, service-oriented architectures, etc.
57
58 %package -n bash-completion-lxc-docker
59 Summary:        bash-completion for Docker
60 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
61 Group:          Applications/Shells
62 Requires:       %{name}
63 Requires:       bash-completion >= 2.0
64 %if "%{_rpmversion}" >= "5"
65 BuildArch:      noarch
66 %endif
67
68 %description -n bash-completion-lxc-docker
69 This package provides bash-completion for Docker.
70
71 %description -n bash-completion-lxc-docker -l pl.UTF-8
72 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
73
74 %prep
75 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
76 cp -p %{SOURCE100} .
77 %patch0 -p1
78
79 # handle external deps offline, these are taken from Dockerfile
80 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
81 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
82 mv context-master .gopath/src/github.com/gorilla/context
83 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
84 mv mux-master .gopath/src/github.com/gorilla/mux
85 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
86 mv pty-master .gopath/src/github.com/kr/pty
87 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
88 mv tar-master .gopath/src/github.com/dotcloud/tar
89 # PKG=code.google.com/p/go.net/
90 install -d .gopath/src/code.google.com/p
91 mv go.net .gopath/src/code.google.com/p/go.net
92
93 %build
94 # avoid interfering with builder env
95 unset GIT_WORK_TREE
96 unset GIT_DIR
97 %{__make} VERBOSE=1
98
99 %if %{with tests}
100 %{__make} test
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,/var/lib/docker/{containers,graph,volumes}}
106 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
107 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc-docker
108 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
109 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
110
111 # bash completion
112 install -d $RPM_BUILD_ROOT%{bash_compdir}
113 cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
114 ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
115
116 %post
117 /sbin/chkconfig --add %{name}
118 %service -n %{name} restart
119
120 %preun
121 if [ "$1" = "0" ]; then
122         %service -q %{name} stop
123         /sbin/chkconfig --del %{name}
124 fi
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
132 %attr(754,root,root) /etc/rc.d/init.d/lxc-docker
133 %attr(755,root,root) %{_bindir}/lxc-docker
134 %attr(755,root,root) %{_bindir}/docker
135 %{_mandir}/man1/lxc-docker.1*
136 %dir %attr(700,root,root) /var/lib/docker
137 %dir %attr(700,root,root) /var/lib/docker/containers
138 %dir %attr(700,root,root) /var/lib/docker/graph
139 %dir %attr(700,root,root) /var/lib/docker/volumes
140
141 %files -n bash-completion-lxc-docker
142 %defattr(644,root,root,755)
143 %{bash_compdir}/lxc-docker
144 %{bash_compdir}/docker
This page took 0.082395 seconds and 4 git commands to generate.