]> git.pld-linux.org Git - packages/docker.git/blame - lxc-docker.spec
add initscript for docker daemon
[packages/docker.git] / lxc-docker.spec
CommitLineData
a73bca1d
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
b2c07037 4
b877f7b7
ER
5Summary: Docker: the Linux container engine
6Name: lxc-docker
b2c07037 7Version: 0.6.1
345101bd 8Release: 3
b877f7b7
ER
9License: Apache v2.0
10Group: Applications/System
11Source0: https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
b2c07037 12# Source0-md5: 487262eae6627971e9181886d65fae1a
3f5ee638
ER
13Source100: https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14# Source100-md5: 44cc86a37fc5dfe59596076d346da20d
a0edb644
ER
15Source1: https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16# Source1-md5: 621f599f7a49f56ca89c25a6d01ecc3a
17Source2: https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18# Source2-md5: e908c7da6b4b8b61b4733d4a348f015c
19Source3: https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
b2c07037 20# Source3-md5: ffdcacc582c7b6404e71c2dce638869e
3f5ee638
ER
21Source4: https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22# Source4-md5: 7458ecaa777e56d124b61638d597b37f
23# $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24Source5: go.net.tar.bz2
25# Source5-md5: c8fd9d068430ddfa42d28d4772260eda
345101bd 26Source6: %{name}.init
d2670441 27Patch0: bash-comp-2.patch
b877f7b7 28URL: http://github.com/dotcloud/docker
cc7690e4 29BuildRequires: golang >= 1.1
345101bd 30BuildRequires: rpmbuild(macros) >= 1.228
b5920dfc 31Requires: iptables
2015cb19 32Requires: lxc
345101bd 33Requires: rc-scripts >= 0.4.0.10
db150373 34Requires: tar
2015cb19 35Requires: uname(release) >= 3.8
db150373 36Requires: xz
345101bd 37Requires(post,preun): /sbin/chkconfig
d2670441
ER
38# only runs on x64 hosts for now:
39# https://github.com/dotcloud/docker/issues/136
40# https://github.com/dotcloud/docker/issues/611
345101bd 41ExclusiveArch: %{x8664}
b877f7b7
ER
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
8c352669
ER
44%define bash_compdir %{_datadir}/bash-completion/completions
45
434d66d3
ER
46# binary stripped or something
47%define _enable_debug_packages 0
48
b877f7b7
ER
49%description
50Docker complements LXC with a high-level API which operates at the
51process level. It runs unix processes with strong guarantees of
52isolation and repeatability across servers.
53
54Docker is a great building block for automating distributed systems:
55large-scale web deployments, database clusters, continuous deployment
56systems, private PaaS, service-oriented architectures, etc.
57
8c352669
ER
58%package -n bash-completion-lxc-docker
59Summary: bash-completion for Docker
60Summary(pl.UTF-8): bashowe uzupełnianie nazw dla Dockera
61Group: Applications/Shells
62Requires: %{name}
63Requires: bash-completion >= 2.0
64%if "%{_rpmversion}" >= "5"
65BuildArch: noarch
66%endif
67
68%description -n bash-completion-lxc-docker
69This package provides bash-completion for Docker.
70
71%description -n bash-completion-lxc-docker -l pl.UTF-8
72Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
73
b877f7b7 74%prep
3f5ee638
ER
75%setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
76cp -p %{SOURCE100} .
044682ca 77%patch0 -p1
a0edb644 78
3f5ee638
ER
79# handle external deps offline, these are taken from Dockerfile
80install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
a0edb644
ER
81# git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
82mv context-master .gopath/src/github.com/gorilla/context
83# git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
84mv mux-master .gopath/src/github.com/gorilla/mux
85# git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
86mv pty-master .gopath/src/github.com/kr/pty
3f5ee638
ER
87# git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
88mv tar-master .gopath/src/github.com/dotcloud/tar
89# PKG=code.google.com/p/go.net/
90install -d .gopath/src/code.google.com/p
91mv go.net .gopath/src/code.google.com/p/go.net
b877f7b7
ER
92
93%build
a0edb644
ER
94# avoid interfering with builder env
95unset GIT_WORK_TREE
96unset GIT_DIR
b877f7b7
ER
97%{__make} VERBOSE=1
98
a73bca1d
ER
99%if %{with tests}
100%{__make} test
101%endif
102
b877f7b7
ER
103%install
104rm -rf $RPM_BUILD_ROOT
345101bd 105install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,/var/lib/docker/{containers,graph,volumes}}
b877f7b7 106install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
345101bd 107install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc-docker
9c77b76c 108ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
b877f7b7
ER
109cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
110
8c352669
ER
111# bash completion
112install -d $RPM_BUILD_ROOT%{bash_compdir}
113cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
114ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
115
345101bd
ER
116%post
117/sbin/chkconfig --add %{name}
118%service -n %{name} restart
119
120%preun
121if [ "$1" = "0" ]; then
122 %service -q %{name} stop
123 /sbin/chkconfig --del %{name}
124fi
125
b877f7b7
ER
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%files
130%defattr(644,root,root,755)
131%doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
345101bd 132%attr(754,root,root) /etc/rc.d/init.d/lxc-docker
b877f7b7 133%attr(755,root,root) %{_bindir}/lxc-docker
9c77b76c 134%attr(755,root,root) %{_bindir}/docker
b877f7b7 135%{_mandir}/man1/lxc-docker.1*
af991618
ER
136%dir %attr(700,root,root) /var/lib/docker
137%dir %attr(700,root,root) /var/lib/docker/containers
138%dir %attr(700,root,root) /var/lib/docker/graph
139%dir %attr(700,root,root) /var/lib/docker/volumes
8c352669
ER
140
141%files -n bash-completion-lxc-docker
142%defattr(644,root,root,755)
143%{bash_compdir}/lxc-docker
144%{bash_compdir}/docker
This page took 0.0579 seconds and 4 git commands to generate.