]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
up to 0.6.0
[packages/docker.git] / lxc-docker.spec
1 Summary:        Docker: the Linux container engine
2 Name:           lxc-docker
3 Version:        0.6.0
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
8 # Source0-md5:  1aedc1fcbb743cd44330a54334db221e
9 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
10 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
11 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
12 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
13 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
14 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
15 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
16 # Source3-md5:        ffdcacc582c7b6404e71c2dce638869e
17 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
18 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
19 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
20 Source5:        go.net.tar.bz2
21 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
22 URL:            http://github.com/dotcloud/docker
23 BuildRequires:  git-core
24 BuildRequires:  golang >= 1.1
25 Requires:       iptables
26 Requires:       lxc
27 Requires:       uname(release) >= 3.8
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # binary stripped or something
31 %define         _enable_debug_packages 0
32
33 %description
34 Docker complements LXC with a high-level API which operates at the
35 process level. It runs unix processes with strong guarantees of
36 isolation and repeatability across servers.
37
38 Docker is a great building block for automating distributed systems:
39 large-scale web deployments, database clusters, continuous deployment
40 systems, private PaaS, service-oriented architectures, etc.
41
42 %prep
43 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
44 cp -p %{SOURCE100} .
45
46 # handle external deps offline, these are taken from Dockerfile
47 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
48 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
49 mv context-master .gopath/src/github.com/gorilla/context
50 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
51 mv mux-master .gopath/src/github.com/gorilla/mux
52 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
53 mv pty-master .gopath/src/github.com/kr/pty
54 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
55 mv tar-master .gopath/src/github.com/dotcloud/tar
56 # PKG=code.google.com/p/go.net/
57 install -d .gopath/src/code.google.com/p
58 mv go.net .gopath/src/code.google.com/p/go.net
59
60 %build
61 # avoid interfering with builder env
62 unset GIT_WORK_TREE
63 unset GIT_DIR
64 %{__make} VERBOSE=1
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
69 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
70 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
71 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
79 %attr(755,root,root) %{_bindir}/lxc-docker
80 %attr(755,root,root) %{_bindir}/docker
81 %{_mandir}/man1/lxc-docker.1*
82 %dir %attr(700,root,root) /var/lib/docker
83 %dir %attr(700,root,root) /var/lib/docker/containers
84 %dir %attr(700,root,root) /var/lib/docker/graph
85 %dir %attr(700,root,root) /var/lib/docker/volumes
This page took 0.051306 seconds and 3 git commands to generate.