]> git.pld-linux.org Git - packages/docker.git/blame - lxc-docker.spec
up to 0.6.0
[packages/docker.git] / lxc-docker.spec
CommitLineData
b877f7b7
ER
1Summary: Docker: the Linux container engine
2Name: lxc-docker
3f5ee638 3Version: 0.6.0
a30f3ec3 4Release: 1
b877f7b7
ER
5License: Apache v2.0
6Group: Applications/System
7Source0: https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
3f5ee638
ER
8# Source0-md5: 1aedc1fcbb743cd44330a54334db221e
9Source100: https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
10# Source100-md5: 44cc86a37fc5dfe59596076d346da20d
a0edb644
ER
11Source1: https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
12# Source1-md5: 621f599f7a49f56ca89c25a6d01ecc3a
13Source2: https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
14# Source2-md5: e908c7da6b4b8b61b4733d4a348f015c
15Source3: https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
3f5ee638
ER
16# Source3-md5: ffdcacc582c7b6404e71c2dce638869e
17Source4: https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
18# Source4-md5: 7458ecaa777e56d124b61638d597b37f
19# $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
20Source5: go.net.tar.bz2
21# Source5-md5: c8fd9d068430ddfa42d28d4772260eda
b877f7b7 22URL: http://github.com/dotcloud/docker
a0edb644 23BuildRequires: git-core
cc7690e4 24BuildRequires: golang >= 1.1
b5920dfc 25Requires: iptables
2015cb19
ER
26Requires: lxc
27Requires: uname(release) >= 3.8
b877f7b7
ER
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
434d66d3
ER
30# binary stripped or something
31%define _enable_debug_packages 0
32
b877f7b7
ER
33%description
34Docker complements LXC with a high-level API which operates at the
35process level. It runs unix processes with strong guarantees of
36isolation and repeatability across servers.
37
38Docker is a great building block for automating distributed systems:
39large-scale web deployments, database clusters, continuous deployment
40systems, private PaaS, service-oriented architectures, etc.
41
42%prep
3f5ee638
ER
43%setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
44cp -p %{SOURCE100} .
a0edb644 45
3f5ee638
ER
46# handle external deps offline, these are taken from Dockerfile
47install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
a0edb644
ER
48# git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
49mv context-master .gopath/src/github.com/gorilla/context
50# git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
51mv mux-master .gopath/src/github.com/gorilla/mux
52# git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
53mv pty-master .gopath/src/github.com/kr/pty
3f5ee638
ER
54# git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
55mv tar-master .gopath/src/github.com/dotcloud/tar
56# PKG=code.google.com/p/go.net/
57install -d .gopath/src/code.google.com/p
58mv go.net .gopath/src/code.google.com/p/go.net
b877f7b7
ER
59
60%build
a0edb644
ER
61# avoid interfering with builder env
62unset GIT_WORK_TREE
63unset GIT_DIR
b877f7b7
ER
64%{__make} VERBOSE=1
65
66%install
67rm -rf $RPM_BUILD_ROOT
af991618 68install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
b877f7b7 69install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
9c77b76c 70ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
b877f7b7
ER
71cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
79%attr(755,root,root) %{_bindir}/lxc-docker
9c77b76c 80%attr(755,root,root) %{_bindir}/docker
b877f7b7 81%{_mandir}/man1/lxc-docker.1*
af991618
ER
82%dir %attr(700,root,root) /var/lib/docker
83%dir %attr(700,root,root) /var/lib/docker/containers
84%dir %attr(700,root,root) /var/lib/docker/graph
85%dir %attr(700,root,root) /var/lib/docker/volumes
This page took 0.088718 seconds and 4 git commands to generate.