]> git.pld-linux.org Git - packages/dnssec-tools.git/blob - dnssec-tools.spec
- build and package qt GUIs (dnssec-check, dnssec-nodes, dnssec-system-tray, lookup)
[packages/dnssec-tools.git] / dnssec-tools.spec
1 #
2 # Conditional build:
3 %bcond_without  qt      # Qt-based GUI tools
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        DNSSEC tools
7 Summary(pl.UTF-8):      Narzędzia DNSSEC
8 Name:           dnssec-tools
9 Version:        1.13
10 Release:        1
11 License:        BSD
12 Group:          Applications/Networking
13 Source0:        http://www.dnssec-tools.org/download/%{name}-%{version}.tar.gz
14 # Source0-md5:  beb4d59c49a00799ec1dfbbd5c97a8a0
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-qt.patch
17 URL:            http://www.dnssec-tools.org/
18 BuildRequires:  openssl-devel
19 BuildRequires:  perl-ExtUtils-MakeMaker
20 BuildRequires:  perl-Net-DNS
21 BuildRequires:  perl-Net-DNS-SEC
22 BuildRequires:  perl-TimeDate
23 BuildRequires:  perl-base
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %if %{with qt}
27 BuildRequires:  QtCore-devel >= 4
28 BuildRequires:  QtDeclarative-devel >= 4
29 BuildRequires:  QtGui-devel >= 4
30 BuildRequires:  QtNetwork-devel >= 4
31 BuildRequires:  QtSvg-devel >= 4
32 BuildRequires:  QtXml-devel >= 4
33 BuildRequires:  qt4-qmake >= 4
34 %endif
35 Requires:       %{name}-libs = %{version}-%{release}
36 Requires:       perl-%{name} = %{version}-%{release}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The goal of the DNSSEC-Tools project is to create a set of tools,
41 patches, applications, wrappers, extensions, and plugins that will
42 help ease the deployment of DNSSEC-related technologies.
43
44 %description -l pl.UTF-8
45 Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
46 aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
47 technologii związanych z DNSSEC.
48
49 %package gui
50 Summary:        DNSSEC tools with GUI
51 Summary(pl.UTF-8):      Narzędzia DNSSEC z GUI
52 Group:          X11/Applications
53 Requires:       %{name}-libs = %{version}-%{release}
54
55 %description gui
56 DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
57 dnssec-system-tray and lookup.
58
59 %description gui -l pl.UTF-8
60 Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
61 dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
62
63 %package libs
64 Summary:        DNSSEC libraries
65 Summary(pl.UTF-8):      Biblioteki DNSSEC
66 Group:          Libraries
67
68 %description libs
69 DNSSEC libraries.
70
71 %description libs -l pl.UTF-8
72 Biblioteki DNSSEC.
73
74 %package devel
75 Summary:        Header files for DNSSEC libraries
76 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNSSEC
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79 Requires:       openssl-devel
80
81 %description devel
82 Header files for DNSSEC libraries.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe bibliotek DNSSEC.
86
87 %package static
88 Summary:        Static DNSSEC libraries
89 Summary(pl.UTF-8):      Statyczne biblioteki DNSSEC
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static DNSSEC libraries.
95
96 %description static -l pl.UTF-8
97 Statyczne biblioteki DNSSEC.
98
99 %package -n perl-%{name}
100 Summary:        Perl modules supporting DNSSEC
101 Summary(pl.UTF-8):      Moduły Perla wspierające DNSSEC
102 Group:          Development/Languages/Perl
103 Requires:       %{name}-libs = %{version}-%{release}
104 Requires:       perl-Net-DNS
105 Requires:       perl-Net-DNS-SEC
106
107 %description -n perl-%{name}
108 Perl modules supporting DNSSEC.
109
110 %description -n perl-%{name} -l pl.UTF-8
111 Moduły Perla wspierające DNSSEC.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117
118 %build
119 %configure \
120         --disable-bind-checks \
121         --with-dlv \
122         --with-ipv6 \
123         --with-nsec3 \
124         --with-perl-build-args='INSTALLDIRS=vendor'
125 %{__make}
126
127 %if %{with qt}
128 cd validator/apps
129 for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
130         cd $d
131         qmake-qt4 \
132                 QMAKE_CXX="%{__cxx}" \
133                 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
134                 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
135         %{__make}
136         cd ..
137 done
138 %endif
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 %{__make} -j1 install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %if %{with qt}
146 for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
147         %{__make} install -C validator/apps/$d \
148                 INSTALL_ROOT=$RPM_BUILD_ROOT
149 done
150 %endif
151
152 find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
153 # bugfix
154 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{dt-,}libval_check_conf.1
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   libs -p /sbin/ldconfig
160 %postun libs -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc COPYING ChangeLog NEWS README
165 %attr(755,root,root) %{_bindir}/blinkenlights
166 %attr(755,root,root) %{_bindir}/bubbles
167 %attr(755,root,root) %{_bindir}/buildrealms
168 %attr(755,root,root) %{_bindir}/check-zone-expiration
169 %attr(755,root,root) %{_bindir}/cleanarch
170 %attr(755,root,root) %{_bindir}/cleankrf
171 %attr(755,root,root) %{_bindir}/convertar
172 %attr(755,root,root) %{_bindir}/dnspktflow
173 %attr(755,root,root) %{_bindir}/donuts
174 %attr(755,root,root) %{_bindir}/donutsd
175 %attr(755,root,root) %{_bindir}/drawvalmap
176 %attr(755,root,root) %{_bindir}/dt-getaddr
177 %attr(755,root,root) %{_bindir}/dt-gethost
178 %attr(755,root,root) %{_bindir}/dt-getname
179 %attr(755,root,root) %{_bindir}/dt-getquery
180 %attr(755,root,root) %{_bindir}/dt-getrrset
181 %attr(755,root,root) %{_bindir}/dt-validate
182 %attr(755,root,root) %{_bindir}/dtck
183 %attr(755,root,root) %{_bindir}/dtconf
184 %attr(755,root,root) %{_bindir}/dtconfchk
185 %attr(755,root,root) %{_bindir}/dtdefs
186 %attr(755,root,root) %{_bindir}/dtinitconf
187 %attr(755,root,root) %{_bindir}/dtrealms
188 %attr(755,root,root) %{_bindir}/expchk
189 %attr(755,root,root) %{_bindir}/fixkrf
190 %attr(755,root,root) %{_bindir}/genkrf
191 %attr(755,root,root) %{_bindir}/getdnskeys
192 %attr(755,root,root) %{_bindir}/getds
193 %attr(755,root,root) %{_bindir}/grandvizier
194 %attr(755,root,root) %{_bindir}/keyarch
195 %attr(755,root,root) %{_bindir}/keymod
196 %attr(755,root,root) %{_bindir}/krfcheck
197 %attr(755,root,root) %{_bindir}/libval_check_conf
198 %attr(755,root,root) %{_bindir}/lights
199 %attr(755,root,root) %{_bindir}/lsdnssec
200 %attr(755,root,root) %{_bindir}/lskrf
201 %attr(755,root,root) %{_bindir}/lsrealm
202 %attr(755,root,root) %{_bindir}/lsroll
203 %attr(755,root,root) %{_bindir}/maketestzone
204 %attr(755,root,root) %{_bindir}/mapper
205 %attr(755,root,root) %{_bindir}/realmchk
206 %attr(755,root,root) %{_bindir}/realmctl
207 %attr(755,root,root) %{_bindir}/realminit
208 %attr(755,root,root) %{_bindir}/realmset
209 %attr(755,root,root) %{_bindir}/rollchk
210 %attr(755,root,root) %{_bindir}/rollctl
211 %attr(755,root,root) %{_bindir}/rollerd
212 %attr(755,root,root) %{_bindir}/rollinit
213 %attr(755,root,root) %{_bindir}/rolllog
214 %attr(755,root,root) %{_bindir}/rollrec-editor
215 %attr(755,root,root) %{_bindir}/rollset
216 %attr(755,root,root) %{_bindir}/signset-editor
217 %attr(755,root,root) %{_bindir}/tachk
218 %attr(755,root,root) %{_bindir}/timetrans
219 %attr(755,root,root) %{_bindir}/trustman
220 %attr(755,root,root) %{_bindir}/zonesigner
221 %dir %{_sysconfdir}/dnssec-tools
222 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
223 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
224 %{_datadir}/%{name}
225 %{_mandir}/man1/blinkenlights.1p*
226 %{_mandir}/man1/buildrealms.1p*
227 %{_mandir}/man1/bubbles.1p*
228 %{_mandir}/man1/check-zone-expiration.1p*
229 %{_mandir}/man1/cleanarch.1p*
230 %{_mandir}/man1/cleankrf.1p*
231 %{_mandir}/man1/convertar.1p*
232 %{_mandir}/man1/dnspktflow.1p*
233 %{_mandir}/man1/dnssec-tools.1*
234 %{_mandir}/man1/donuts.1p*
235 %{_mandir}/man1/donutsd.1p*
236 %{_mandir}/man1/drawvalmap.1p*
237 %{_mandir}/man1/dt-getaddr.1*
238 %{_mandir}/man1/dt-gethost.1*
239 %{_mandir}/man1/dt-getname.1*
240 %{_mandir}/man1/dt-getquery.1*
241 %{_mandir}/man1/dt-getrrset.1*
242 %{_mandir}/man1/dt-validate.1*
243 %{_mandir}/man1/dtck.1p*
244 %{_mandir}/man1/dtconf.1p*
245 %{_mandir}/man1/dtconfchk.1p*
246 %{_mandir}/man1/dtdefs.1p*
247 %{_mandir}/man1/dtinitconf.1p*
248 %{_mandir}/man1/dtrealms.1p*
249 %{_mandir}/man1/expchk.1p*
250 %{_mandir}/man1/fixkrf.1p*
251 %{_mandir}/man1/genkrf.1p*
252 %{_mandir}/man1/getdnskeys.1p*
253 %{_mandir}/man1/getds.1p*
254 %{_mandir}/man1/grandvizier.1p*
255 %{_mandir}/man1/keyarch.1p*
256 %{_mandir}/man1/keymod.1p*
257 %{_mandir}/man1/krfcheck.1p*
258 %{_mandir}/man1/libval_check_conf.1*
259 %{_mandir}/man1/lights.1p*
260 %{_mandir}/man1/lsdnssec.1p*
261 %{_mandir}/man1/lskrf.1p*
262 %{_mandir}/man1/lsrealm.1p*
263 %{_mandir}/man1/lsroll.1p*
264 %{_mandir}/man1/maketestzone.1p*
265 %{_mandir}/man1/mapper.1p*
266 %{_mandir}/man1/realmchk.1p*
267 %{_mandir}/man1/realmctl.1p*
268 %{_mandir}/man1/realminit.1p*
269 %{_mandir}/man1/realmset.1p*
270 %{_mandir}/man1/rollchk.1p*
271 %{_mandir}/man1/rollctl.1p*
272 %{_mandir}/man1/rollerd.1p*
273 %{_mandir}/man1/rollinit.1p*
274 %{_mandir}/man1/rolllog.1p*
275 %{_mandir}/man1/rollrec-editor.1p*
276 %{_mandir}/man1/rollset.1p*
277 %{_mandir}/man1/signset-editor.1p*
278 %{_mandir}/man1/tachk.1p*
279 %{_mandir}/man1/timetrans.1p*
280 %{_mandir}/man1/trustman.1p*
281 %{_mandir}/man1/zonesigner.1p*
282
283 %if %{with qt}
284 %files gui
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_bindir}/dnssec-check
287 %attr(755,root,root) %{_bindir}/dnssec-nodes
288 %attr(755,root,root) %{_bindir}/dnssec-system-tray
289 %attr(755,root,root) %{_bindir}/lookup
290 %{_desktopdir}/dnssec-check.desktop
291 %{_desktopdir}/lookup.desktop
292 %{_iconsdir}/hicolor/48x48/apps/lookup.png
293 %{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
294 %{_pixmapsdir}/lookup.xpm
295 %endif
296
297 %files libs
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_libdir}/libsres.so.*.*.*
300 %attr(755,root,root) %ghost %{_libdir}/libsres.so.12
301 %attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
302 %attr(755,root,root) %ghost %{_libdir}/libval-threads.so.12
303 %attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libval_shim.so.12
305
306 %files devel
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_bindir}/libval-config
309 %attr(755,root,root) %{_libdir}/libsres.so
310 %attr(755,root,root) %{_libdir}/libval-threads.so
311 %attr(755,root,root) %{_libdir}/libval_shim.so
312 %{_libdir}/libsres.la
313 %{_libdir}/libval-threads.la
314 %{_libdir}/libval_shim.la
315 %{_includedir}/validator
316 %{_mandir}/man3/dnsval.conf.3*
317 %{_mandir}/man3/dnsval_conf*.3*
318 %{_mandir}/man3/libsres.3*
319 %{_mandir}/man3/libval.3*
320 %{_mandir}/man3/libval_shim.3*
321 %{_mandir}/man3/p_ac_status.3*
322 %{_mandir}/man3/p_val_status.3*
323 %{_mandir}/man3/resolv_conf_*.3*
324 %{_mandir}/man3/root_hints_*.3*
325 %{_mandir}/man3/val_*.3*
326
327 %files static
328 %defattr(644,root,root,755)
329 %{_libdir}/libsres.a
330 %{_libdir}/libval-threads.a
331 %{_libdir}/libval_shim.a
332
333 %files -n perl-%{name}
334 %defattr(644,root,root,755)
335 %dir %{perl_vendorarch}/Net/DNS/SEC
336 %{perl_vendorarch}/Net/DNS/SEC/Tools
337 %{perl_vendorarch}/Net/DNS/SEC/Validator.pm
338 %{perl_vendorarch}/Net/DNS/SEC/defines.pl
339 %{perl_vendorarch}/Net/DNS/ZoneFile
340 %{perl_vendorarch}/Net/addrinfo.pm
341 %dir %{perl_vendorarch}/auto/Net/DNS/SEC
342 %dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
343 %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.bs
344 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
345 %dir %{perl_vendorarch}/auto/Net/addrinfo
346 %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.bs
347 %attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
348 %{perl_vendorlib}/Net/DNS/SEC/Tools
349 %{_mandir}/man3/Net::DNS::SEC::Tools::*.3pm*
350 %{_mandir}/man3/Net::DNS::SEC::Validator.3pm*
351 %{_mandir}/man3/Net::DNS::ZoneFile::Fast.3pm*
352 %{_mandir}/man3/Net::addrinfo.3pm*
This page took 0.789498 seconds and 3 git commands to generate.